Screen updates very slowly and erroneously in several but not all applications

I have had Lubuntu 20.04 for some time. Today I suddenly got problems when the screen started updating very slowly and erroneously in several but not all applications. I tried to take a screenshot of this behaviour but it turned out to be impossible to capture on screenshots. However I took a picture from my mobile phone (enclosed) that shows how the problem looks like. The screen still updates correctly in some apps, such as Google Chrome, so that makes me think that there is nothing wrong with the hardware.

Please help:)

Thanks in advance.

There’s no need to post duplicates of the same question. We’re volunteers scattered across the globe and across many time zones. If someone can help you, they will help you when they’re online. It’s also not a very busy forum, so your question isn’t going to get missed. All forum participants will see your post.


Something that was brought up in another thread has me wondering about something.

By chance, did this occur after a particular event that you can recall (e.g. updates were applied)?

It might be due to a driver update that happened but we won’t know for sure without some digging.

Can you see if booting with an older kernel results in the same problem behavior?

The simplest way to display your Grub is to press and hold the SHIFT button while booting. Once you see the grub menu, you may see a list of available installed kernels. If you have more than one, please select the one before the current default. The default (latest kernel) is usually at the top of the list if I’m not mistaken and usually highlighted by default. You can try the second from the top and let’s see if the problem happens again.

I didn’t see the updates in the duplicate thread. I think the mods can close this one since the other thread already has some traction going. Please disregard my post. Thanks!


Is this a box you use regularly? ie. daily? A couple of weeks ago the HWE kernel moved from 21.04’s 5.11 kernel, to the kernel from 21.10 or 5.13. The kernel change also mandates kernel modules be changed, ie. drivers change.

The timing of that though doesn’t fit to me; as the change hit most users weeks ago, but it’s still possible… I’d explore the Advanced options at boot (ie. grub menu), and boot using whatever kernels you have installed; and check the issue only occurs with your latest kernel - as that provides a wealth of information & some possible steps needed (raise a bug report and more).

Details such as what graphics kernel module (driver) you’re using would also be helpful, eg. I tend to use the command sudo lshw -C display as I find it easy to remember but inxi -G & others work too.

Yes the working fine in google-chrome is very useful detail. :slight_smile: Alas it’s closed-source nature makes it harder to know what Tk/libs it uses thus isn’t as useful as open-source code is though (you indicate other apps; what were they?)

FYI: If it wasn’t clear; I’d hope using an older kernel when selected from Advanced options (at grub) would resolve the issue for now whilst a reason & fix is looked for. If your machine has only a single OS on it; the grub menu may not show, so you’ll have to make it show using ESC pressed at the end of your machines POST (power-on-self-test).


Thanks for the reply.

I use this box almost daily. It worked fine when I used it yesterday. The problem started today at some point.

Unfortunately I only have and as options in Grup. I have regularily done cleanups of old kernels to save disk space. Booting with did not help.

Output from sudo lshw - C display is as follows:

description: VGA compatible controller
product: HD Graphics 530
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list
configuration: driver=i915 latency=0
resources: irq:127 memory:de000000-deffffff memory:c0000000-cfffffff ioport:f000(size=64) memory:c0000-dffff

Examples of other apps that are working fine are Libreoffice Calc and Libreoffice Writer. Examples of apps that have problems with screen updating are Featherpad, TexStudio and qpdfview.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

I just reinstalled the 5.11.0-46 kernel. It does not boot properly unless I select recovery mode and from recovery mode proceed to a normal boot (how can I fix that by the way?).

However, when running the 5.11.0-46 kernel the screen problem disappears. So now I have a temporary solution to the problem. Yesterday I forgot to mention that I was prompted to do two system upgrades, so that probably upgraded the kernel to 5.13.

So then there seems to be something in the 5.13 kernel that causes the screen problem.

1 Like

The 5.13 kernel works when using recovery mode by the way. Currently all the kernels that I have available only boot in recovery mode. A consequence is that graphically intensive applications run very slowly.

Hi again.

I installed the 5.4.0 kernel and it booted without having to go into recovery mode. However, the same problem with screen updating persisted. Could it be that an update to the video driver in recent weeks or similar has caused this problem? And if yes, how can I roll back to previous versions? Do you have any other ideas to what may cause this problem?

It would be good to solve this problem soon as it is making it difficult for me to do my work on the computer.

Thanks in advance for help.

Hi again.

I have now solved this problem by installing drivers from oibaf.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

Well done for solving it.

Don’t forget the Oibaf drivers will prevent do-release-upgrade (ubuntu-release-upgrader tool) from operating, so when it comes time to upgrade to a newer release; so you’ll need to ppa-purge the Oibaf packages, perform release-upgrade, then re-add them if required.

1 Like