Printing problem with 20.04

I just installed the new 20.04 Lubuntu version and I thought it would fix the mistake from using the beta version. I can print neither to file nor to a printer. I have a libre office writer file which includes a table. The only thing seen on the printout is the frame. I don’t know if you are aware of this do I thought I’ll write you right away.

I’m having the same trouble with any libre office text document. Even if I just wrote “test” and printed it out, I got an empty sheet.

My printer is a Brother DCP9017.

1 Like

Also, if I print the “test” document to file or export it to pdf, I always get an empty sheet.

If you tell the printer to print a test page from within Lubuntu, does that print correctly?

After installing the printer I’m asked to print a test page, which works fine. If I download a picture or pdf file and print it, it works fine. But anything I write on libre office doesn’t. Neither if I export it to pdf nor if I print to file nor if I try to print it out on the printer.

Crazy idea, but if you run SAL_VCL_QT5_USE_CAIRO=true libreoffice --writer and then try, does it do any better?

Just tried it, libre office opened, I tried to open a file and the computer froze. Only a hard reboot worked.

I tried it again without opening a file but just writing the word test and I was able to create a PDF from it and print it

So you could print it on your physical printer, too?

Ok, now it works. Thank you very much!

Yes, everything works now. THANK YOU!!!

I’m surprised it worked, but glad it did.

It doesn’t work anymore after reboot. Do I have to type it in everyone I boot the computer or is there a way for it to keep it?

Am I the only one with that problem? I’ve tried it on a couple of computers and have the same problem on every one.

You would need to change the Exec key in the Desktop Entry file in /usr/share/applications to reflect the new command line.

I’m sorry but I can’t find it there.


I’ve done it but it doesn’t work. Interestingly it only works if I type it into a terminal. I’ve checked the spelling numerous times and rebooted as well.

Include a copy of the aforementioned file with the changes you made and we’ll see what’s up.

I’m not authorized to upload the *.desktop file. I hope the screenshot helps.