Libre Office Editing Problem

Hi guys!

I’m having a problem editing documents in Libre Office Writer. I want to move a picture from the bottom of the document (a doc.x file) to the top, but when I bring up the Right-Click menu something weird happens in the top left of the window - almost like a smaller window or box is trying to open, and when I click on Cut the problem is made worse.

Trying to get screen shots of all this is hard as every mouse click affects the screen. Here are a couple of what it looks like just before I close the window:

screen-2020-09-14-23-39-09

screen-2020-09-14-23-40-16

This also happens when trying to do the similar thing with the PDF version of the document in LO Draw.

I have recently implemented the Printing Fix from this post

but I have no idea if the problem existed before as I hadn’t done very much with the program.

Hopefully someone can help with this.

Many thanks :smiley:

Edit: I’m using Lubuntu 20.04 on an Asus Vivobook , Intel processor.

Hi,

I can confirm that this problem did not exist before fixing the printing issue as I mentioned in my first post. I remembered that I had copied a pattern from a website and pasted it into Writer and edited it with Cut and an image resize.

I’ve just tried to do that again, and it won’t work, I get the same problem happening.

Hope this helps.

Well, no prizes for guessing that it was the printing fix that scuppered my attempts at editing :frowning_face:

I found this post about exporting PDF files, which even has similar screenshots to mine, helpful:

And from this post it seems clear that real problem here is libre office-qt5.

I haven’t tried the suggestion to use

SAL_USE_VCLPLUGIN=kf5

but I have removed the line of code from the desktop file, mentioned in my first post. Editing still isn’t perfect (some of the tool buttons disappear) but at least it works. I just won’t be able to print anything quickly :angry:

Here are some quotes from the Lubuntu home page:

“Your daily operating system”
“…a complete Operating System that ships the essential apps and services for daily use: office applications…”
" Lubuntu now ships the most advanced desktop interface, using Qt technologies…"
Everything works out of the box.

I’m not sure I can agree with all this when you can’t even print a written document without delving into the terminal.

Disappointed. :disappointed:

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.