No authorization after adding user

I installed Lubuntu 20.04 on a stick and added another user “pw_admin” which I want to use if a student forgets his password. I used the preinstalled “Users and Groups”. Then I logged out to log in with the new user to see if I could change the password which I couldn’t. But afterwards I couldn’t even change the password while being logged in as the original user anymore because I was not authorized. I couldn’t even download apps from discover anymore because I wasn’t authorized.
Firstly I thought I messed something up, downloaded the image again and created a new stick. The only thing I did was add an user and tried to change the password which ended in the same result. Everytime I try to add an user I lose all authorization. I even added both users to all groups through the terminal and sudo (even though I know that’s stupid because I really tried ALL groups). But no authorization to do anything.

How can I add an user without losing authorization to do anything?

Btw, I also used chmod to change the rights in the home directories to rwxrwxrwx just for the sake of finding the mistake. Didn’t work either.

I’ve explored this a little.

I created a fresh install on dc7700 of Lubuntu 20.04, logged in as me (guiverc), modified screen layout & checked out box.

I then created a new user “pw_admin” using User Groups and Settings setting the General/Groups/Advanced settings as I felt appropriate.

I logged out, and logged into “pw_admin” and everything was as I expected. I opted to give this user “sudo” access which you may not have done, but I suspect you’re using different groups to what I possibly do.

You didn’t specify how you created your installation on the thumb-drive (mkusb? or install to thumb-drive?), so I’m unsure if that would make a difference; my install was to hdd.

I’ve been unable to re-create your issue sorry, but the only thing that stood out to me as possible issue was the groups that “pw_admin” was given; I wonder if you’re doing something unusual there (I just gave myself groups that I felt appropriate but some knowledge was likely involved in this decision).

I did reboot & try logging in again, no issues.

More specific detail maybe helpful. I had no issues with what I described above, however I thought I’d remove ‘sudo’ rights from ‘pw_admin’ via GUI (logged in as me/guiverc) and I had this error
lxqt-admin-user_usermod_failed_t

I haven’t looked yet on why I got this (yet to exclude user/me mistake as the cause), but is this what you’re describing as “lose all authorization”, or if it’s something else, please provide clear details.

Same results with no sudo rights for ‘pw_admin’.

1 Like

Primarily for documentation purposes:

The error lxqt-admin-user error pop up in my last post appears when

[ 764.849494] traps: lxqt-policykit-[1598] general protection fault ip:7f8c94773671 sp:7ffc5acf6618 error:0 in libgobject-2.0.so.0.6400.2[7f8c94745000+36000]

occurs in dmesg, and in /var/crash/ (it was submitted)
-rw-r----- 1 guiverc whoopsie 3.2M Apr 29 11:37 _usr_bin_lxqt-policykit-agent.1000.crash

so if the error message I captured is your issue, we may have our problem. Anyway this has been filed at lp: 1875774

In the prior post, I removed sudo rights using terminal (sudo vim /etc/group) bypassing the error, and in play so far, the crash seems to occur when removing rights and elevated privileges need to be raised in the GUI, but my exploration thus far has been limited.

1 Like

Yes, that’s exactly the issue. Also, in Discover the following message appears:
screen3
It says that you don’t have authorization for this procedure. All I did was press install.

Here’s what I did step by step:

  1. I installed the image on a USB stick using Disks (which I have also done so in the past with 16.04, 18.04, and 19.10).
  2. After the installation I created the user pw_admin using Users and Groups.
  3. I logged in as pw_admin and tried to change the password of the original user which didn’t work (same screenshot like yours above just passwd in brackets instead of usermod).
  4. I logged back in with the original user to add pw_admin to the group sudo which resulted in your prompt.
  5. Then I noticed that both users were not in their own group anymore (they were beforehand).
  6. I added the users to their groups and the sudo group using the terminal but that didn’t change anything (adding or removing groups resulted in the “Action (usermod) failed” prompt while using the GUI / Discover: you have no authorization for that procedure).
  7. I added the users to each group one by one and changed the rights of the home directories to “rwxrwxrwx”.

Nothing worked though.

1 Like

I’ll create a new USB stick now and add the users to the sudo group right away instead of after logging in as another user.

I just created a new USB live stick. Here’s what I did:

  1. I installed the system with the main user “digitnms” and a short password. (The user is in the sudo group).
  2. Using the GUI “Users and Groups” I added the user “pw_admin” with a short password and added him to the sudo group right away.
  3. I logged out as “digitnms” and back on as “pw_admin”.
  4. I opened the GUI and tried to change the password of “digitnms”. Here’s the result.
    screen
  5. I tried to install an app using Discover but it gave the same prompt as in my post above.

The only way to install apps now is through the terminal. (Applies to each user being logged in)

Now, I have deleted pw_admin through the terminal. Adding to groups with the GUI is possible again just like installing apps using Discover.

I don’t currently have a good solution for you (given I believe it’s a bug, it’ll take time), but I’ll tell you what I’d do.

I’d possibly use that dialog to create users (but not change groups etc), then change details via command, or better yet do it all through commands.

I won’t write a tutorial for it; I’m not a network or system admin (and I’d use vim to change files rather than commands anyway), but there will be many available online I believe. I’ll provide the following Ubuntu doc though (a server guide)

1 Like

I just used the shell. Thanks for your help!

1 Like

Sorry for my late response but I had a lot of work. Using the shell didn’t work either. Interestingly though, when I use a stick with version 19.10 with multiple users and do an update, everything works just fine. It doesn’t work with a new installation though.

I have the same problem and I’ve reported it, it seems like a bug in 20.04 (I also opened a thread)

Thanks, that’s an most interesting thing to note, ie. a regression

Bug detail should also be reported on the bug tracker, but what part didn’t work?

I think he means it doesn’t work when 20.04 is installed from scratch, I can confirm that since the systems I’ve installed are fresh 20.04 installations and not upgrades.