Cannot install software - Lubuntu 20.04 (on Lubuntu-Desktop or Raspberry Pi 4 (installed via Ubuntu server) )

I have installed Lubuntu 20.04 on a Raspberry Pi 4 using the Ubuntu server 64 bit image, the installation went fine, everything seems to work just fine but I’m having a peculiar problem when adding users and installing software.

This is the problem, apparently only ONE user can install software, if there are more than one user on the system things break, let me explain:

After installing Lubuntu the only user is the default ‘Ubuntu’ account, the account can update, install software (from APT, Discover, Muon) no problem, if I create a new user (and give this account the same group memberships as the ‘Ubuntu’ account) the new account can login and works fine BUT, it cannot install software, it keeps getting a ‘You are not authorized’ error, the interesting thing is that the Ubuntu account gets the same error if is used to install software, now, deleting ANY of those accounts and leaving ONLY ONE the problem goes away.

To clarify, let’s see the following scenario:

  • Ubuntu is the only account (no problem, can install software)

  • A new account is created (e.g. User1)

  • User1 cannot install software

  • Ubuntu cannot install software

  • Remove User1 account

  • Ubuntu can install software again

  • or

  • Remove Ubuntu account (leave User1)

  • User1 can install software

I’m not sure where to look or how to fix this problem, it seems permissions get screwy somewhere when a user is added, and by the way, it doesn’t matter how the user is added to the system, meaning, using the Add Users app or from the command line.

Ok, upon closer look, it seems Lubuntu 20.04 has a problem handling user accounts, I tried the same on 19.10 and it works.

In 20.04 if you use: Preferences -> LXQt Settings -> Users and Groups, you can create a user but you can’t delete it, that’s not the case in 19.10. it seems there’s a bug in Lubuntu 20.04.

By the way, it has nothing to do with Ubuntu Server or the Pi, I have 2 VMs one running 19.10 and another 20.04 (both running the desktop version) and the problem occurs only on the 20.04

Indeed. Solution’s here (tl;dr use the command line):

Hi,

I have done it via the command line and still the same problem, like I said before, it seems like a bug.

Must be on server because that post is on 20.04, too.

It happens as long as the version is 20.04.

Right. What I’m saying is that using the command line works fine in Lubuntu 20.04. Since you’re using Ubuntu Server 20.04 with lubuntu-desktop installed, it’s not really the same thing. The bug must be in Server.

No, if I do that on a regular Lubuntu desktop I get the same problem. And it doesn’t matter if I use the app or the command line.

Well that’s strange because two folks seem to have used it successfully on Lubuntu 20.04 if you read there.

Well, I wouldn’t be typing this if I found the solution, in fact, I have a PC right in front of me running Lubuntu 20.04, create a user, can’t install, and can’t remove the user from the app but only from the command line, but the problem is adding a second user prevents installing software, which doesn’t happen in 19.10