Lubuntu 23.04 Now Uses PipeWire! Info you should know + Call for Testing

In our continuing mission to create and maintain one of the best open-source operating systems, the Lubuntu Development team has made the decision to migrate away from the older Pulseaudio system present in current releases of Lubuntu, and to replace it with a newer, more advanced PipeWire audio system. We hope that this will improve our users’ experience with audio on Lubuntu.

As this is a rather major change under the hood, there are some things that we would like our current early users of Lubuntu Lunar 23.04 to know.

This does not affect users of Lubuntu 22.10 or any earlier releases - only users of the Lubuntu 23.04 development release need to take this info into account.


If you’re running Lubuntu 23.04, you will probably notice the PipeWire system automatically install itself onto your system. However, the Pulseaudio system probably will not automatically uninstall itself. It would be wise to run

sudo apt purge pulseaudio pulseaudio-module-bluetooth

to ensure that Pulseaudio is entirely replaced. You should probably also reboot your system after doing this.


The necessary packages for Bluetooth support with PipeWire are probably going to be installed properly, but currently this has had minimal testing. In the event of problems, please let us know ASAP. You can file a bug report on Launchpad, reply to this thread, or use any of the support methods listed on our links page, but please let us know.


If you’re running Lubuntu Lunar in a QEMU virtual machine, you may notice your VM behave very strangely if PipeWire is installed and you reboot from within Lubuntu (mainly constant web browser crashes). This is a known problem, and we haven’t explored what exactly is happening very thoroughly yet. In the event this happens, shut your VM all the way down and then turn it back on. This should resolve the problem. Currently this is only known to happen if you’re using QEMU directly from the command line using combined intel-hda and hda-duplex audio devices. VMs made using QEMU interfaces like GNOME Boxes or virt-manager, VMs made with entirely different virtualization software like VirtualBox or VMware, and VMs made with QEMU but with alternate emulated audio devices, may not be affected. We currently do not believe that this issue affects physical hardware.


In the event you aren’t able to get audio after PipeWire is installed and Pulseaudio is removed, you may need to ensure that the PipeWire services are properly enabled. Try running the following command in a terminal if this happens:

systemctl --user enable --now pipewire && systemctl --user enable --now wireplumber &&  systemctl --user enable --now pipewire-pulse

This should immediately cause your audio to work again. If you get any messages about a service being masked, run systemctl --user unmask <service> (replacing <service> as appropriate), and then run the enabling command again.


PipeWire on Lubuntu needs a lot of testing. This is the first time we’ve started officially supporting PipeWire on Lubuntu, so it has not been tested very well yet. If you have the time and hardware, we would love your help with testing Lubuntu and PipeWire! You can get the latest development release of Lubuntu from Ubuntu’s ISO QA tracker. Make a Ubuntu One account and you’ll be able to report your findings or just let us know that all went well!


For the most part, users probably won’t notice much of a difference from this change. However, for those who have had problems with Bluetooth audio, or for people with advanced audio setups, you may notice that your Bluetooth audio problems are resolved, and you may be able to enable extra features to enhance your audio management experience. If you notice anything different (good or bad) as a result of this change, please let us know!

Thank you for your time and help, and we hope you continue to enjoy Lubuntu!


The sony vaio I use for QA-test installs

sony vaio ultrabook svp11216cgb (i5-9400u, 4gb, intel haswell-ULT)

had an lunar install made awhile ago (2022.12.05 ISO), so I used that to apply all upgrades (ie. sudo apt update; sudo apt full-upgrade).

On reboot, the system appeared identical, with operation as expected, sound being achieved as normal :slight_smile:

As warned/documented; the packages pulseaudio & pulseaudio-module-bluetooth were still installed, so I executed the documented purge & rebooted.

Here I tested again, sound again was perfect, adjustable via Fn-sound keys on device, panel widget, within apps or via pavucontrol. From a user point of view, I saw no change :heart_eyes:

testing included firefox with music vids & clementine using local files


Tested (new install) Lubuntu Lunar daily ISO dated 23-12-2022 on Dell Optiplex 7060 i7-8700 ,32gb,intel HD Graphics) and pipewire installed.No need to purge pulseaudio and/or pulseaudio-module-bluetooth as neither were installed.


I’ll confirm @leok 's last comment, this install was made with the 2022.12.22 ISO daily and its for now a primary box. Sound works as expected, and the pulseaudio packages mentioned are not installed.

Alas I’d not thought to look at it earlier; was more interested in getting it setup for my own use.

Hardware: hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)


I tested in my Dell Precision M4800: Pipewire works in Christmas Eve’s [daily] live Lubuntu Lunar with Firefox and espeak (they can run mixed together without problems).


Me and @guiverc have noticed a worrying problem after the PipeWire switch - it appears that GTK apps (HexChat and Thunderbird so far) are no longer making notification sounds when audio is playing in the background (specifically music being played in Chrome is triggering the problem for me, @guiverc can trigger the problem with either Chromium or Clementine). The next plan of action is probably to test Ubuntu Desktop (which already uses PipeWire), and see if the problem is in Lubuntu or in Ubuntu as a whole.


UPDATE: Turns out this is indeed an actual bug, caused by the lack of the pipewire-alsa package in Lubuntu. If you’re impatient, you can run sudo apt install pipewire-alsa on your Lunar machine, then log out and log back in, and this bug should be gone. Or you can wait for it to automatically install itself - we are working on getting this rolled out to all current users of Lubuntu Lunar.