Blinking cursor when I try to install Lubuntu

Hello friends…

I built a USB stick to install lubuntu on a old toshiba laptop. The laptop has a modern fast samsung solid state drive in it and 4 GBs of RAM. It had/has an old version of Ubuntu on it. When I booted it (after it had not been turned on in about 2 years) it booted to Ubuntu and then it said I needed to update it so I did. After the update, it said I needed to reboot, which I did. After the reboot, all I saw was a blinking cursor. After many tries, I gave up and decided to install Lubuntu on it (as it is an older laptop).

I built a Lubuntu USB stick. I tested it first by booting to it on a windows laptop. It booted fine and it ran from the USB stick just fine.

So I plugged it into the old Toshiba laptop and booted. I saw the screen that said view or install, safe graphics and something else. I selected install/view. All I had was a blinking cursor.

I saw that I could press C for a command line. I did that. But I do not know any commands to try.

I played around with it for a bit and now it says:

GNB GRUB version 2.06
Minimal BASH- like line editing supported. Press TAB to see possible devices.


I have no TAB key on that old Toshiba. I tried all the keys to see if any did anything but they did nothing.

I a looking at a command line now that says:


And a blinking cursor after the >

Maybe this is the old Ubuntu on this Toshiba I have in front of me? Can anyone give me some commands to try to see if the old Ubuntu will fix itself and maybe boot?

If not, any suggestions as to what to try when I boot to the flash drive and can choose:

simple graphics

Or, I can click on the “C” key and I am at a command line from the USB stick.

Any help appreciated. Many thanks,


You’ve not provided any release details; and if it was a recent LTS release for example the ISO details matter (eg. Lubuntu 22.04.2 LTS has a later calamares or installer than the earlier Lubuntu 22.04 media; so the .2 detail is useful).

You mention it booting on another box as your test; if that other box has different hardware - the test is only 100% useful if you also jumped to terminal & confirmed the media validation completed successfully in my view. How you check the media varies on unspecified release, but you mention grub 2.06 which would imply you’re talking about 22.04 or later possibly.

How long did you wait? Some boxes have firmware that can cause live media to be very slow to boot; eg. on this thread I talk about hardware that can show blinking cursor for 7+ minutes (longer on some ISOs too), but you gave no timings. Whilst you can write the ISO to thumb-drive to speed this up, as it only impacts the live media which we use to install Lubuntu with, I suggest just writing the ISO normally & install; as boots of the installed system aren’t slow.

You didn’t mention how you wrote the ISO to your thumb-drive; it’s possible to write an ISO so it’ll boot only on some hardware systems (eg. booting on uEFI only, but not older BIOS boxes, or the reverse), so I usually opt for CLONE writes which will boot on all.

That’s my reaction anyway… With more detail I maybe able to offer more. Even hardware details can be helpful; as I have no idea what you consider ‘old’; all my hardware is refurbished, so even my ‘new’ hardware maybe something you consider ‘old’.

FYI: For some clues on media checks; this prior comment of mine maybe helpful if you wish for some details.

Thank you guiverc for helping me. I was installing Lubuntu 22.04.2 LTS I used the documentation on the Lubuntu web to check the down load file before I burned it to a USB drive.

I waited about 30 minutes and then shut down the Toshiba, and tried again from a different USB port. The Toshiba only has 3 USB ports. I waited about 20 minutes on the second USB port and a little over an hour on the third USB port. All were the same - blinking cursor, but nothing else.

What do you mean when you say writing the ISO normally? I used this from the link of the manual at the Lubuntu web site:

Do you mean burn a DVD maybe? I have not tried that. I will read about to install with CLONE if it is on the Lubuntu web site.

The Toshiba is a Satellite A205 Model number PSAF0U. It was shipped with Windows Vista if that helps.

I will read more to see if I can find CLONE and try that.

Thank you,



I could not find CLONE at this web site:

Could you post a link to CLONE for me and I will try that? Thank you again for your help.


Sorry, I’m fighting with time so this will be short points.

You’re following correct Ubuntu instructions, which are QA tested & work; however rufus is one program that has various ISO reconstruction options that can have issues, an example can be seen here which has an answer provided by a rufus developer that tells us issues will be fixed in time. On that thread you’ll also note another Lubuntu member (@sudodus) who translates my use of “clone” to “dd-mode” which is the terminology used by the rufus program. Different terms are often used by different tools and a couple of years back I stopped referring to the write as dd & switched to using clone instead as it was understood by more people (dd is a traditional unix command used to write files to magnetic tape for backup & other media).

By writing the ISO normally I meant using a dd command, or equivalent, which can be called a clone of ISO image to media, or dd-mode in rufus…

No I didn’t mean using optical media; in fact I’d suggest avoid if wherever possible on releases after 20.04 if possible; it’s now a second-class media for Ubuntu installs.

FYI: 30 minutes is a long time… if the media boots & media check verifies on another system (If i have failure to boot on one box in QA; I verify the media on two other boxes; one of a similar type (as close as I have anyway) and a very different type of box - just to exclude media writes; as I find 5-8% of writes to sandisk media can be faulty; worse for other brands; as USB flash media is made to cost; but I have other boxes easily accessible too)

Sorry I don’t have time to offer more currently.

1 Like

Thank you for the link! I will try it today and report back.


Hello… I did the dd-mode and tried it. I tried “try or install Lubuntu” and I tried the “Safe Graphics” mode. I let it sit and blink for 45 minutes in each of my three USB ports. Same thing. Just a blinking cursor.

I think my older ubuntu is still in this old Toshiba. I can get to a grub 2.06 prompt. Can you point me to a place where I can read some command line things to try to recover or fix my installed Ubuntu? It worked until I updated it, and now it will not boot. So maybe I can fix it.

And links you can point me to would be great.

Thanks again for helping me.


1 Like

I don’t fully understand this; your question was about installing Lubuntu, which I understand is Lubuntu 22.04.2 LTS.

What is your older Ubuntu?

Specifics matter, eg. at 22.04.2 there kernel changes that can cause issues with some graphics hardware. For flavors like Lubuntu, 22.04 & 22.04.1 media install with the GA kernel stack (ie. 5.15) which remains the same for the life of the system, however 22.04.2 & newer media install using HWE which changes; 22.04.2 included the 5.19 kernel.

Some hardware; esp. older hardware, can perform better with older kernel stacks (ie. GA), however you usually have the same booting, can usually (but not always) switch to text terminal (CtrlAltF4 etc) & explore problems, but not stop at the grub prompt (ie. which is before the Linux kernel/OS starts to boot!)

Grub issues are usually the result of changes to the disk, either in the session before the problem OR as a consequence of failing hardware. On any such issues; I boot live media & perform disk checks (SMART etc). FYI: Grub is a boot loader; is GNU code that has minimal functionality as its purpose is only to boot an OS, Ubuntu is this case (Lubuntu being a Ubuntu system).

I don’t understand what you mean by “* It worked until I updated it*” where understanding what you meant by that will allow me/others to more clearly advise.

At grub (where you pressed the “C” as I understand it) my most common first exploration is instead to enter EDIT mode of an existing boot entry (ie. E) and on the linux kernel line, I usually remove quiet splash and may also add a 1 so the system stops at runlevel 1 (ie. to tell the system to boot only a minimal system so I can explore)

To understand grub, you could look at Grub2 - Community Help Wiki but the page doesn’t contain that much detail; most of it being found when you follow links there (including to upstream GNU).

Sorry, I still don’t understand where exactly you are, but those are my thoughts on what I do follow.

Apologies… This old Toshiba laptop had a version of Ubuntu loaded on it, but the laptop had not been turned on for at least two years. I plugged it in, hooked up an ethernet cable, and turned it on. It booted just fine to an Ubuntu desktop. But with in about a minute, I had a pop up that said I had updates and to click this button to update which I did. It downloaded many updates and then it said that the laptop needed to reboot in order for some of the updates to take effect and to click the button to reboot which I did. The laptop rebooted, but the only screen I got was a blinking cursor. I thought it might take a while to load the updates so I walked away. About an hour or so later, I still had a blinking cursor. I tried rebooting a few more times, once leaving it overnight, but no joy. That was when I decided to see if I could install a new version of Ubuntu on it. As this laptop can only support 4 GBs of RAM, I looking for a Linux version that was one that could support older computers. I decided ton Lubuntu. And you know the story after that.

I thought (I could be completely wrong here), that if I could read about some commands from the terminal, I might be able to try some commands that might rebuild, fix or try to get the version of Ubuntu on this laptop to boot. The laptop only has one drive in it, but it is a modern Samsung SS drive.

Thank you for the links and suggestions. I will give it a try tomorrow first AM and see what happens.

Many thanks,


Quick update before I go to bed… I tried the Ctrl, Alt, F4 and a screen came up. It says:

Ubuntu 18.04.6 LTS A205 tty4
A205 Login:

I remembered the correct user ID and password. I entered it and now it is showing about 3/4s of page of text (no error messages) and a prompt that says:

jack@A205:~$ (and a blinking cursor).

So it looks like a version of Ubuntu is still alive in this laptop. How can I get it to boot to a GUI interface?

I think you have gotten me close to the finish line!


We don’t support Ubuntu 18.04 LTS, our final notice was this back in late April 2021, or three years after we released Lubuntu 18.04 LTS.

Ubuntu support sites can be found here.

The only currently supported products of Lubuntu are Lubuntu 20.04 LTS (with mere weeks of support only remaining), Lubuntu 22.04 LTS, and Lubuntu 22.10.

In your situation, I’d explore what kernel stack you’re running for starters (I mentioned the two primary stacks (GA & HWE) earlier) and see if that changed as I alluded to with 22.04 LTS earlier on this thread; Note: the last stack change occurring when bionic reached 18.04.5; with the 18.04.6 change relating to key revocation. But I won’t support a bionic system here sorry.


Thank you for your help. Can you suggest a way that I can upgrade it?

I think if I could get it to boot to a GUI interface, than I would have a chance of installing the latest version of Lubuntu.

Do you have any suggestions on how I could do that?

Many thanks,


Hello guiverc… I finally have my old Toshiba laptop up and running again with an up to date Linux OS.

I talked to the original owner of this laptop. He still had the install DVD he made to install the OS. The DVD he made says: “Lubuntu LTS 18.04.3 Bionic Beaver 2020”.

I booted the laptop with this home made DVD. I planed around for a while trying to recover, rebuild or fix the GUI interface so the laptop would boot. But I was unable to do that. So I did a clean install of 18.04.3 without updating it after the install. I then tried the two different versions of Lubuntu 22.04 I had on flash drives. I had the same issue. The laptop would boot to the flash drives, and I could see the menu and pick “view or install”. But after that, I only saw a blinking cursor. After that, I burned a DVD and tried that. Again the same thing.

Then I noticed that on the sleeve that the 18.04.3 Lubuntu was in, it said “32 bit”. So I thought that was the issue. I looked around for a Lubuntu or any Ubuntu OS that was 32 bit but I could not find any. I am guessing Ubuntu has stopped support for 32 bit only computers?

I then went on the web and searched for 32 bit Linux OSs that could run on older slower laptops and desktop computers. After reading many reviews, I decided on a version of Debian GNU/Linux Bookworm i386 4/01/2023. As I was having good luck booting to DVDs, I decided to down load the above and burn it to a DVD to see if I could boot to that and hopefully install a modern Linux.

It worked! My system is up and running and current. I do prefer a Ubuntu OS the best. I have a powerful desktop that will not upgrade to Windows 11 and I hope to next try Ubuntu Studio on it.

Thank you for all your help, and especially teaching me some terminal command lines things to type. I hope to expand on that in the future.

Many thanks,


1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.