WPS office only runs as root in Lubuntu 18.04

Hi to Everybody,

I’ve updated WPS Office to the last version (, but after that update it only works as root.

If I run WPS Office as a normal user, I see it in the task manager but nothing happens on the screen.

The previous version of WPS Office was ok.

I’ve tried with six different notebooks, all with Lubuntu 18.04 installed. Only for curiosity, same behaviour with Debian 10 with LXDE desktop and Peppermint 10.

What could be the problem?

I know and I use LibreOffice, but since I only use Lubuntu I need something with full compatibility with the documents that my colleagues send to me. I know also OneDrive, but WPS is more comfortable if I’m not online.

Thanks in advance for your help!

You should ask the creator of the package. If it is reproducible on several different systems, then something is wrong with the deb package.


I have no idea, but I would explore all libraries/files used by the WPS program and ensure all file permissions are accessible to ordinary users (and write permission is available if config file or a file you’ll likely need access to).

If you still have access to an old system, I’d consider comparing permissions looking for a changed permission made by the update.

Please note these are just my thoughts (2c worth), I don’t know the program.

1 Like

Hi, thanks for your reply. I’ve already written to KingSoft, but they have never replied to me. I was hoping in some silly error from my side and that some Lubuntu user experienced my same problem…

Hallo, thanks for your reply!

Effectively, I’ve explored just like you wrote and I compared a previous WPS version, but… I didn’t find differences :expressionless:
Really, I didn’t check all the files, many of them but not all :sweat:

Nobody can help me? Thanks in advance

Maybe, if you start the application from the command line and post the output.

Ciao, in this attachment the screenshot without being root: as you can see, no output, the program seems to normally work.

ciao/2, in this second attachment you can see from tasks manager that two wps task are running, but on the screen wps doesn’t appear.

ciao/3, if I run wps as superuser, the program regularly starts.

It looks to me like WPS is available as a Debian package from the developer’s website. I also see that there is a version in the Snap store, but judging from a comment on an issue in the developer’s GitHub repository, it seems like the way he speaks about WPS, they are unrelated, so this must be unofficial. There is no version in the Ubuntu repositories. That said, I’m not sure that consulting the Ubuntu community for support is going to be the best place for resolving your issue. I would instead suggest contacting the upstream developer.

1 Like

@wxl → Ciao and thank you for your reply!
Well, I’ve installed the Debian package right from the link you’ve provided. Then, after the problem I experienced, I wrote to them: the only reply they gave me is that is a Lubuntu issue, since on Ubuntu Gnome and Debian Gnome there are no problems. So, just out of curiosity, I’ve tried the wps package on Debian 10 with LXDE desktop: I’ve experienced the same problem I have had with Lubuntu (18.04). Before the last update, wps used to rightly work.
I allow myself to insist on this problem because wps is useful when you receive from someone (in my case, mainly my colleagues) some office documents and you need to have a full compatibility with them. In these days the internet connection is not always so stable as usual (we are all at home in “smartworking” due to Coronavirus), so (at least in my knowledge) wps is the only package with full compatibility with Office. That is why I ask for help here, you are the experts of “my” Distro! Thanks in advance.

Please check, that all files in your home directory are owned by your user:

find ~ ! -user $USER

Ideally, this shouldn’t return any file.

Could you please provide a link to this report?

I confirm, no return after the command

Ciao, I wrote an email to ‘feedback’ (top right in the Linux home page) when the actual version has been released, so I used other solutions (onedrive…). Now, with an often unstable webline, the use of a offline solution could be useful…

Wow, they don’t even have a bug tracker? This is why proprietary software sucks. Can I ask why you use WPS as opposed to free software solutions like LibreOffice? It can handle proprietary formats, too. And besides, most of the proprietary software is going for more open solutions for formats.

Anyways I can confirm your problem (including in 20.04 which is LXQt and not LXDE although it did work in Kubuntu 20.04). I did an strace and it seems to be looking for something it cannot find. If the developers are too lazy to even check whether or not it works with other desktop environments than Gnome, that’s a real problem on their part. I have no idea how their software is supposed to work—no one but they do! That’s the nature of software that is not open source!


Ciao and thank you very much for your efforts in helping me!
I always use LibreOffice, but a lot of customers send me documents in Office formats and -until now- the only way to have a full compatibility to edit them have been Onedrive and Wps. LibreOffice creates me problems mainly in .xlsx format documents, or in .docx documents when there are some more laboured formattings in.
In Italy is even hard to convince people to use Google docs for working on shared documents, so I have to deal with this kind of problems that in these days are accentuated from the situation.
Anyway, thanks again! I really love Lubuntu!!

1 Like

i have same problem with wps office only runs as root, i have tried to change permission the executable using chmod and chown, it doesn’t work.

As I said above, this is a problem with the upstream developer. Contact them. If they refuse to help, I can’t help further since I have no insight into their codebase since it’s all proprietary!