System bug Lubuntu LXQT

I posted this about a month ago: HELP! I cannot open disk

Basically I was not able to open the specifc disk on which Lubuntu was installed in the new LXQT desktop environment on my old netbook (10 years old). I then proceeded to install the Bionic Beaver version of Lubuntu and on that version everything was working fine. However I wanted to install the latest LXQT version on my newer computer (Around 3yrs old) as well and I encountered the exact same issue. It says “Can’t mount file” and “Can’t mount disk” for the disk on which Lubuntu is installed but it opens every other disk just fine. Then I installed Bionic Beaver and everything is working fine, just like it happened on my old netbook. Where am I able to file a bug report for this? Clearly this is not normal…

I can safely say that I do not understand your issue any more than the other two people that were trying to help you with the original issue, so perhaps it would be wise to elaborate in detail (pretend we’re dumb and don’t know anything) the steps you took, what you expected to happen, and what did happen.

One other thing I’ll add: if there is some sort of bug, it may not be an issue with LXQt or the file manager. It may be the underlying lower-level software. So we’ve got some digging to do before we can determine what is at fault.

2 Likes

Reporting Bugs

Please refer to our wiki page https://phab.lubuntu.me/w/bugs/

If the issue relates to LXQt itself (and not something specific to Lubuntu), it’ll need to be pushed to https://github.com/lxqt for work to be performed (ie. LXQt to be changed). This usually involves testing on another distribution (to confirm it’s not Lubuntu specific; I usually use openSUSE tumbleweed). Changes made upstream will flow through to all projects using LXQt including Lubuntu.

1 Like

I will make a video of it and I will share it through Google Drive when I have time. (I have to reinstall Lubuntu 20.04 so it will take time…)

Why not just explain it?

In this video you can see Lubuntu Bionic Beaver, which is installed on my SSD. As you can see a USB is plugged in as well, and everything works fine. I am able to open the contents of my SSD and of the USB without any issues.

As you can see this is the latest Lubuntu focal fossa. I booted it from my USB. I am able to open the contents of my SSD without issues however I receive an error message when I try to open my USB. (In case I would boot Lubuntu focal fossa from my SSD and not from my USB then I would be able to open the contents of my USB but I would not be able to open the contents of my SSD, I would receive the exact same error message you see in the video)

I hope you understand what the issue is with Focal Fossa through these videos, I have no issues with Bionic Beaver, it is super fast and everything works fine, you did an excellent job with regards to Bionic Beaver however I cannot say this about Focal Fossa. I am not able to use Focal Fossa due to this huge issue and I am sure I am not the only one having this issue. (I tried to install Focal Fossa on two computers and this was an issue on both of my computers. And Bionic Beaver runs excellently on both of my computers)

Hi,

Bionic Beaver is installed on your SSD and you can access to your USB correctly.

BUT Focal Fossa is running through the USB (live USB) and it is not the same.
You are booting Focal Fossa from the USB and you are trying to access to the same USB consequently it may cause an error.

Greetings.

Hi, I am aware that it is running through the USB as I did not want to install it, as it simply wouldn’t work. (I already installed it on two of my computers and I kept encountering this issue, so I switched to Bionic Beaver instead, which works very well on both of my computers. I just demonstrated this issue through Lubuntu live but this issue is present even when Lubuntu Focal Fossa is installed on an SSD)

If I installed it on my SSD then I would not be able to access my SSD… (I repeat that I tried it numerous times, trust me) I even wrote this in my earlier comment, that if I would install it then the same problem would persist. I am never able to access the drive on which Lubuntu Focal Fossa is installed…

Hi,
I think that you are doing something wrong in your Focal Fossa installation way.

I have installed Focal Fosa (fresh install) in my desktop (dual boot with win10) for five months and I can access to any device, such as SSD, USB, Kindle, etc…

Greetings.

Believe me I installed everything the right way, I followed the tutorial. I believe you that everything works for you, I think this error is only present in certain types of computers and not in others. Both of my computers have Intel Atom processor and one of my computers has a 1GB RAM and the other one has 4GB of RAM. And both of my computers have a 60GB SSD (both extended with another 64GB micro SD) They became both super fast with Lubuntu Bionic Beaver but with Lubuntu Focal Fossa I had this same issue on both of my computers.

I do believe you @mylubuntu , but I don’t fully understand your issue. It does however remind me of something I’ve experienced, then ignored, as they way I believed something should work, is not how upstream (LXQt & pcmanfm-qt) believe it should be used.

I’ve looked for the what it reminded me on GitHub (https://github.com/lxqt/lxqt/issues & https://github.com/lxqt/pcmanfm-qt/issues) but I couldn’t find whatever your description reminded me of (I suspect it’s a closed issue).

I don’t think the issue relates to just some computers… but maybe it’s more an issue on less powerful hardware (I used to test Lubuntu with 1GB of RAM into the 19.04/disco cycle when x86 was dropped), but your description has reminded me of something many cycles ago (not focal or groovy, likely not even eoan, and we’re starting hirsute currently)

I see, well for me Bionic Beaver works just fine so it does not really bother me, I am going to stick with Bionic Beaver, I just thought I am going to better explain this issue (As you can see I even attached two videos) since I believe you should fix this in future releases. Because you can lose a lot of customers with this error (Canonical is for profit I believe). Imagine a person installs it and it does not work, and that person is not aware that in Bionic Beaver this issue would not be present. The person would switch to another distro or just abandon Linux altogether. Thankfully I tried Bionic Beaver as well so I no longer face this issue.

If you want to find the source of the problem then you can write me and I will try my best to help. I am not really pro in Linux yet so I just made those two videos I attached. (Otherwise I would have provided logs and other system information as well). I forgot to mention that the issue was on a Samsung N150 netbook. (My first computer :smiley: )

Canonical maybe a private company that is after profit, however Lubuntu is not a Canonical product, it’s a community flavor of Ubuntu created by volunteers.

We have users, not customers.

I don’t see any videos sorry, you could try uploading them to some place where you have an account, and adding links to them.

@guiverc The videos are in this post on Google Drive.

1 Like

Sorry, I was looking for new vids. Sorry, my mistake.

No problem :slight_smile: Really though? I thought lubuntu.me belongs to Canonical Ltd. I learned something new then :smiley:

The website may have it’s bills paid for by Canonical (applies to all flavors), they also build all packages (we use launchpad.net and other Canonical funded infrastructure), but there are no Canonical employees that I’m aware of in the Lubuntu Council, nor in the wider Lubuntu team.

The same applies with all Ubuntu flavors (with minor exceptions, eg. Martin Wimpress who leads Ubuntu-MATE is now an employee of Canonical and heads Ubuntu Desktop, but that’s relatively recent; he was head of Ubuntu-MATE as a community member for far longer, originally employed elsewhere, those exceptions/people have two hats, their employee roles being separated from their community/volunteer roles they do in their own time)

This whole description is a mess and the videos don’t help. There is so much conflicting information, I don’t even know where to begin to ask questions to try to figure this out.

But you did ask about where to file a bug. To that, I will say that a clear, simple, concise description in English text is essential. There should be clear steps that others can use to reproduce this, as well as a clear description of the problem, including any errors, verbatim. If it is specific to particular hardware, it should be described in very specific detail as well.

To that, I would add a general suggestion to remove variables as much as possible when making comparisons between two situations, else it is hard to draw any reasonable conclusions.

2 Likes

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.