Stuck on splash screen

I don’t know what happened, but my PC is stuck on boot:


As you can see it has no loading icon which means it doesn’t load at all. My PC usually and constantly freezes cuz it’s a low end PC so I just restart it with the power button. But today it doesn’t start up except when it’s recovery mode or set to ‘nomodeset’. I even tried to reinstall grpahics driver with ‘apt autoremove’ and ‘ubuntu-drivers autoinstall’ commands but it still occurs. What do you thinks causes this to occur?

It is difficult to know exactly what the issue is, obviously the Plymouth splash screen is hiding some of that. To dig a little deeper you could try pressing the ESC key when the splash screen starts or booting into recovery mode and looking at journalctl -xeb -1

2 Likes

I don’t know If I’m doing it right, I’m just a newbie, but this is what it shows:

How do I save this into a log file so that I can send it here

It’s way too long should I send it all?

@VladdyHell

You can copy/paste it here and put the whole thing in between “detail” tags as shown below:

/[/details="list title"]
Put
Your
Text
Here
/[/details]

(you will need to remove the forward slashes when you do it… I put them there to show the formatting syntax.)

… or just paste it here and highlight the text you want to “hide”, click the gear icon in the text editor while you’re editing or making your post and click on “Hide Details”. This will do the same thing.

If you manage to get the formatting right, it will look like this:

(you click on the arrow there and it will expand longer text you want to tuck away neatly)

Example

Example
Yada
Yada
Yada

Alternatively, you can copy/paste the entire thing to paste.ubuntu.com or pastebin.com and provide us a link to the “paste” i.e. post.

You have a mouse?
I can never copy stuff from that screen.
Plus, there is nowhere to paste it.
Is it logged to a file somewhere?
I think there is a way to open another command prompt at that point.

I somehow managed to copy the whole text, however, it’s very long that it can’t even be posted here. So I just pasted it here:

It seems that it only shows the logs for Dec. 4, the issue occured yesterday (Dec. 3). Am I doing it wrong?

You’re not doing it wrong. I believe the command journalctl -xeb -1 is showing you the log contents for the session before last. Since you’ve likely reboot or shutdown your PC afterwards, the contents will show results for a different time period and session. This is ok as long as you can still get the error again and boot normally afterwards. You just need to produce the error first and then boot normally, run the command again, and it should show some hints in the log. Of course, assuming the log text you provided already shows interesting stuff, there is no need to do it again. The log is helpful for understanding what would be causing the error.

1 Like

@bjlockie
You can look at the following file:
/var/log/syslog

Usually it’s easier to use the journalctl command to grab the info you’re looking for a bit nicer.

For more info on logs under Ubuntu, you can check out this link:
https://help.ubuntu.com/community/LinuxLogFiles

1 Like

I did it in the GUI recovery mode and simply just copied it with the --no-pager option Where should I execute the journalctl command? If I should execute it directly from recovery terminal only, I should see the log file in /var/log/syslog right?

If you’re able to boot into recovery mode, you should be able to see the /var/log/syslog file. I think the contents of this file gets archived after a certain amount of time or after every boot. You can use the journalctl command once you’ve logged in be it via GUI and terminal or just the console from recovery. The benefit of the journalctl command is it lets you kind of query for specific things and it tries to bring you only the relevant log information per your specification. The command as specified above was to get specific log data for the session that had the problem.

Is this right?

I got an update, after several days of not being able to boot, this is what it shows now:

Did you do anything between your last post and this most recent one that maybe changed the behavior?

I’m assuming the picture you provided is showing you booting with nomodeset?

Does it stop there at the last line every time now with the CUPS scheduler text?

If it always stops there in that spot, my next guess would be to boot into recovery and turn off CUPS from starting at boot. You can use the systemctl command to disable CUPS.

If it stops during boot at a different stage with different text… I am not so sure what to check next. You mentioned in your initial post that your PC freezes often causing you to force the PC to shutdown. This might cause your system to become unstable since you are not shutting down properly. Someone can correct me here but I believe depending on your hardware, this can affect your system integrity… more specifically, your file system. To rule this out, you can boot the live DVD/USB for Lubuntu and run a fsck (assuming you didn’t do an encrypted install).

Unfortunately, because your system already shows signs of being unstable (i.e. hardware), we can’t say for sure what the problem is. It could be a number of things at this point.

Can you show us the command you used to install your graphics drivers or did you do it via GUI?

EDIT: I only added the fsck suggestion as something to maybe check. I don’t truly think that is the problem here as I imagine it would’ve shown on the screen as an error but I have been proven wrong before.

I didn’t do anything actually, I’m currently using a live USB.

In the picture I provided, it’s actually a normal boot, nomodeset still works, so I’m assuming the graphics card driver is the one that causes this issue, I even tried reinstalling it like I did the last time this happens too and it fixed the issue, but this current issue I think is different from the last time.

I tried to reproduce the issue again but currently, it’s just stuck to the boot selection, unlike the one picture I provided above.

Is this the right way to disable CUPs?

systemctl stop cups
systemctl stop cups-browsed
systemctl disable cups
systemctl disable cups-browsed

I’ll try to repair it with fsck, and if you think it’s an issue regarding the grub, I’ll try it too and update you if it doesn’t work

As I stated above, I updated the driver with the following commands:

sudo apt remove nvidia*
sudo apt autoremove
sudo ubuntu-drivers autoinstall

This solution works from the first issue encounter.

Yup - that looks right to me. You can try that and see if booting shows anything different.

Just keep in mind that disabling cups is only suggested if the last line mentioning cups as shown in the image is always the last line to show up on screen during boot for your PC now. Otherwise, disabling cups might not have any affect on the stalled boot.

I am not familiar with using ubuntu-drivers command so I’m not sure what it’s doing exactly. I’m assuming it’s doing what the GUI component let’s the user do.

Ubuntu has a wiki page for details on installing drivers under Ubuntu:

https://help.ubuntu.com/community/BinaryDriverHowto

Following the steps listed there for your card might prove better results.

I tried to disable CUPs but it didn’t work.

I also tried fsck directly in the recovery terminal mode, and here is the output:

Is there any way to reinstall the OS without losing the data?

It depends on how you installed Lubuntu. If you did manual partitioning and created a separate partition for /home directory, then you can reinstall without losing your data. Otherwise, you’ll likely have to manually move your data to something like a USB or external hard drive. Since you can still boot and enable GUI with nomodeset, you can technically also use a web browser to upload stuff to a cloud service if you use one. Someone else can correct me on all the possibilities for what’s installed now though.

I’ve been having trouble accessing the log file contents from the link you provided previously. I might have a better chance if the text is available on pastebin.com or paste.ubuntu.com.

1 Like