[SOLVED]Chromium/Google Chrome keeps nagging about not being the default browser

Configuring x-www-browser in Alternatives, XDG’s default-web-browser and Lubuntu’s default internet browser application in Session Settings is not enough. Turns out Chrome looks at /etc/xdg/xdg-Lubuntu/mimeapps.list and you have to edit it as sudo and replace the instances of the “firefox” string with your browser of choice.

Hope I’ve been of some help.