Printing problems with Libreoffice in lubuntu 20.04.1 and 20.10 Beta

Came across this bug 1892637 and did some testing on both releases and can confirm this. I cannot print anything from Libreoffice.

As a workaround I ran in terminal:

sudo apt install libreoffice-kf5

followed by:

sudo apt remove libreoffice-qt5

I refer to https://ask.libreoffice.org/en/question/242188/cannot-print-anything-exporting-to-pdf-produces-blank-pdf-lubuntu-2004/

this needs further testing as there maybe adverse effects which I am not aware of.

See also earlier discussion on Discourse here .

Does it work as per Walter’s suggestion

That’s been my fall back in support questions on askubu & UF if I recall correctly. It’s what I’ve used too (though I rarely print)

Yes it works but it is not a permanent fix. You have to run it from the terminal every time you use Libre writer which is inconvenient for many users. I intend to test this further on various boxes/setups.

Anyone else interested in testing this is more than welcome. :smiley:

1 Like

you can change the ENV variable in Session Config
image
Actually we should have changed it for 20.10, I forgot.

3 Likes

Thank you @hmollercl

Maybe we should include mention of that in final release notes as a work-around @kc2bez for groovy.

1 Like

Yes thank you @hmollercl !

Tested and solved. However this also needs to be added to 20.04.1 as well as 20.10. @guiverc @kc2bez

20.04.1 is out already, 20.04.2 can still be changed.

I’m not sure forcing a change on everyone (ie. existing users with installed focal systems) is a great solution; I fear it’ll break some manual fixes/work-arounds people have already implemented so I’d suggest we concentrate on new releases, and deal with existing via support, posts etc.

A question, then answer on AskUbuntu for example (alas I’m probably the person for that). Maybe

  • a page in the manual? (not ideal to my thinking),
  • a blog post (possibly out of place as I see only announcements there),
  • lubuntu wiki (too obscure)
  • probably easiest is a post on this site where the problem is outlined, releases impacted mentioned, then solution offered. (not this thread, ideally clean without bug references beyond link like @leok initial thread).

I’d suggest a post here first, and I could use that as my basis for an Ask Ubuntu one, with link to here :slight_smile: and something that can be used to refer users to whenever UF/askubu/other questions are noticed.


@Leok sorry I referenced a link you were no doubt fully aware of (even likely helped test!), I’d not noticed it was the same link you made reference to, so apologies.

1 Like

@guiverc

Good suggestion and will do - :smiley:

1 Like

I forgot to mention that this introduce a small bug in libreoffice which is that some movements/resizing of the window might cause window content freeze, which is solved by maximizing/unmaximizing it.
I haven’t had time to look if the bug exist and create it if not. If someone could it would be great. Here https://bugs.documentfoundation.org

1 Like

@hmollercl
Thanks for the tip…I will test that as well and report back.

1 Like

Hi, Is this what you are referring to? When I tried to fix this printing issue, I ended up with editing issues which I talk about in this post Libre Office Editing Problem

I haven’t “logged” the bug anywhere but here, I don’t know how, and no one else seemed interested anyway.

I haven’t tried the maximising/unmaximising fix either.

The other suggestion of removing libreoffice-qt5 and replacing it with libreoffice-kf5 doesn’t make sense to me because according to Muon package manager, one of the depends of libreoffice-kf5 is libreoffice-qt5, so how does it help by removing it?

This was just a suggestion that I stumbled onto and tested. I never recommended it as I stated it needed further testing. The reply by @hmollercl pointing out the need for the env variable in Session config appears to solve the problem. I am still testing this and will post my results in a separate post when finished.
Sorry for any confusion caused by my original post above.

Hi, I’m sorry if I implied you had caused any confusion, you hadn’t. I had seen the suggestion to replace libreoffice-qt5 with libreoffice-kf5 in another post, and it was by looking for it in Muon that I discovered the association, causing the confusion.

I’ve actually been wondering if we need both -qt5 and -kf5 installed to resolve the printing issue. Or would this not help at all? My understanding of this type of thing is non-existent so if I’m talking jibberish let me know :confused: