My first live Lubuntu Hirsute Hippo

I discovered that there is a Lubuntu Hirsute Hippo iso file available via the iso testing tracker now. I tested it live, and it works :slight_smile:

my-first-live-lubuntu-hirsute

ps/

I found no zsync file, but I could rsync the iso file according to the available link,

$ rsync -tzhhP rsync://cdimage.ubuntu.com/cdimage/lubuntu/daily-live/20201103/hirsute-desktop-amd64.iso .
This is an Ubuntu mirror - treat it kindly

hirsute-desktop-amd64.iso
          1.86G 100%   10.60MB/s    0:02:59 (xfr#1, to-chk=0/1)

I think the zsync file will arrive soon, but couldn’t wait for it :wink:

5 Likes

Yes - zsync file arrived and more testing underway. :grinning:

5 Likes

I attempted to load it in VirtualBox and it froze the host OS after the file checks.

I haven’t yet set up a dedicated box for testing - but it’s on my list of things to do.

I also have no idea what to do with this information - nor do I know if it has any value.

I also can’t seem to make zsync work, but I’ll tackle that another day.

Edit: zsync appears to finally be working properly. It threw errors when I tried it previously. I did not make note of them.

If the integrity check succeeded, then it may be an issue of not enough resources. Otherwise, if it froze during or even near the end of the check, that may indicate a problem. Making use of zsync and/or manually checking the hashes on the ISO can confirm the integrity.

1 Like

It passed the check and I threw 8 GB of RAM and 2 cores at it.

Lemme download it again and try it on bare metal.

zsync worked. I ended up with a ~2 GB file. I tried first with Rufus, twice. I tried with uNetbootin - which only got me to a blinking cursor. I am now trying mkusb. I’ll try dd next. Hmm… mkusb uses dd, so that’s out of the question.

So far, no luck. I get even less far. This is now on bare metal. It’s an older dual-core AMD w/16 GB of RAM and an SSD. I know Lubuntu 18.04 works on it, as that’s installed on it at this moment in time. It installed with nary a hitch - and runs surprisingly well on that hardware.

Before I make any claims, I want to eliminate me as the problem.

I am going to give it a clean download one more time. I’ll also try it on different hardware.

LOL I may need some hand-holding until I’m fully onboard.

Since it is a moving target when in development, there could be a catastrophic failure of some kind. Did you try Groovy?

I have played with Groovy, but not tested it in any significant capacity. Groovy works just fine on that hardware. It’s not even slow. It’s surprisingly snappy, considering the age of the hardware.

It’s just this particular ISO that’s causing me issues.

That is the correct one, yes?

There is this warning:

WARNING: This image is OVERSIZED. This should never happen during milestone testing.

You know what’s weird is that I can’t seem to get zsync to behave. It’s as if there’s some sort of network issue. Using HTTP rather than HTTPS, it’s a little more cranky but works as expected. Something is strange.

…but after downloading, everything worked fine in VirtualBox. So may be some issue on your end.

I’ve got my hirsute script running

#!/bin/sh
rm *.old
rm hirsute*manifest
mv hirsute-desktop-amd64.iso.zsync hirsute-desktop-amd64.iso.zsync.old
wget http://cdimage.ubuntu.com/lubuntu/daily-live/current/hirsute-desktop-amd64.iso.zsync
wget http://cdimage.ubuntu.com/lubuntu/daily-live/current/hirsute-desktop-amd64.manifest
zsync -u http://cdimage.ubuntu.com/lubuntu/daily-live/current/hirsute-desktop-amd64.iso  hirsute-desktop-amd64.iso.zsync

When it completes, and is written (dus or mkusb) to thumb-drive I’ll give it a quick spin on a couple of old c2d and like boxes.

It was booted successfully on

  • hp dc7700 (c2d-e6320, 5gb, nvidia quadro nvs 290)
  • dell [optiplex] 755 (c2d-e6850, 5gb, amd/ati radeon rv516/x1300/x1550)
  • dell [optiplex] 755 (c2d-e8300, 8gb, amd/ati radeon rv610/radeon hd2400 pro/xt)
  • dell [optiplex] 780 (c2q-q9400, 8gb, amd/ati cedar radeon hd 5000/6000/7350/8350)
  • hp 8200 elite sff (i5-2400, 8gb, nvidia quadro 600)

Right. HTTP behaved, HTTPS did not.

lubuntu@lubuntu:~$ cat /etc/*-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=21.04 DISTRIB_CODENAME=hirsute DISTRIB_DESCRIPTION="Ubuntu Hirsute Hippo (development branch)" NAME="Ubuntu" VERSION="21.04 (Hirsute Hippo)" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu Hirsute Hippo (development branch)" VERSION_ID="21.04" HOME_URL="https://www.ubuntu.com/" SUPPORT_URL="https://help.ubuntu.com/" BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/" PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy" VERSION_CODENAME=hirsute UBUNTU_CODENAME=hirsute

Tada!

1 Like

So what ending up being the problem? Just needed more patience?

I am not sure. In some instances, it was stopping at just saying GRUB in the upper left on boot. That was with the rsync file. I downloaded it fresh, from the web using my browser, and then booted and it went to a blinking cursor - after the grub menu.

I ended up waiting about five minutes with the blinking cursor and then it turned into the 8 bit graphics type of thing where it didn’t look like the normal file checking screen. I let that complete and then a couple of minutes the screen popped up. Those times are rough estimates and not exaggerated.

It was much, much longer booting than it should be - even for booting from USB.

It never worked in VirtualBox, but I haven’t tried VBox with this newly downloaded ISO.

For some reason, I think the rsync’ed file was corrupt, but I was under the impression that shouldn’t happen.

Yeah one of the steps to zsync is actually checking the hashes. It’s like a necessary part of the protocol, just as error checking is a necessary part of torrents.

That said, bizarre, but oh well. :slight_smile:

1 Like

It works now. It also made me make a few changes. I can dedicate an entire desktop to testing, so can do so consistently. It’s an i5 with maybe 16 gigs of RAM and an SSD. It’ll be suitable. I don’t use it for anything. In fact, I just got rid of one just like it.

All that and I have nothing to report!

Also, I’m subscribed to all the mailing lists already. I’ve been there for years. I don’t normally post. I’m the ‘uninvolved@outlook.com’ (David) on the lists. I must have been subscribed for five years now, somewhere in that area.

Is the chat used often? I’m not a huge chat fan.

1 Like

The mailing lists are largely pretty quiet unless we’re doing announcements, calls for testing, etc. Most of the regular coordination and stuff happens in chat. We’ve got folks on there via IRC, Telegram, and Matrix, so there’s lots of options.

2 Likes

Thanks. I am flipping back through some of the mailing list emails right now, actually.

LOL I think I know which one is you! Well, that’s going by initials, so it might be coincidental.

I’ll swing by chat sometime, but definitely not tonight.

Thanks again. I hope this isn’t a waste of your time, meaning I’ll do what I can to help.

Oh, I’m sure you found me. The email should be a dead giveaway.

Anywho, help is what we need. Read the docs on our Phabricator wiki and let us know how we can help you help us.

P.S. Your help providing support on this site has already been extremely valuable.

3 Likes