My Brave Browser won't set as default?

Sorry, I hit the wrong button and deleted my post I was trying to edit.

I just installed Lubuntu and installed Brave Browser using Discover, it installed and works great but It will not set as the default browser, so I removed it and reinstalled it several times using the Terminal using different commands, I can get it working but nothing will let me set it as default. The last one I used is from here… Install Brave I had this the other day and the one at Brave install this is the one that worked on Zorin Pro when I had this problem but it won’t work in Lubuntu. Any ideas or did anyone else have this problem? I did a search and didn’t see anything about it. Thanks.

Settings > Default browser
Make Brave the default browser > Make Default

There isn’t really a good “set as default” program in Lubuntu, and for some reason the usual ways that browsers set themselves as default just doesn’t work (I don’t know why). As it turns out, there’s a file that stores the default application database in Lubuntu that you can edit manually - doing this will let you set your browser as default. See this documentation page: [SOLVED]Chromium/Google Chrome keeps nagging about not being the default browser Using these instructions, I was able to get Chrome to replace Firefox as the default browser, and I would guess it would probably work for Brave, too.


try in session configuration, change the default web browser to brave-browser

is working for me.


It has been a while since I’ve tried this:

 sudo update-alternatives --config x-www-browser

Pick the correct number to set your default browser.

Confirm the change with:

 sudo update-alternatives --display x-www-browser

Roberalz, I can’t find this? Where is this located? Thanks

KGlll, what are my choices? Do I have to put in anything else? Do I do this when installing? Just wondering. Thanks

The browser needs to be installed to be able to select it as the default.

On my system, the menu @Roberalz shows can be found by going to the Application Menu → Preferences → LXQt Settings → Session Settings → Environment (Advanced).


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.