Mouse misbehaving in lubuntu while it was working fine in windows 7

My Dell N-5030 PC is encountering issues with the mouse in Lubuntu, despite its smooth functionality on Windows 7. I've already attempted driver updates through the terminal using commands like "sudo apt-get update" and "sudo apt-get upgrade." However, the problem persists. I've also tried different USB ports and restarted the computer, yet the mouse misbehavior persists. I'd appreciate guidance on adjusting Lubuntu's mouse settings to ensure they align with my preferences. ram is more than 3 gb

You’ve not said what release, I believe it’s 22.04 as per this question but it’s best if you’re specific.

I’ve already stated being specific with details matter, as 22.04 media is available that used the 5.15 GA kernel stack (ie. older which can perform better on older devices) and HWE which currently is using the 6.2 kernel, which will perform better on newer hardware.

The mention of windows 7 implies to me older hardware, but I don’t know your device. You also mention RAM is moer than 3GB but not saying what it is; in recent years anything less than 6GB is considered minimal RAM for web browsing, thus using sufficient swap is pretty essential which is what i’ve already alluded to.

You can use uname -r to get details of what kernel you’re using; on my system that responds “6.5.0-10-generic” where the only detail I’m interested in is the first two numbers, ie. 6.5 being my current kernel. For Ubuntu 22.04 LTS the numbers should be 5.15 if using the GA kernel stack, or 6.2 if using the newer HWE kernel stack (your install media will determine what yours is).

Unless you’re using propriety (closed-source) kernel modules you can have both GA & HWE installed, selecting which you use at boot (at grub), though it’ll use slightly more disk space if you keep both installed, plus both will get updated meaning slightly more bandwidth used during upgrades… but that is one option.

An alternative that is even easier is to not install anything, but boot live media using different kernel stack, and just using the try mode provided with Ubuntu media; see if it makes a different. Ubuntu 22.04 LTS media is available with the 5.15 (22.04 & 22.04.1) , 5.19 (22.04.2) & 6.2 (22.04.3) kernels currently.

If it’s mouse settings; configuration settings for Lubuntu can be found in the manual on the page Chapter 3.2.8 Keyboard and Mouse — Lubuntu Manual 22.04 documentation in a manual page I’ve already provided; but as already stated I’d try increasing swap first if your RAM is less than 6GB, with details in this link already provided.

As I don’t know your hardware, I don’t know which approach is best; I can only give my 2c (being what I’d consider).

  • try other kernel stacks via live media and see if it makes a difference; this doesn’t require any change to your system thus has no negative consequences; except it requires multiple ISO downloads/writes to media & testing via USB-thumb-drive media; ie. time being the cost. I’m offering this as it’s easy to do (I consider it easy anyway), as drivers are kernel modules, thus changing kernel stack causes modules (aka drivers) to change, however if you’re missing a synaptics or other driver this won’t help, as I’ve never used hardware that benefits from those modules
  • try different stacks on your machine; may make no difference though (esp. if your issue is a missing synaptics module), but this is often very helpful on older hardware (when using the HWE kernel stack) or newer hardware (and using GA or older stack)
  • if your swap is 512MB only; that is where I’d go first (free -h), by increasing it… An example I’ve written about a number of times was my stealing half (4GB of 8GB) from a box so I could test another box with some RAM, not expecting to notice any difference (on box which lost half its RAM) — boy was I wrong; a 8GB system was great to use, but with only 4GB the box was annoying until I increased swap from the defaults
  • checking settings as per manual page I provided; it may or may not help

ps: If I use/say Ubuntu rather than Lubuntu; read it as Lubuntu if you’d prefer; I’m using Lubuntu/LXQt currently, but I do see my system as a Ubuntu system; I’m using Lubuntu/LXQt as GNOME (Ubuntu’s Desktop) just isn’t my cup-of-tea, but I do like the Ubuntu base all flavors of Ubuntu use.


i increased swap so it will fix my mouse issue ?

i allocated 3 gb out of my 5880 mb ram should i allocate full 5880 ?

see screenshot that what i have done

1 Like

22.04.3 have 5.15 KERnel ?

Ubuntu 22.04 LTS using the GA kernel stack uses the 5.15 kernel (this applies to any point of upgrade; thus 22.04.3 too).

If a Ubuntu 22.04 LTS install is using the HWE kernel stack, at 22.04.3 the HWE Linux kernel is be 6.2. This applies with all flavors such as Lubuntu.

Installs of Lubuntu 22.04.3 LTS will default to the HWE kernel stack, thus you’ll have the 6.2 kernel (coming from 23.04; upgrading to 6.5 from 23.10 soon or at 22.04.4).

Lubuntu 22.04.2 & later media defaults to the HWE kernel stack on install; with GA being the default for older Lubuntu 22.04 & 22.04.1 ISO/media.

i cant change kernel in my existing lubuntu from 6.2 to 5.15 ?

Please refer to Kernel/LTSEnablementStack - Ubuntu Wiki (provided previously) which tells you how.

Search that for this text “To downgrade from HWE/OEM to GA kernel:” as that is what you want to do, downgrade the HWE 6.2 to GA 5.15.

You’ll note the instructions tell you first to install both stacks, test, and then remove the unwanted HWE stack. Unless you’re using certain third party or closed-source kernel modules (like some nVIDIA) you can just never remove the alternate stack & decide at login (ie. selecting at grub) which you’ll use for that boot as both can remain, both will be upgraded, thus you’ll use slightly more disk space & bandwidth (during upgrades).

1 Like

that article is hard to follow as i m not so techy somehow i installed lubuntu in more than 1 week
would u plz write those codes then i will copy paste on terminal if u can to fix my dell n-5030 touchpad/mouse

somehow i done 5,15 after pressing shift key but after reboot it again showing 6.2 ):

i pasted this sudo apt remove --purge linux-generic-hwe-20.04 linux-oem-20.04 linux-hwe-* linux-oem-* linux-modules-5.1* linux-modules-5.8.0-* linux-modules-5.6.0-*

all other removed except 6.2.0-39 ):

This is why you shouldn’t paste commands into your terminal that you don’t understand. Even when they’re not malicious, they can cause trouble if they aren’t customized correctly.

Try this:

sudo apt install linux-generic
sudo apt purge linux-image-6.2.0-39-generic linux-modules-6.2.0-39-generic linux-modules-extra-6.2.0-39-generic linux-tools-6.2.0-39-generic
ls /boot
ls /lib/modules

The above commands install the normal 5.15 kernel image and its accompanying packages via the linux-generic metapackage. They then remove the 6.2.0-39 kernel and its accompanying packages (though these packages have to be spelled out in order to be correctly removed). Finally, the contents of the /boot and /lib/modules directories are listed so you can make sure things went as planned.

If you see a 5.15 kernel left in your /boot and a 5.15.something folder in /lib/modules, you should be good - make sure you have a live USB around just in case something goes wrong, then reboot. Once rebooted, run uname -r to see the version of the currently running kernel. If you see a 5.15 kernel, you’re good.

If you don’t see any kernels at all in your /boot, something’s gone wrong. DO NOT REBOOT until the problem is fixed. You should probably try running sudo apt install linux-generic again if this happens.


ok but u know i was unable to remove 6.2(so u can say i have both 6.2 and 5.15) but managed to boot with 5.15 and i was check with unmae -r it was 5.15 but still touchpad/mouse stuckking i m so sad what to do now?

and i just pasted this sudo apt install linux-generic
sudo apt purge linux-image-6.2.0-39-generic linux-modules-6.2.0-39-generic linux-modules-extra-6.2.0-39-generic linux-tools-6.2.0-39-generic
ls /boot
ls /lib/modules

terminal asked that r u want to remove 6.2 ? i clicked yes and reboot and then checked with uname -r but still its showing 6.2.0-39-generic not 5.15 ):

btw can i install this in lubuntu maybe it will fix my touchpad/mouse issue

Windows drivers are incompatible with all Linux-based operating systems, including Lubuntu.

Have you tried another mouse ?

its inbuilt touchpad/mouse of my laptop,isnt annoying to use external mouse and keyboard with laptop? i want to fix it within inbuilt so not any way to fix it ? going to older version of lubuntu will help ? but what about security then as older versions may dont receive security updates ):

so what to do plz help i m stuck from around 20 days ):

Are you sure that you’re not just accidentally triggering a feature of the mouse that you don’t have enabled in Windows? Try clicking the Application Menu → Preferences ->LXQt settings → Keyboard and Mouse, then scroll down in the left sidebar so you can actually see “Mouse and Touchpad” (it’s hiding at the bottom). Then try disabling “Tap to click”, “Tap and drag”, and “Scrolling”, then click “Apply”. See if that helps anything.


1 Like

for now it is anything wrong ? i think already tried all 3- disabled,two finger,edge,button i dont remember but all 3 was not helped, i have to reboot everytime when if i try again all 4?