Lubuntu 22.04.1 fresh installation in dual-boot machine

Hi,

Next month I´m going to do a Lubuntu 22.04.01 fresh installation in a dual-boot machine.

Acording to this thread, in ubuntun 22.04 there was a problem with grub (os-proper).

Is this problem solved in Lubuntu 22.04.01?

Greetings.

1 Like

If you look up our Lubuntu 22.04 issue tracker you’ll see that was added in 24-Dece-2021 by myself (my primary box sits on the development release, though I didn’t notice it until I rebooted which I do only fortnightly).

The issue was last detected using the 2022-01-22 daily of jammy with Lubuntu, having been resolved after that, before finally dropping off our issue tracker on 24-March-2022 for Lubuntu 22.04 LTS on the thread I provided earlier.

It wasn’t a problem per se, just a security difference with prior releases; with the behavior reverted to what was used in prior releases (ie. it explores/peeks-inside other partitions like it did before)

The problem didn’t exist in 22.04 media; nor 22.04.1 media; only very old alpha ISOs. Lubuntu media is identical in this regard to main Ubuntu, or all other flavors as grub rules are common for all.

In QA-testing the dualboot installs were performed with other releases of Lubuntu, other GNU/Linux distributions, plus with windows 10. I stopped experiencing that issue in the alpha stage of jammy (22.04); others may have tested other OSes in dual boot beyond what I mention here, and my own testing includes up to 4 OSes on the same machine.

Myself, I don’t believe it’s a problem, however as the thread you provided was answered by a Lubuntu member @ArrayBolt3, he may respond here as well, or you can ask him questions if you wish.

2 Likes

I originally got my info about the problem from this post: OS Prober is Disabled in Ubuntu 22.04, Here's a Workaround - OMG! Ubuntu! What I didn’t realize was that the post was made in December of 2021, which aligns with the early alpha stage of Jammy. The post was (mostly) written as if it was just a normal-old, run-of-the-mill installation of Jammy, and I thought I had seen others encounter this problem, so I was led to believe that this was just how it was in Ubuntu 22.04. I see I was mistaken. I will edit the Ask Ubuntu question linked above to make this clear. Thank you guys for bringing this to my attention!

@ubun-ie, yep, problem is solved, you should be good.

3 Likes

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.