Lubuntu jammy jellyfish (22.04) issue tracker

Items that need to be watched

Useful links

2 Likes

Item to watch - install alongside, install using existing partition etc for Lubuntu jammy.

grub 2.06

I just rebooted my primary box (I tend to do about fornightly) so it’d been running 16 days, and I was hit by the OS_PROBER issue.

My system is dual boot; my other OS being 20.04; but it wasn’t there for me to select in grub, in fact with only a single OS detected I didn’t even see the grub menu.

I haven’t confirmed this is an issue hitting new installs, but I bet it will. When Lubuntu 21.04 reaches EOL my current 21.04 install kept for support purposes will shift to a 22.04 QA-test install & I’ll be noticing this rather regularly I suspect.

It’s not impacting 20.04 installs I believe (last QA-test install with focal daily was 2-3 days ago), but I’m betting it’ll hit certain BIOS jammy installs at a minimum (not full-disk or dual-boot types).

This topic created for tracking purposes primarily (it’s still early days so this is of no importance currently)

2 Likes

Ran into this issue twice in the past few days installing Kubuntu Jammy and also Ubuntu Mate Jammy on “install alongside” installs. The original bug report is here Bug #1955109.
Planning on testing Lubuntu Jammy later today. :grinning:

2 Likes

Thanks @leok

I’m disappointed in that I saw that bug report appear on #ubuntu-bugs-announce, and intended to test for it… but never got around to it :frowning: Alas, it was forgotten and whilst I was convinced I’d seen a report for it; I didn’t find it when this box didn’t have the other OS listed (I think I found the original focal report & it b/c of the focal on it I missed it’s importance).

Thank you.

1 Like

I can confirm this also in Lubuntu Jammy - tested ISO 23-12-2021
http://iso.qa.ubuntu.com/qatracker/milestones/429/builds/241694/testcases/1701/results/

Comment #5 in the bug report suggests a workaround.

2 Likes

Another issues that requires tracking…

firefox deb to snap transition.

As noted in a QA-test release-upgrade (from 21.10 to jammy) by @leok

<lubot> [telegram] <Leokolb> Ran an upgrade from 21.10 to Jammy - upgrade went well but Firefox
was not on the menu(installed after the upgrade ..then opened Discover installed Firefox and all
settings were retained (re @kc2bez: In my limited testing it should retain your settings and
extensions.)
<lubot> [telegram] <Leokolb> Test result of upgrade @kc2bez http://iso.qa.ubuntu.com/qatracker/milestones/429/builds/244252/testcases/1310/results/
..
<lubot> [telegram] <kc2bez> I think we will need to provide instructions in the release notes.

Thanks for the QA-testing @Leokolb

2 Likes

Just for the record a new bug report was filed regarding the Firefox snap transition mentioned in above post. . https://bugs.launchpad.net/ubuntu/+source/lubuntu-default-settings/+bug/1960823

2 Likes

firefox deb to snap transition:

I noted in a live QA-test the following comment

Clicking About & then clicking a LINK… after which there is a VERY LOOONG pause before a link opens… I think release notes mention maybe required?? b/c of firefox snap usage; and it being somewhat slower to start on initial run. My USB has no LED to show read/write so it does ‘feel’ like it didn’t work…

I knew to be patient. but new users, or installers who aren’t expecting the package type change, may declare it’s not working…

1 Like

Minor issue…

Post install and using the fresh lubuntu system, opening LibreOffice - HELP - Libreoffice.Help

gets firefox opened &

FILE NOT FOUND - file://tmp/lu23267w8nw8.tmp/NewHelp1.htmp (or equivalent file)

but this isn’t likely snap related given date of initial report & Edward/epp1’s report of it in impish too.

Update: issue acknowledged; is not a Lubuntu specific issue but instead a snap confinement issue, and is being worked on.

1 Like

Two firefox’s have appeared on our ISOs :frowning:

Thanks to @leok for noticing, however it’s now confirmed we’re not alone with this (Ubuntu Desktop canary), so hopefully it’ll get fixed soon to & is not a Lubuntu issue directly.

Update: I just noticed Feature Freeze Exception: Seeding the official Firefox snap in Ubuntu Desktop - Announcements - Ubuntu Community Hub which I hope is related… Maybe the change here of “NoDisplay=true” will fix this for us :slight_smile:

3 Likes

By the way, I took a ‘deeper’ look today and they’re two distinct versions. The snap is a different version than the one installed from the traditional repositories. I looked just to satisfy my own curiosity.

We don’t really need more confirmation. I was just curious.

2 Likes

Update.

Grub resolved :slight_smile:

I believe the grub issue has been resolved. I can install many systems now without issue, including our “Install using existing partition” without needing to manually fix grub… We’ll just watch it.

Wallpaper change, 2x firefox items & ISO creation issue

We’ve changed wallpaper, but currently have an ISO creation issue (Bug #1966168 “Jammy Lubuntu and Ubuntu Studio Daily ISO images n...” : Bugs : Ubuntu CD Images which was closed, but thanks @leok) so we can’t test that, or the two Firefox issues (1963672) now deb package of firefox is just a snap wrapper

The ISO creation issue maybe just a naming issue… RikMills noticed a .IMG file that maybe the ISO.

Update to my update

I have removed the wrongly-named ‘.img’ files. The next daily build will produce .iso files again.

quoting Vorlon/Steve Langasek here so that issue will be gone tomorrow with luck :slight_smile:

2 Likes

A new bug report was filed regarding custom partitioning on btrfs.

https://bugs.launchpad.net/ubuntu/+source/calamares/+bug/1966774

2 Likes

@leok in QA had an upgrade issue with snap store for upgrades from focal to jammy

This issue is really a concern for 22.04.1 as only impish (21.10) users will see the upgrade process to jammy (22.04) after 22.04’s release, so we can monitor this [for now].

This issue (2 Firefox entries on app menu) is fixed after beta release 20220329.1 - tested 2 machines and all good.

4 Likes

Yup. I was able to grab and test it before today’s .iso dropped (assuming we get one). So far, so good.

1 Like

Upgrade from Impish to Jammy no longer a problem as per 01.04.2022 - tested both TUI and GUI upgrades and all good- no errors .

Regarding Focal to Jammy - the issue is being worked on and as mentioned by @guiverc still a bit of time before 22.04.01.

3 Likes

Not technically a Jammy-specific problem but worth mentioning, the iso tracker site is now back to performing in a reasonable manner - no longer taking close to two minutes to load some pages.

So, whoever was tracking that, it has been fine for a few days now. For whoever fixed it, thanks.

3 Likes

@leok noted that installs using BTRFS leave an unbootable system.

Bug report - Bug #1966774 “btrfs partioning with calamares results in unboota...” : Bugs : calamares package : Ubuntu

This is likely an upstream calamares issue as noted by Erich Eickmeyer

@Leok noted in further release-upgrade testing

Just for the record -Not a workaround but tested an Impish btrfs system upgrade to Jammy Lubuntu with no errors

Thank you @leok

3 Likes

Tested today (04-04-2022) upgrading from Lubuntu Focal 20.04.4 LTS to Lubuntu Jammy LTS - on 2 boxes with no errors. All upgrades from Focal and Impish now no longer an issue.

4 Likes