Lubuntu 20.04 Wi-fi connection issues

Hello people, I am new to Lubuntu environment and I have recently decided to install the 20.04 LTS version on my laptop, it has been a fresh install and I’m dual booting it with Windows 10.
Actually I installed it yesterday and since then I’ve had an issue.

Everything is working fine except for one thing, I’m experiencing a problem with wi-fi connection: it happens frequently that the connection drops (I see a notification on screen that clearly states that and on the tray bar too when I’m lucky enough) and it won’t reconnect unless I maually disable and re-enable the wi-fi mode through my keyboard (Maybe there are other ways, but I haven’t found them yet). Sometimes it won’t appear a notification at all (the computer thinks it’s connected) but internet still doesn’t work.
When on the same laptop I’m using Windows 10, everything is fine.

It is a bit frustrating because it makes the usage of my pc very unpleasant if I need internet connection, since it happens VERY frequently, although everything is fine when I’m using a wired connection.
As I said at the beginning of this post, I am new to the environment therefore consider me a real noob with commands on terminal and any other ‘particular’ function (I have always been a Windows user) and I don’t know what other kind of information I should provide you in order to find a solution. So, thanks for your patience and gently ask whatever you need to know.

Hi. I installed Lubuntu 20.04 soon after it was released, and have been reading this and other forums since then. You are not the only one who has had this issue.

My experience is that I had a lot of dropped Wi-Fi issues soon after the first system upgrade was installed. However, over time, it has gotten better. I don’t have an explanation for that, it’s just an observation. After a day or so, the dropped Wi-Fi stopped happening frequently.

Now, it happens about once every 2 days, and when it does happen, I have to re-boot. I haven’t found another way to successfully deal with this yet.

It’s definitely not optimal as I am working online from home right now, including Zoom meetings, etc. Haven’t had dropped Wi-Fi in the middle of one of those yet, but…

Previously, I used Lubuntu 17.10 on the same hardware, and I didn’t have any Wi-Fi issues at that time. I have no idea what is different in 20.04.

Sorry that doesn’t solve your problem, but I suggest keep installing the upgrades and wait a day or two and see if things get better.

We’d need to know information about the specific card in use.

As wxl mentioned, it’ll help us to help you if we can know the hardware your system is using.

Can you copy/paste the output of this command from the terminal:

lspci

After that, we might be able to help out a bit more. Let me know if you get any trouble.

Thanks for answering, so here’s what I have with lspci
> > `00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 2 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.5 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 6 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)
09:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
09:00.1 Bluetooth: Ralink corp. RT3290 Bluetooth

`
And I also used this command sudo lshw -c network and I got this

*-network                 
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:08:00.0
       logical name: enp8s0
       version: 07
       serial: d0:bf:9c:1a:fc:26
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII
       resources: irq:18 ioport:3000(size=256) memory:b2600000-b2600fff memory:b2400000-b2403fff
  *-network
       description: Wireless interface
       product: RT3290 Wireless 802.11n 1T/1R PCIe
       vendor: Ralink corp.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: wlp9s0f0
       version: 00
       serial: c0:38:96:92:ab:a7
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rt2800pci driverversion=5.4.0-31-generic firmware=0.37 ip=192.168.1.6 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:16 memory:b2510000-b251ffff

From what I can tell, the drivers for your Wi-Fi NIC are reportedly known for being buggy or at least have that reputation from the older bug reports I found on Google.

It also looks like the drivers aren’t really being maintained all that well as random people have made tweaks on their own to make it work (previously).

What I don’t know is if you had an older version of Ubuntu/Lubuntu installed before you installed 20.04? If you did, did you have this problem then too?

If it worked on a previous Linux install, then it might be a similar case where the driver isn’t playing well with the kernel in use.

Since the Wi-Fi isn’t a problem when you’re using Windows, that kind of rules out hardware being the issue (i.e. software issue). At least, that’s how I would go about it but perhaps someone with more fine grained experience can probe better to make that more conclusive.

Unfortunately, I’m not really able to provide much else at this point as I’m coming up to dead ends on Google. I think you might also be able to ask for some assistance on Ubuntu’s forum or discourse. Should have a spot for flavors like Lubuntu.