Lubuntu 20.04 / lxqt 0.14 keyboard layout does not switch

Hi folks
install Lubuntu 20.04 on Thinkpad x220 Intel(R) Core™ i5-2520M CPU @ 2.50GHz
everything works but I had problems with switch keyboard layout (eng/ru)
built in way to choose keys to change layout (in mouse and keyboard settins) - does not work at all and as I understand developers already know about it
in all my Linux systems I use “Caps Lock to first layout; Shift+Caps Lock to last layout”
I found next solution:

1)disable caps(thanks to Vivek Gite https://www.cyberciti.biz/faq/linux-deactivate-caps-lock/):

setxkbmap command to turn off caps locks key
To turn off caps lock key, enter:
$ setxkbmap -option ctrl:nocaps
(check that capslock is NOT enabled or will be FROZEN IN ENABLE POSITION)

To reset caps lock. enter:
$ setxkbmap -option

2)change keyboard layout(thanks to Tharbad https://bbs.archlinux.org/viewtopic.php?id=250248):

I was able to solve the problem without editing X confs by adding line
options=grp:shift_caps_switch (Caps Lock to first layout; Shift+Caps Lock to last layout)
to ~/.config/lxqt/session.conf in [Keyboard] section.

Other key shortcuts are found in /usr/share/X11/xkb/rules/base.lst

I think you have to reboot after correction in session.conf

Good luck!

2 Likes

Why do you say that it does not work with the options that the system gives? You can switch with a combination of keys between Russian and English

no I could not,
1 add russian layout
2 choose desirable keys to change layouts
3 nothing works…(i steel was able change layout by clicking language icon)
ps:
now I understand that didn’t check default layout maybe it was working…
Ill modify original post thank you

Have the same troubles with fresh LTS Lubuntu 20.04.2. lxqt-config-input: any chosen element in “Keyboard Layouts → Key to change layout” doesn’t work properly (always resets to None).

I edited [Keyboard] section in ~/.config/lxqt/session.conf manually (options param was added):

[Keyboard]
layout="us,ru"
model=pc105
# was added
options=grp:lalt_lshift_toggle
variant=","
1 Like

Hi Denis, (dobrogo vremeni sytok)
I can’t advise you anything because I didn’t remember details (I am mechanic not a computer person.
But try to check Vivek Gite (https://www.cyberciti.biz/faq/linux-deactivate-caps-lock/)
and Tharbad (lxqt key to change keyboard layout won't save / Newbie Corner / Arch Linux Forums)
posts they might give you some ideas where to dig…
YDACHI!

@gd13 , also there are another bug with layouts: Can’t change keyboard locale on logon screen with lxqt (Lubuntu 19.04, 19.10 and 20.04).
For me: there are still one way to install correct Lubuntu nowadays - install from Ubuntu Netboot ISO or from clean Ubuntu Server [with tasksel select “Lubuntu Desktop”] :woman_shrugging:

Hi all! I have the same problem on a fresh installation. I’ve added two layouts, Finnish and Russian, and I’ve noticed that the shortcut (Win+Space) only works when switching from Russian to Finnish, but not vice versa.

I’ve tried adding more layouts, and the shortcut does not work in most of them. Russian and German are the two layouts where the shortcut works. I uninstalled fcitx, but this didn’t help. I do not want to disable the caps lock, has anyone here been able to solve their problem without switching to another distribution?

You probably don’t need to disable caps, I’d disable it because I personally hate CAPS…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.