Lubuntu 20.04 and 20.10: Libreoffice: font of some dialog-windows is too small

In LibreOffice:
If you go on
Tools>Options…: the font of the dialog-window is too small
same problem:
Help>About LibreOffice: the font of the dialog-window is too small
it is because the VLC is set to qt5+cairo
(this information can be found in: Help>About LibreOffice)

now if I run those 2 lines on the terminal:

  • sudo apt install libreoffice-kf5
  • sudo apt remove libreoffice-qt5
    now the VLC is set to gtk3
    (this information can be found in: Help>About LibreOffice)
    then the font of the dialog-windows are not too small any more
    so, the problem is qt5+cairo

my question to you:
Where should I post this issue?


To the site above?
1 Like

Unless someone chimes in otherwise, this is how I file bugs:

From the terminal:

ubuntu-bug libreoffice

Then follow the prompts. It’s probably easiest to already have a LaunchPad account. At least this way, you can be sure it’s seen, triaged, and then hopefully fixed.

Just follow the directions when filling in the bug report. As near as I can tell, there’s no such thing as too much information. What is the expected behavior? What is the actual behavior? Then, you can tell 'em the workaround that you found all in the same form.

2 Likes

I agree with KGIII

I always file first using the bug tracker used by the project where I found the bug, ie. launchpad for Lubuntu/Ubuntu and most other flavors.

If I believe it’s an upstream issue, my next step is to test for the issue on another box running another OS.

I’m setup for that second testing, having an opensuse tumbleweed box, debian testing/sid & fedora box I can compare with. It’s common for them to be running different versions of packages, but with the three I usually have a mix of packages (debian is behind of late, tumbleweed regularly ahead)

It’s more detail for when I make the upstream bug report (ie. it’s not just a single packaging or OS as the different OSes will be packaged by different people).

The bug trackers usually provide a means to link the bug reports for the various trackers; if they don’t I just use links in my text (launchpad for sure allows you to add the upstream github link when filed).

For your specific testing, a live system would likely do, if you can find one that contains the same or later version of LibreOffice. Upstream bugs will usually want the latest version tested, but if you can’t find a live system, installing in a VM maybe an option

2 Likes

due to your explication, I found the right place to report the bug:

thank you for your help

2 Likes

Given that GTK3 is not Qt and doesn’t integrate well into the rest of the UI, it is unlikely that we are to make this change.

We know the Qt VCL is buggy but we’re working to get LibreOffice to fix that and we should be set.

P.S. you can just change the VCL on the fly with environment variables, which is a much easier way to make the change should you want the GTK3 option.

3 Likes

@wxl

Does that mean, I don’t need to post the issue on bugs.launchpad.net?

sorry, I have no idea what you mean; I would like to stay with libreoffice-qt5, but the font is too small;

Do you have an example, so I have a better idea what you mean?

I entered the bug.

That was my steps:
bugs.launchpad.net > in the search field: libreoffice qt5 > enter > I clicked on "Printing a blank page with libreoffice on Lubuntu 20.04 " > Report a bug > in the search field: libreoffice qt5 > I clicked on Next > No, I need to report a new bug

And this is the bug:

4 Likes

FYI: It’s best if you use ubuntu-bug on your actual system, as that way details of your system (release details, package details, etc) are entered in the bug tracker (currently they’re missing).

The command apport-collect will add them (I just requested it on your report using standard request template). Please run it on your system once (either the 20.04 or 20.10 system)

4 Likes

I do not think installing kf5 alone does anything useful. Just remove qt5 and LO should default to gtk3. Beware, though! When qt5 is made to work perfectly, you’ll be the last to know. So, checking future versions of qt5 whether they are bug-free or not will be a good idea.

1 Like

All bugs should be reported via ubuntu-bug (which is to say, via Launchpad but you shouldn’t use Launchpad directly), but ultimately this will get solved by LibreOffice. The issue isn’t one that is specific to LibreOffice on Lubuntu or LibreOffice on Ubuntu flavors, but one that is specific to LibreOffice.

Run LibreOffice with SAL_USE_VCLPLUGIN=gtk3 libreoffice. What that means is that, just for the non-interactive, non-login shell that runs LibreOffice, the environment variable SAL_USE_VCLPLUGIN (which defines which VCL is used) is set to use the gtk3 option. In the LXQt session settings, we have the qt5 version set, so you can override that with this without necessarily removing the qt5 version.

Also while I was looking around the Internet to answer this, I found this Debian wiki page on the subject I hadn’t noticed before. There is a specific fix for the font size issue. I haven’t tested it, so can’t tell you much about it but it’s something to look into.

1 Like

I tested it, but it didn’t work for me; it could be that I did something wrong

that is a good idea; it sounds logic;
I will test it the next time I will do a Lubuntu 20.04 or Lubuntu 20.10 installation

the next time I will find a bug in libreoffice, I will do it;
thank you for the answer

I just looked at your bug report, and I’ll reply here rather than another comment on the bug report.

The apport-collect didn’t work from what I can see, but thanks for trying.

If you haven’t filed a bug before on the machine (via commands apport/ubuntu-bug etc) I would expect firefox to open, ask you to sign into launchpad.net, a window open asking you to grant permission (and time limit) then the detail to be submitted. Note: it may differ to this as this is from memory

Did you experience any errors doing this?

@guiverc
yes, indeed I was asked to grant permission with a time limit;
I think, I clicked on a button “1 hour” or so;
that is what I did;
but half an hour later I had to leave, so I had to shutdown the computer;
I was hoping that everything was OK;

Did I do something wrong?
I mean, do I really have to wait one hour?
Did I miss something?
It was my first time to report a bug by terminal.
Should I restart it?

No you did nothing wrong!

The time limit is for permissions for that machine to upload to launchpad. On this desktop I’m using now, I’ve given permanent upload rights, but for laptops I usually go for shorter times. You don’t need to wait that time, the upload should take 10-40 seconds (even faster is possible). Maybe there was a button or something on screen waiting for you to OK, but sorry I’m not sure (I just do it; and don’t notice the screens anymore)

After the time question was answered, the upload should have occurred, you’d receive emails of the details uploaded (me too as I subscribed to your report when I wrote the initial response (#1) on that bug report).

As it didn’t work, can you please try again.

apport-collect 1905778

(as per comment #1 on bug report)

@guiverc
after the click on “For one hour” this is the text of the website:

Almost finished …
The Ubuntu computer called p-hpnotebook now has access to your Launchpad account. Within a few seconds, you should be able to start using its Launchpad integration features.

and then nothing happens, although I’m logged in

after about 1 hour I reloaded the website; this was the text:

Authorize application to access Launchpad on your behalf
Unable to identify application
The information provided by the remote application was incorrect or incomplete. Because of that we were unable to identify the application which would access Launchpad on your behalf.
You may have already authorized this application.
See all applications authorized to access Launchpad on your behalf.

so what?

1 Like

Running LO with --quickstart from terminal complains a JRE and libreoffice-java-common are missing. I checked the JRE packages but confused which one is appropriate for Lubuntu.

There’s nothing about any particular JRE package that would render it more or less appropriate for Lubuntu. I’m surprised you don’t have those packages but with you uninstalling stuff, you might have uninstalled that with it.

Nope, this is a clean install of 20.04.1 current and this is the error message:

lxq@triton:~$ libreoffice --quickstart
javaldx: Could not find a Java Runtime Environment!
Please ensure that a JVM and the package libreoffice-java-common
is installed.
If it is already installed then try removing ~/.config/libreoffice/4/user/config/javasettings_Linux_*.xml
Warning: failed to read path from javaldx
Icon theme “elementary” not found.