Libreoffice printing issues

Several users have reported and encountered problems with Libreoffice printing.

The problem is Libreoffice printing blank pages when attempting to print to printer and/or export to pdf file.

This occurs in releases 20.04.0, 20.04.1 LTS and the 20.10 BETA

The solution is to go to Preferences-LXQt settings-Session settings - Environment variables - Environment (advanced) -
then add the following 2 variables if they are missing -

SAL_USE_VCLPLUGIN qt5
SAL_VCL_QT5_USE_CAIRO true

screen01

3 Likes

Me I don’t even use Lubuntu 20.04 as there are so many issues, for me it did not even let to mount my SSD :joy: I use Bionic Beaver, the 18.04 version, and so far I had very few issues. Bionic Beaver is an excellent OS but the latest Lubuntu 20.04 is very messed up imo.

Hi, do you know if this fix messes up the ability to edit files? When I tried adding the env line to the desktop file (as detailed in another post) I found I wasn’t able to edit without the screen going nuts.

Thanks for putting your time into this issue :grinning:

Hi, just to let other users know, after adding SAL_VCL_QT5_USE_CAIRO true to the LXQT Session Settings list, switching off - then on again, the editing problems still occur but the unmaximise/maximise solution does seem to work. I haven’t tried printing anything yet.

@Ranger5

Could you be more specfic about the editing problem so I can also test it? I have not been able to reproduce any errors when moving images within a.docx file - was that not the problem?

Just one further question: Do you have Compton enabled in the Session settings - Basic settings ?

Hi, I talk about the editing problem in this post: Libre Office Editing Problem

It includes screen shots. This is happening both before saving as a file type (when creating the file) and after it has been saved as an .odt file. I have been using the right click menu to edit, perhaps using the toolbar buttons produces a different result? Even selecting an image to begin resizing it starts the problem.

As I mentioned in my last post, unmaximizing then re-maximizing the window clears the problem and I can continue with the document.

I will have to get back to you on this as I am currently on a different computer. I’ve never really been sure what Compton is or does, I clicked on it once in the menu and nothing opened so I just left it alone.

Edit: 10:40pm, I’ve just checked the basic settings and Compton is not enabled.