Installing Lubuntu on a Dell Venue 10 Pro

I am trying to install Lubunto on a Dell Venue 10 Pro. I created the bootable USB stick, but when I reboot the device, got into the Boot menu, I don’t see the USB. I thought perhaps the USB 3.0 could be an issue, but when I choose the Boot file, it pick the information in the USB stick. No matter what I tried, it failed. Any suggestions how to proceed? I was able to make Window faster on this device, but I think Lubuntu would be so much better. I appreciate your help. Thank you.

You haven’t said which release of Lubuntu you’re talking about.

If a written Lubuntu doesn’t boot for me, I always shutdown the device and try the media on another device, as in my experience the write to media fails far too regularly. If it fails to boot on a second device, I usually assume it’s an invalid write, but do on occasion try it on a third device (devices will differ, first two are usually same type, eg. uEFI, third will be BIOS in this example).

  • Did you validate your ISO prior to write?

  • Did you verify the write to your installation media? (here release details matter; as I don’t know your release I don’t know if this step was automatic for you, or manual)

The Lubuntu manual can be found here, and includes details on the steps I’m talking about (it’ll assume 20.10, but applies equally to 20.04; verification of media differs for 18.04)

2 Likes

Thank you for your reply. I downloaded 20.10 (Groovy Gorilla) and used Rufus to install it on the USB stick as a bootable drive. When I put the stick and reboot the device, then go to Boot, I don’t see the USB. I tried 2.0 USB, no difference. I can see the content of the USB stick (USB 3.0) if I choose “File Browser Add Boot Option”, but I don’t know which file to choose (if this even works). I’m stumped. What do you suggest?

I just tested the bootable USB drive on a desktop, and booted flawlessly into the Lubuntu desktop environment. So now I know the USB drive is working (good advice to check). I tried it again on the Dell Venue 10 Pro. Same thing. It won’t recognize the USB drive in the boot option (which right now only says “Windows Boot Manager” yet oddly does recognize the content of the USB drive when I go to the “File Browser Add Boot Option”. I’m not sure what to do.

As it boots on another device, I’d suspect your issue relates to your specific device: Dell Venue 10 Pro.

A quick scan showed it uses an intel atom which is amd64, but beyond the likely fix I’d expect to be a BIOS/uEFI setting, I have no experience with a like device sorry.

Thank you. It looks like what I need to find it a 32-bit UEFI bootloader, but it doesn’t look like Lubuntu (or any other current OS) supports it, so it appears that I am out of luck. :frowning_face:

The Venue 10 Pro only supports UEFI.
If your stick works elsewhere, you’ll need to play with the UEFI boot settings.

Thank you. I will try it. So this is done within Windows. Should I still try the latest 64-bit or use an older 32-bit of Lubuntu?

amd64 is fine.
It’s a UEFI issue.

1 Like

I see. Still no luck. I am not sure what to do to get BIOS to detect the USB. Actually, it does detect it when I go to “File Browser Add Boot Option”, but I don’t know which file to choose to get it boot there. It won’t boot on its own otherwise. Very frustrating. :frowning:

Did you read the .PDF I linked to, and did this text pop out?:

"After(…) powering on the tablet, as soon as the Dell splash screen is displayed, press the F12 on the keyboard or hold the Volume-Up button to bring up the one-time boot selection menu.

Use the arrow keys or system Volume-Up bottom to highlight the second “USB Storage Device” then press enter on the USB keyboard or press the Volume-Down button the system. After pressing enter or the Volume-Down button, the system will then boot to the USB flash drive and start the OS installer. Follow the OS installer prompts to complete the OS install process."

You should not worry about files etc. the USB should just boot.

That’s the problem. The USB does not boot at all. The only option I get is for Windows in the Boot menu. :frowning:

BTW, I tested the USB bootable drive on 2 different desktops and it boots right into Lubuntu, but not on the Dell Venue 10 Pro (I have 2 of them). I am totally stumped. :frowning:

Just for fun, I tested this on my own (Win10) Dell laptop.

F12 takes you into the setup. The first things to do are:
“Fast Boot”: disable
“Secure Boot”: disable.
This still doesn’t help, unfortunately (but removes other associated problems) :frowning:

What DID help was selecting “Boot List Option” as “Legacy”. Then it was possible to set the USB device as first boot, and: tadaa!
A perfect Lubuntu boot from the stick.

Now, my Dell is 4 years old, so it might not fit 100%. But at least you know where to look now. :slight_smile:

3 Likes

If you really have a 32-bit UEFI, you can try Fedora (which has a LXQt spin), which should have 32-bit UEFI support out of the box.

If it works and you really want *buntu on it, then you have to prepare the installation medium and installation. But you will need some time and endurance to get it all working.
There are also some guides, which show how to prepare an 64-bit installation media for an 32-bit UEFI.

2 Likes

Why are these the first steps to do?

  1. Secure Boot prevents the loading of unsigned kernel and drivers. If you install an unsigned, third-party driver (NVidia, Wireless, etc.), you can normally add the key via the MOK Manager and the driver will be loaded (estimated effort: 2 minutes). To say that disabling Secure Boot “removes other associated problems” is a special point of view.
  2. Why disable Fast Boot? What associated problems are avoided?

In which mode is this perfect Lubuntu boot? In the legacy boot mode or in UEFI boot mode?

I guess, Windows is installed in UEFI mode and therefore Ubuntu must be booted also in UEFI mode to have a working dualboot.

1 Like

It was a short change to legacy to change the boot order, then back to UEFI before booting from stick.

AFAIK, because fast boot is not a complete boot, but a sort of Win “pseudo-hibernate” boot which will inhibit other installations, as it’s closely linked to Win.
The machine needs to be completely turned off before attempting a Lubuntu installation.

Disabling secure boot was just a way of eliminating potential side effects. It can always be turned on again later.

When I booth the tablet, F12 does not work. To go to the Setup Utility, I have to press the Volume Down button. Once I am in, I do not have a choice for “Fast Boot”. The boot Menu only has the following options:

Network Stack: {Disabled]
File Browser Add Boot Option
File Browser Del Boot Option
Secure Boot: [Disabled]

Boot Option Priorities
Boot option #1 [Windows Boot Manager]

My choices are very limited on this device. It’s very frustrating. Any ideas?

According to the Dell .pdf I linked to, you should hold the Volume Up button during boot, not the Volume Down.
F12 probably only works with an external real keyboard.