Hibernate not working (Error name "org.freedesktop.DBus.Error.InvalidArgs") (Lubuntu 20.04 LTS) (Dell Inspiron 6400)

It appears that I am unable to hibernate my Dell Inspiron 6400 laptop with Lubuntu 20.04 LTS (dual boot with an old version of Windows). When I run the command

lxqt-leave --hibernate

, after confirming I do indeed wish to hibernate the laptop, I get the following output:

qt5ct: using qt5ct plugin
(0x7ffdecd81930) Debug: systemd: “CanHibernate” = “na”
(0x7ffdecd81930) Warning: ** Dbus error **************************
(0x7ffdecd81930) Warning: Error name “org.freedesktop.DBus.Error.InvalidArgs”
(0x7ffdecd81930) Warning: Error msg “No such interface “org.freedesktop.DBus.Properties””
(0x7ffdecd81930) Warning: ****************************************
(0x7ffdecd81930) Warning: dbusCall: QDBusInterface is invalid “org.freedesktop.ConsoleKit” “/org/freedesktop/ConsoleKit/Manager” “org.freedesktop.ConsoleKit.Manager” “CanHibernate”

Is there any remedy? I have also tried doing it via the desktop interface, and that does not work either. Judging by the output, there is a missing interface.

In case it were relevant in diagnosing the problem, here are some of my CPU details (extracted via

lshw

):

 *-cpu
      product: Intel(R) Core(TM)2 CPU         T7200  @ 2.00GHz
      vendor: Intel Corp.
      physical id: 1
      bus info: cpu@0
      size: 1927MHz
      capacity: 2GHz
      width: 64 bits
      capabilities: fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ht tm pbe syscall nx x86-64 constant_tsc arch_perfmon pebs bts rep_good nopl cpuid aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm lahf_lm pti tpr_shadow dtherm cpufreq

Postscript: I have not run previous Lubuntu releases on this particular laptop, so I have no idea whether this is a version-specific problem or a more general compatbility issue.

try this…

UPDATE (17:14 BST on 18th June): it looks like the solution referenced by Noumeno is not working for me because I appear not to have a swap partition. So, I think I will need to work-out how to create one and whether it is worth the trouble (my disk is already partitioned so that I can run Windows and Lubuntu).

This is the output I got when I ran cat etc/fstab

# /etc/fstab: static file system information.
#
# Use ‘blkid’ to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
#
UUID=xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx / ext4 defaults 0 1

[i.e.: there is only one UUID displayed (I have substituted ‘x’ for the actual UUID characters)]

Re Noumeno:

I have just tried both of the solutions proposed on the relevant page. Unfortunately, neither worked (even after rebooting). Perhaps, this may be because I have a dual boot (Lubuntu and Windows)? Or maybe, my computer is not powerful enough – this is the response I got when I tried sudo systemctl hibernate

Failed to hibernate system via logind: Not enough swap space for hibernation

Here you go:

Also works for 20.04. As you see it’s a bit more involved than just editing one file.

Your SWAP partition must be larger than your RAM. Also, a resume from Hibernate takes longer than a cold boot. Ask yourself if you need this functionality.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.