Applications not appearing in LXQT App Menu if installed from Snap or through Terminal

I am having an issue where only certain applications I install through Terminal will appear in the App Menu. I have tried restarting LXQT to no avail. Also nothing installed via Snap appears in LXQT app menu either.

Has anyone else experienced this and have a workaround?

I’ve seen this several times both within and without Lubuntu and every time it has been caused by the packager (especially on Snaps where it is often the case that packagers are less experienced) failing to provide a Desktop Entry, which is a required element of the whole Freedesktop Menu Specification which LXQt (and thus Lubuntu) as well as nearly every other Desktop Environment uses. Even the GUI for git which is maintained by the same folks that maintain git suffers this fate.

If this isn’t the case, I’d be absolutely shocked.

To be clear: this has nothing to do with Ubuntu, Lubuntu, LXQt, Snaps, deb packages, or the method to install such packages.


Thank you for the quick response. Snap aside, I downloaded a .deb of ungoogled-chromium and installed using apt ./ and it is also not appearing in the menu.

Which one? If it’s this one then you can unarchive the deb and the data archive within it and you’ll find usr/share/applications/chromium.desktop. This should be installed in your “Internet” category based on the fact that it has Category=Network.

Yeah that is it and it should be there but it isn’t. I will remove and try it again, but this has occurred with a few applications installed through terminal; no utilization of Snap.

I just installed it and it works for me. :man_shrugging:t4:


1 Like

Odd, I don’t know why it didn’t work when I did it. I have reinstalled using the same on you provided and it worked great. Thanks and sorry for the bother.

Also do yall have a donation page or anything? I could not find one on the site.

1 Like

It’s possible (but I think unlikely since this seems to be a patched Chromium and I know Chromium has a Desktop Entry) that you were using some earlier version that did not have the Desktop Entry. It’s also possible because of the sequence you need to have all the dependencies installed and configured that the installation process didn’t get completed right. I think that’s more likely. That doesn’t explain the Snaps, but my suggestion that less experienced folks tend to deal with Snaps may provide some explanation there.

We currently do not have a methodology of donation, though I know @tsimonq2 is working on that. Ideally, we’d like to have something generally within the availability of Lubuntu Members as a whole, much like there is for Ubuntu. For the time being, there are ways to support Simon and myself.

@slowmopickle ask and you shall receive. We now have donations available to Lubuntu via Patreon, Liberapay, and PayPal.

BTW, though this isn’t directly related to your current situation, since you have mentioned experienced in the past, I just learned that 18.04 snapd doesn’t set $XDG_DATA_DIRS to include /var/lib/snapd/desktop and that’s where snaps include their Desktop Entries, so that’s a thing, too.

1 Like

Hello, I want to start by saying this thread is the closest thing I have found online describing my issue wo starting a new thread…if I need to do that please let me know as I would not want to anger the support gods.
My issue the same; installed snaps are not making menu entries. My example here is flight-gear.
Thank you kindly in advance for any advice given.
soCiety -

Nevermind my previous comment. I read it a bit too quickly. This is clear about a Snap called FlightGear. It does have a Desktop Entry defined in the Snap and that does exist in the upstream code. There don’t seem to be any open issue that relates to this particular problem. And I guess that all makes sense because it Just Works™:

Thank you for your speedy reply, I appreciate you.
With all that being said, how do I fix the issue of snaps not showing up in my menu?
It appears that “search and rescue II” another flight simulator I am trying to install does not appear either…I would imagine if I install something else through the snap store I will have the very same issue with said application. However, the resounding response I get is “nothing is wrong” without addressing the fact that installed applications are not appearing in the menu even after reboot/logout.
Any advice is appreciated!
soCiety -

The only thing I can tell you is something is wrong with your system. How did you install? What version do you have?

I used a live CD I created from an Ubuntu mirror, my version is listed as follows:
Ubuntu 20.10 groovy
x86_64 Linux 5.8.0-36-generic
bash 5.0.17
LXQt 0.15.0

So are you saying that you did not use a Lubuntu image? Which mirror?

Note above I’m using 20.10.

I really suspect there’s something amiss with your install.

1 Like

I am not sure if this pertains in this case or not but if you change your shell to fish or zsh (chsh -s /usr/bin/fish or chsh -s /usr/bin/zsh), there is a bug and a possible workaround on AskUbuntu.