32-bit EFI hardware and grub-install

I’ve just tried installing Lubuntu 22.04 LTS onto an old Asus laptop which has 32-bit EFI but 64-bit CPU. On running the install, it fails at exactly the same point as @Fritz posted from the calamres log.

I’ve tried following the instructions from here, and after a false start complaining about missing efivars, (I think the fix was mount -t efivars none /mnt/[something I've forgotten]—closed the terminal now, and can’t find the exact location), I reran update-grub && grub-install, and eventually got a booting system.

But I don’t know what else was left for the installer to do, and how to ‘complete’ it. Can you shed any light? Also, if it’s useful to retest this ‘edge case’ of the failing install, happy to give that a go.


grub-install is the very last part. So that means you completed everything else right?

Interesting to read that someone else is having this problem too.

It is been some 5-6 months since I struggled getting pre-release candidate of Lubuntu Lunar onto 32-bit EFI hardware. I never got the finger behind it (very unlike me), and at some time the problem ‘suddenly’ disappeared in a new daily pre-release.

After 10 days of learning, compiling, debugging Calamares and the rest, it suddenly worked on the daily pre-release, and not on the one pre-released a few days earlier.

And to be honest, I felt that I’d lost the battle, gave up. Lost interest too, and moved on. A few weeks after Lunar was released, I tried do do a clean install of the then released version on the same 64-bit/32-bit EFI machine…and surprise, surprise… it failed again.

It is hard to blame anyone specific for his. 32-bit EFI is an anachronism, the number of people using Lubuntu is not very large (I guess, but I don’t know). Other distro’s with LXQt that I’ve tested don’t have this problem. So…it could be some kind of unforeseen side effect of a specific software combination, grub, Calamares, who knows.

I’ve tested several distros, and it failed (on my 64-bit/32-bit EFI machine) only with Lubuntu. And as I said, at some point in time, the daily pre-Lunar did not have the problem (which already existed on the release before Lunar as well), and after a while the release of Lunar version did.

So I repeat myself, I gave up. I decided that it was not worth spending more time on it. The 64-bit/32-bit EFI machine got Debian with LXQt, and still works fine as an extra machine in my garden shed. I use it when I am outside and need to look up something quickly, when I am too lazy to get the “official” laptop from the house.

I have been having warm sympathies for Lubuntu for many years (since 2011 or so). And I still do, but I have to admit that currently I am not using it on any of my primary machines. I only use it (every day though) on a machine to read my mails. I’ve decided that for the foreseeable future I will stick with Debian and LXQt. Lubuntu is certainly in the gene pool. I will keep on checking out what’s going on in the next release.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.