22.04 (upgrade from 21.10) on Lenovo x201 won't make it to graphical mode


I got this Lenovo notebook with Lubuntu 21.10. Today I upgraded to 22.04 following the manual.

After reboot however the notebook jumps after splash screen to graphical mode and then it all freezes at a random point of “early start”

  • first time when I already saw task bar
  • second time with just background and mouse arrow
  • third time in the middle of autostarting Skype

and all I can do is just turn the machine off by hardware POWER button. I can not even use my keyboard or touchpad or …anything. I tested it with just “clean notebook”, no peripherals attached. I tried this trick with Ctrl-Alt-Backspace or Ctrl-Alt-Fn keys (which are the only tricks I caught from my ex) to get to text, but with no avail. At random amount of time, but up to 15 seconds after splash screen disappears, it becomes unusable.

Any tips where to go when I can’t even provide you with Lenny’s requirements?

Thank you very much!

1 Like

First, thank you for answering! I mean it! :heart_eyes:

Function keys were (unfortunately) used in a correct way, but that’s very good hint for owners of newer devices. I’ve been there when I had to use someone elses’ newer machine :wink:

EscAdvancedroot was wonderful! This part should be pinned and added to inital Lenny advice. You wrote it just purrfectly :smirk_cat:.

Then I tried neofetch (another command I learned) and it says I have Memory 7747 MiB so I dare to not create this swap file.
But this helped me to get to text mode with init 3 magic (again, what I rememeber)… and now I had a chance to run those commands recommended by Lenny.

BUT I also did snap remove skype. It made the machine at least start properly.
And now it fails when I want to start Chrome browser… :face_holding_back_tears:

With your trick I tried to run it with the older 5.13.40-generic kernel, but it didn’t help either.

Your trick gave me a chance to at least save files from my hard drive before I format the machine and reinstall, but…

…once again I am very grateful for that Esc recovery though.


It might still be low RAM - Chrome has a reputation for being a RAM gobbler, and depending on how you’ve set your system up, you might be consuming a lot of RAM with background processes. You might boot the system up normally, and then open htop to see if your system’s pushing its RAM limits.

If everything seems OK, then yeah, your reformat and reinstall idea is good. When things go awry like this, reformatting and reinstalling like you suggested is usually the best idea, since it’s guaranteed to get the system into a known-good state (and if it doesn’t, we have a lot better chance of figuring out what’s gone wrong).

Very glad to be helpful! Thank you for your encouragement!


Note for the record.

@ArrayBolt3’s first post on this thread has been updated using detail from the last reply (now deleted)

1 Like

I know the Lenovo x201, in fact have used my own more than this box so far today. My own was an upgrade from 20.04 (and is running jammy or 22.04 too).

If my own did this, I’d likely try and shutdown or restart using SysRq commands direct to the kernel (I tried it just now on my x201 and they look partially disabled; though as mine is running & I don’t want to lose my session, I didn’t complete a REISUB/REISUO command) and not use the power button. Did you try alternatives to power? as inability to switch to text terminal (Ctrl+Alt+F4) or direct kernel to reboot (Alt+SysRq commands) reveals detail on the system state.

I’d next likely explore the hardware itself, ie. boot a system on thumb-drive & check out the machine is still reliable. For me that usually includes memory test, exploring drive health (SMART etc) and often opening the case & visual exploration looking for problems (on laptops wouldn’t be at this stage, but I’d likely look at what temperature it’s running at, fan speed etc prior to deciding to open the case). This is mostly in result of the hard crash you describe. esp. given you report issues when the older 5.13 is used. I personally wouldn’t troubleshoot the installed OS until you’re convinced the hardware is all good.

Once I was convinced the hardware was working as expected, I’d likely try booting to runlevel 1 (ie. text only), enable networking & then likely run sudo apt update to ensure all looks as I expected, then sudo apt full-upgrade to ensure the release-upgrade fully completed. I tend to do this on the first boot post release-upgrade before I attempt a GUI login. Ubuntu (and flavors like Lubuntu) have a recovery mode which is an easier method to get to runlevel 1 which can be used too; the network mode is the equivalent of what I’d do then root (drop to root shell), but I tend to think in generic GNU/Linux ways rather than Ubuntu.


I’m pretty sure you have to echo "1" > /proc/sys/kernel/sysrq from a root shell to get all Magic SysRq features to work.

Thanks for putting my post back where it looked nice and editing it. I didn’t like that I had to delete the old one and make a new one to fix a security hole I left in the guide, but I really didn’t want to leave a security hole in the guide. You made it so that everything is perfect.


Just FYI: You can re-install Ubuntu and flavors (ie. Lubuntu) without losing any data files, and it would be my first option if you had to re-install (in fact I think of it as my fallback if I have problems, or just don’t have the time to release-upgrade as it’s so fast).

In Lubuntu’s QA Testing Checklist I’m referring to the Install using existing partition and it’s what I’d perform if you felt you needed to re-install. Without the format (and re-use of existing partitions) user files aren’t touched, plus your manually installed packages are noted, and re-installed if available for the new release. If you have problems with that, the clean install (ie. with format) option is still available.


Before reinstalling I did huge backup. And then I tried to reboot. It worked for awhile and htop showed RAM was never exhausted over 3,5 GB of RAM of 8 even with running Chrome.

Then I ran aptitude mindlessly just to keep software nice and tidy, only to learn that libc++ was kept from upgrading. So I released it, upgraded and everything sems to be fine for ~30 minutes. Now I am typing from this machine even with Skype snapped back and running.

@guiverc @ArrayBolt3 thank you all again for teaching me all those neat tips and tricks and don’t just give up moral support! I owe you.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.