You cannot switch the input language in the user data questionnaire when installing the Russian version.

The only way to change the keyboard layout is to forcefully remove the Russian input method and leave only the English one.
After the installation is complete, it is also difficult to set up switching layouts.

Which Lubuntu release are you referring to?

  • Lubuntu 18.04(.5) LTS
  • Lubuntu 20.04(.1) LTS

Latest version from lubunru.me: Lubuntu 20.04.1 LTS.
You can try in emulators to simulate this situation with any other language.

@guiverc, @De-Luxis, please see my investigations of this bug on Can’t change keyboard locale on logon screen with lxqt (Lubuntu 19.04, 19.10 and 20.04), especially my comment about clean install: Can’t change keyboard locale on logon screen with lxqt (Lubuntu 19.04, 19.10 and 20.04)#10.
It seems like a root cause of this crazy bugs is some “problem” with installation media (since LXQT ever created), because layouts works perfect after manual installation of Lubuntu over “clean” Ubuntu (and it’s not a bug of sddm itself).

1 Like

locale in english , sddm takes the locale configuration to work. in the keyboard options put it in Russian. I have tried it several times and it works fine.

1 Like