Windows Linux network - sharing not working

My home network is
Notebook Win 11 Home, VirtualBox - Bodhi Linux
Notebook Win 10 Pro, Virtual Box - Bodhi Linux
PC Win 10 Pro, VirtualBox - Lubuntu (I tried several distros but Lubuntu seems to win!)

Win: Network - shows all the Win and Linux machines, I can access all the shared resources both on Win and Linux machines. NMAP and IP scanner show everything correctly.
Linux: Network - all the Linux machines sees one another and access all the shared resources. NMAP see all the machines.

Problem: there is NO WAY how I could get from Linux machine to Win shares. Even enabled old SMB 1.0/CIFS support on all Wins.

smb.conf (because the network is behind firewall, I used the simliest configuration possible.

[Global]

server string = Lubuntu sharick
workgroup = ALNILAM
security = user
netbios name = lubuntu
map to guest = Bad User
name resolve order = bcast host lmhosts wins
include = /etc/samba/shares.conf
----------
[Lubuntu share]

path = /shares/Sharick
force user = sambashare
force group = sambagroup
create mask = 0777
force create mode = 0777
directory mask = 0777
force directory mode = 0777
public = yes
writable = yes

Any advice?

Starting point for me is details of your software stack, where release details are critical (ie. age of stack). You’ve not provided any such details (except for windows where you did provide 10/11?)

lubuntu-22.04.4-desktop-amd64
bodhi-7.0.0-64-apppack, updated
linuxmint-21.2-cinnamon-64bit - updated

As you can see I tried even one more distro: Mint but the result is the same as described above

If this is happening on only the Linux boxes, this doesn’t sound like something specifically impacting Lubuntu.

Maybe it’s a firewall issue on Windows? I don’t recall if SMB is allowed (over the network) by default. Also don’t know how you’ve configured your Windows PC.

I also don’t recall how SMB shares get identified across the different file managers. Maybe that’s also where they’re different? They’re not going to magically appear in the file manager like in Windows?

I would double check your Windows settings to make sure you’re allowing the right ports and nothing is blocking from the Windows side of things.

Also, you can run something like…

nc -vz X.X.X.X 445

… and see if maybe that comes back with success. You put your Windows machine IP address at X.X.X.X.

I also don’t know how you’re testing what works and what doesn’t work. Are you just mapping the shares via the file manager and testing it that way or are you using some kind of commands in CLI?

You mentioned nmap which tells me using something like nc would show the same thing but again, I don’t know what you’re using to test.

Until you know the tcp port is accessible from the Linux boxes, there’s nothing to say it isn’t a firewall issue.

Please describe the steps you are taking to mount the SMB share on the Linux boxes. Also list commands if you are using them…

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.