WiFi disconnects often

I am facing an annoying issue with the WiFi. It disconnects every now and then. This issue seem to appear after a recent update, I suppose(started observing from 22nd Nov), did not face the problem before. It disconnects every 60 minutes, but quite often in every 20 or 30 minutes too . Details below:

1. Lubuntu Version:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.1 LTS
Release: 20.04
Codename: focal

2. Hardware Info:
DELL INSPIRON N4110

3. Log for network_manager_22:40_22:41_24_NOV:

tail -f /var/log/syslog | grep -i networkmanager

Nov 24 22:40:46 NetworkManager[896]: [1606236946.1536] sup-iface[0x559ca59c5910,wlp1s0]: connection disconnected (reason 15)
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.1976] device (wlp1s0): supplicant interface state: completed -> authenticating
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.1990] device (wlp1s0): supplicant interface state: authenticating -> associating
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.2119] device (wlp1s0): supplicant interface state: associating -> associated
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.2968] device (wlp1s0): supplicant interface state: associated -> 4-way handshake
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.2970] sup-iface[0x559ca59c5910,wlp1s0]: connection disconnected (reason -1)
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3017] device (wlp1s0): supplicant interface state: 4-way handshake -> disconnected
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3047] device (wlp1s0): Activation: (wifi) disconnected during association, asking for new key
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3050] device (wlp1s0): state change: activated -> need-auth (reason ‘supplicant-disconnect’, sys-iface-state: ‘managed’)
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3242] dhcp4 (wlp1s0): canceled DHCP transaction
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3243] dhcp4 (wlp1s0): state changed bound -> done
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3253] dhcp6 (wlp1s0): canceled DHCP transaction
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3253] dhcp6 (wlp1s0): state changed bound -> done
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3273] manager: NetworkManager state is now CONNECTING
Nov 24 22:40:46 user-PC dbus-daemon[895]: [system] Activating via systemd: service name=‘org.freedesktop.nm_dispatcher’ unit=‘dbus-org.freedesktop.nm-dispatcher.service’ requested by ‘:1.13’ (uid=0 pid=896 comm="/usr/sbin/NetworkManager --no-daemon " label=“unconfined”)
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3503] device (wlp1s0): no secrets: No agents were available for this request.
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3512] device (wlp1s0): state change: need-auth -> failed (reason ‘no-secrets’, sys-iface-state: ‘managed’)
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3571] manager: NetworkManager state is now DISCONNECTED
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3598] device (wlp1s0): Activation: failed for connection ‘WiFi-SSID’
Nov 24 22:40:46 user-PC NetworkManager[896]: [1606236946.3615] device (wlp1s0): state change: failed -> disconnected (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:47 user-PC NetworkManager[896]: [1606236947.7880] device (wlp1s0): supplicant interface state: disconnected -> scanning
Nov 24 22:40:48 user-PC NetworkManager[896]: [1606236948.4090] device (wlp1s0): supplicant interface state: scanning -> inactive
Nov 24 22:40:49 user-PC NetworkManager[896]: [1606236949.7879] device (wlp1s0): supplicant interface state: inactive -> scanning
Nov 24 22:40:50 user-PC NetworkManager[896]: [1606236950.3540] device (wlp1s0): supplicant interface state: scanning -> inactive
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.7875] device (wlp1s0): supplicant interface state: inactive -> scanning
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9633] device (wlp1s0): Activation: starting connection ‘WiFi-SSID’ (86e7abc9-cdb2-40f6-8a1b-9869829958eb)
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9635] audit: op=“connection-activate” uuid=“86e7abc9-cdb2-40f6-8a1b-9869829958eb” name=“WiFi-SSID” pid=1599 uid=1000 result=“success”
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9637] device (wlp1s0): state change: disconnected -> prepare (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9644] manager: NetworkManager state is now CONNECTING
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9653] device (wlp1s0): state change: prepare -> config (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9658] device (wlp1s0): Activation: (wifi) access point ‘WiFi-SSID’ has security, but secrets are required.
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9659] device (wlp1s0): state change: config -> need-auth (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9709] device (wlp1s0): state change: need-auth -> prepare (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9717] device (wlp1s0): state change: prepare -> config (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9729] device (wlp1s0): Activation: (wifi) connection ‘WiFi-SSID’ has security, and secrets exist. No new secrets needed.
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9730] Config: added ‘ssid’ value ‘WiFi-SSID’
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9730] Config: added ‘scan_ssid’ value ‘1’
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9730] Config: added ‘bgscan’ value ‘simple:30:-70:86400’
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9731] Config: added ‘key_mgmt’ value ‘WPA-PSK WPA-PSK-SHA256 FT-PSK’
Nov 24 22:40:51 user-PC NetworkManager[896]: [1606236951.9731] Config: added ‘psk’ value ‘’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.4548] device (wlp1s0): supplicant interface state: scanning -> authenticating
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.4574] device (wlp1s0): supplicant interface state: authenticating -> associating
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.4603] device (wlp1s0): supplicant interface state: associating -> associated
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5440] device (wlp1s0): supplicant interface state: associated -> 4-way handshake
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5515] device (wlp1s0): supplicant interface state: 4-way handshake -> completed
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5516] device (wlp1s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful. Connected to wireless network “WiFi-SSID”
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5520] device (wlp1s0): state change: config -> ip-config (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5529] dhcp4 (wlp1s0): activation: beginning transaction (timeout in 45 seconds)
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5714] dhcp4 (wlp1s0): option dhcp_lease_time => ‘86400’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5715] dhcp4 (wlp1s0): option domain_name_servers => ‘IPS’s DNS servers’ ##EDITED
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5715] dhcp4 (wlp1s0): option expiry => ‘1606323352’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5715] dhcp4 (wlp1s0): option ip_address => ‘192.168.254.2’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5715] dhcp4 (wlp1s0): option requested_broadcast_address => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5715] dhcp4 (wlp1s0): option requested_domain_name => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5715] dhcp4 (wlp1s0): option requested_domain_name_servers => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5716] dhcp4 (wlp1s0): option requested_domain_search => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5716] dhcp4 (wlp1s0): option requested_host_name => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5716] dhcp4 (wlp1s0): option requested_interface_mtu => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5716] dhcp4 (wlp1s0): option requested_ms_classless_static_routes => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5716] dhcp4 (wlp1s0): option requested_nis_domain => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5716] dhcp4 (wlp1s0): option requested_nis_servers => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5716] dhcp4 (wlp1s0): option requested_ntp_servers => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5716] dhcp4 (wlp1s0): option requested_rfc3442_classless_static_routes => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5717] dhcp4 (wlp1s0): option requested_root_path => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5717] dhcp4 (wlp1s0): option requested_routers => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5717] dhcp4 (wlp1s0): option requested_static_routes => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5717] dhcp4 (wlp1s0): option requested_subnet_mask => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5717] dhcp4 (wlp1s0): option requested_time_offset => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5717] dhcp4 (wlp1s0): option requested_wpad => ‘1’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5717] dhcp4 (wlp1s0): option routers => ‘192.168.254.254’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5718] dhcp4 (wlp1s0): option subnet_mask => ‘255.255.255.0’
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5718] dhcp4 (wlp1s0): state changed unknown -> bound
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5756] device (wlp1s0): state change: ip-config -> ip-check (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5817] device (wlp1s0): state change: ip-check -> secondaries (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5822] device (wlp1s0): state change: secondaries -> activated (reason ‘none’, sys-iface-state: ‘managed’)
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5831] manager: NetworkManager state is now CONNECTED_LOCAL
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5863] manager: NetworkManager state is now CONNECTED_SITE
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5865] policy: set ‘WiFi-SSID’ (wlp1s0) as default for IPv4 routing and DNS
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5881] device (wlp1s0): Activation: successful, device activated.
Nov 24 22:40:52 user-PC NetworkManager[896]: [1606236952.5895] manager: NetworkManager state is now CONNECTED_GLOBAL
Nov 24 22:40:54 user-PC NetworkManager[896]: [1606236954.8074] dhcp6 (wlp1s0): activation: beginning transaction (timeout in 45 seconds)
Nov 24 22:40:54 user-PC NetworkManager[896]: [1606236954.8088] policy: set ‘WiFi-SSID’ (wlp1s0) as default for IPv6 routing and DNS
Nov 24 22:40:54 user-PC NetworkManager[896]: [1606236954.8668] dhcp6 (wlp1s0): option dhcp6_name_servers => ‘fe80::1’
Nov 24 22:40:54 user-PC NetworkManager[896]: [1606236954.8669] dhcp6 (wlp1s0): state changed unknown -> bound
Nov 24 22:40:57 user-PC whoopsie[1154]: [22:40:57] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/21
Nov 24 22:40:57 user-PC whoopsie[1154]: [22:40:57] Not a paid data plan: /org/freedesktop/NetworkManager/ActiveConnection/21
Nov 24 22:40:57 user-PC whoopsie[1154]: [22:40:57] Found usable connection: /org/freedesktop/NetworkManager/ActiveConnection/21
Nov 24 22:41:04 user-PC systemd[1]: NetworkManager-dispatcher.service: Succeeded.

network_2

network_3
Happened again!!

Info on the card and drivers would be helpful. lspci -nnk or lshw should do the trick.

Sure!!

01:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a] (rev 34)
        Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN [8086:5325]
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

So I searched for “iwlwifi disconnect” and came up with a whole hoarde of results. Apparently, it’s a known thing. Lots of suggestions here:

P.S. I edited that for you for a couple reasons:

  1. I used code markup rather than quote markup. This has the benefit of preserving the way things actually look on the command line. Ultimately, it’s more readable, especially with things like lspci.
  2. I removed the command you used, most importantly because you shouldn’t sudo when you don’t need to and you don’t need to with lspci. Ever.
  3. You didn’t need to include all of the information about your system, just the bits relevant to the topic at hand, i.e the wifi card.
3 Likes

I’ll also add that there’s one similar bug that seems to be related to firmware:

And in an even crazier scenario, tweaking a TCP parameter to get around issues with misbehaving routers might be helpful, too:

3 Likes

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.

@marco_olsen since I’m sure others will have the same problem and since the post you marked as a solution included lots of possibilities, could you let us know what the solution you used was and then mark that as the solution?

After going through the links provided, I realized the problem is with the power management option. Then, I remembered I had installed a package “TLP-RDW package”, just to check if it works(its especially for Thinkpad users), after which I removed this package and rebooted. I was relieved that issue had be solved by this, but unfortunately did not resolve.

Then, I tried the very first option in the initial link, i.e. editing the “/etc/modprobe.d/iwlwifi.conf” file. The problem has not occurred for now, will post if issue persists.

@wxl Thank you for the solution links.

@marco_olsen So the correct answer is to add the line

options iwlwifi 11n_disable=1 power_save=0 power_level=5 bt_coex_active=0

to the end of /etc/modprobe.d/iwlwifi.conf, correct? If so, please mark this as the solution.

Also, I suspect you need to unload/reload the module (sudo modprobe -r iwlwifi; sudo modprobe iwlwifi) or restart the machine for it to take effect.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.