What Version of Lubuntu Do I Have?

Hello to all. I’ve been trying out different commands in the terminal to figure out which version of Lubuntu I have. I’ve been using this command:

lsb_release -a

And this is what I got back:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.3 LTS
Release: 22.04
Codename: jammy

I’ve also tried:

lsb_release -a
lsb_release -c
lsb_release -i
lsb_release -r
lsb_release -as
cat /etc/issue

As well as many more that I can’t even remember. But it does not refer to Lunbuntu or the release. I guess that I have:

Lubuntu 22.04.3 LTS? I this correct? I have tried so many different commands and the thing that surprises me the most is that Lubuntu refuses to admit that it is Lubuntu! It doesn’t even show it in the Discover Software application/package manger or whatever it’s called.

Here is my question in a nutshell. Is there any terminal command I can use, as a universal tool for all distibutions, that will tell me the exact distribution and flavor/flavour?

Any help I receive would be very much appriciated. Cheers!

Written: Sep 07, 2023, 07:40:11

Your release is Lubuntu 22.04 LTS, and your codename jammy, as you worked out.

A simple tool included by default on recent releases of Lubuntu is neofetch which provides a fair amount of system detail, for mine it’ll show

guiverc@d7050-next:~$   neofetch --off
OS: Lubuntu Mantic Minotaur (development branch) x86_64 
Host: OptiPlex 7050 
Kernel: 6.3.0-7-generic 
Uptime: 2 days, 32 mins 
Packages: 3207 (dpkg), 11 (snap) 
Shell: bash 5.2.15 
Resolution: 1920x1080, 1920x1080, 1920x1080, 1280x1024, 1280x1024 
DE: LXQt 1.3.0 
WM: Xfwm4 
WM Theme: Pills 
Theme: Greybird [GTK2/3] 
Icons: oxygen [GTK2/3] 
Terminal: qterminal 
Terminal Font: IBM Plex Mono Text 14 
CPU: Intel i5-6500 (4) @ 3.600GHz 
GPU: AMD ATI Radeon HD 5000/6000/7350/8350 Series 
GPU: Intel HD Graphics 530 
Memory: 9289MiB / 15842MiB 

I used the --off option so I didn’t get the default graphic logo.

Lubuntu is a Ubuntu system, using the Ubuntu base packages, thus some tools will identify themselves as [running] Ubuntu; your installation media can be viewed on a Ubuntu system via installer logs (see /var/log/installer/media-info), but that is not universal.

No there isn’t one. If using Ubuntu, commands will be consistent for those systems, and very similar to Debian too, being its part of the same ‘stream’, but what packages & locations will differ if moving further afield (OpenSuSE, Fedora etc) though some will contain the same detail with minor differences (sorry I’m not going to turn on another system to provide evidence). If you move across to BSD; expect more differences.

Many of those differences are hard coded into tools like neofetch which allows easy comparison, but even it will have problems as details (locations & assumptions in the code) change over time, and the hardcoded nature of neofetch can be incorrect or outdated (thus misleading). I still feel it’s a useful tool (just don’t take it as gospel).


Guiverc, many thanks! This is just what I needed. This is the only program (I have found, no, you found) that will tell me the “flavor” and other very helpful things. Many thanks for your help.

I would have responded sooner but my Lubuntu computer had a major upset. It seems that I accidently removed the taskbar when I was trying to uninstal some “widgets” and couldn’t get it back.


If you made a change to a panel, and it disappeared, a logout & login again should cause it to restart.


I tried that and it did work. It did say that this couldn’t be undone but I thought I was clicking on one thing and it ended up being another.

You knew already how to get the version:

lsb_release -a

The following command line can detect the installed desktop program packages (meta packages) in Ubuntu family flavours.

LANG=C apt-cache policy *-desktop|grep -B1 'Installed: [^(]'

[^(] is to avoid listing the desktop packages that are available but not installed “Installed: (none)”.

If you have Lubuntu, the package lubuntu-desktop should be listed.

If you want to know more details about your installed system (for example for debugging), you can install and run the Ubuntu Forum’s system-info script.


Thanks for the reply Sudodus, I haven’t been here in a few weeks. I still prefer “NeoFetch” because it has more information than any terminal command I’ve found. Cheers!


Copy and paste this command into the terminal and then enter your password.

sudo lshw > lshw.txt

When completed look in your home folder for a file listed as lshw.txt.

The command below displays the same information although leaves out the personal information that doesn’t need to be displayed for everyone to see.

sudo lshw -sanitize > lshw.txt

These commands will tell you everything about your computer and than some.

1 Like

You can also try the command line tool inxi for system info. (Although I note it too doesn’t report “Lubuntu”, but “Ubuntu”.)

I can’t remember now if it comes pre-installed or if I installed it myself. You can always:
sudo apt install inxi

You can add “suffixes” (can you tell I’m not a CLI expert?) like -b for detailed system info, or -A for just audio details, -G for just graphics details etc. And even -z for to exclude private info. (inxi -h for the full list of commands.)

inxi -b
me@me:~$ inxi -b
  Host: me Kernel: 6.2.0-33-generic arch: x86_64 bits: 64
    Desktop: LXQt v: 1.2.1 Distro: Ubuntu 23.04 (Lunar Lobster)
  Type: Laptop System: LENOVO product: 82V7 v: IdeaPad 1 15IGL7
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0T76467 WIN
    serial: <superuser required> UEFI: LENOVO v: KKCN14WW date: 09/09/2022
  ID-1: BAT0 charge: 43.2 Wh (100.0%) condition: 43.2/42.0 Wh (102.9%)
  Info: dual core Intel Celeron N4020 [MCP] speed (MHz): avg: 1412
    min/max: 800/2800
  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: driver: X: loaded: modesetting
    unloaded: fbdev,vesa dri: iris gpu: i915 resolution: 1: 1366x768~60Hz 2: N/A
  API: OpenGL v: 4.6 Mesa 23.0.4-0ubuntu1~23.04.1 renderer: Mesa Intel UHD
    Graphics 600 (GLK 2)
  Device-1: Realtek driver: rtw89_8852be
  Local Storage: total: 119.24 GiB used: 27.26 GiB (22.9%)
  Processes: 224 Uptime: 3d 7h 32m Memory: 7.31 GiB used: 6.28 GiB (85.9%)
  Shell: Bash inxi: 3.3.25
inxi -A
me@me:~$ inxi -A
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    driver: snd_hda_intel
  Sound API: ALSA v: k6.2.0-33-generic running: yes
  Sound Server-1: PipeWire v: 0.3.65 running: yes
inxi -G
me@me:~$ inxi -G
  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: driver: X: loaded: modesetting
    unloaded: fbdev,vesa dri: iris gpu: i915 resolution: 1: 1366x768~60Hz 2: N/A
  API: OpenGL v: 4.6 Mesa 23.0.4-0ubuntu1~23.04.1 renderer: Mesa Intel UHD
    Graphics 600 (GLK 2)

More info:


To add to this, I’ll share my preferred inxi command - as it pretty much shows everything:

inxi -v 8

Well, I actually prefer -v 7 but it’s a middling difference. See man inxi for more information about running it this way.


Bartman, many thanks. This is good to know, and very quick and useful. I just tried it and it works nicely. I like having a “hard copy” or file for somehting that I want to know but has lots of information to remember. Cheers!

1 Like

Pan4b, thanks. I have inxi and have use it and find it useful but it didn’t get me what I was looking for and that was the flavor of Ubuntu (Lubuntu) that I was using. I found that the small program, which can be run from the terminal also, NeoFetch comes in quite handy and I have since used it on other distros also. Cheers.

1 Like

@JeffRedd You’re welcome. Yeah, inxi at least tells you the version but doesn’t differentiate Lubuntu from Ubuntu. No idea why Neofetch can pull that off but inxi can’t. I usually install both.

I already covered this

An example of an error was Fuduntu, which was hard coded in neofetch to report itself as a Ubuntu system (it wasn’t, being a Fedora based system). I reported the error to the developer of neofetch and the hard coding was altered so newer versions of neofetch report any user running it on the now defunct Fuduntu correctly.


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.