VirtualBox Guest Share Not Mounting - Now in Emergency Mode

I’ve just installed lubuntu-22.04.3-desktop and I’m trying to get VirtualBox Guest tools to work in Lubuntu, specifically the shared folder to the host OS (Windows).

What I’ve tried so far:
Enabled a shared folder in VirtualBox, set automount and given everyone full permissions to the folder.

From within Lubuntu:
sudo apt-get install open-vm-tools open-vm-tools-desktop
sudo mkdir /mnt/hgfs

I then followed the instructions below:

Edit /etc/fstab and add:
vmhgfs-fuse /mnt/hgfs fuse defaults,allow_other 0 0

Lubuntu now says I’m in emergency mode and will not load the desktop.

So I’ve well any truly messed up the OS. I think the part that killed the OS was editing the fstab file. Any ideas on what I’m doing wrong, and how I can get the folder to auto mount from within Lubuntu?


I’m not quite sure what is your problem exactly.

Presuming that Lubuntu is running OK, inside VirtualBox, right?

Boot the VM from the ISO file and mount the Lubuntu system partition. Then go and comment out the “vmhgfs-fuse” entry from the fstab file. After that you can reboot Lubuntu and should have a “normal” working Lubuntu.

Some tips:

  • When “following instructions” please make sure to follow instructions made vor VirtualBox and not VmWare
  • Install the Virtualbox guest additions inside the VM
  • Add the shared folder from the Virtualbox settings, when the VM is powered off. You do not need to edit the fstab manually.

Thanks. I’ll have a go.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.