Using mono on Lubuntu aarch64

Hi, I am trying to execute my C# program on Lubuntu 22.04 and 24.04 using mono.
I was able to run my C# program on AMD64 Lubuntu 22.04 and 24.04.

However, when I tried to run it on ARM64v8a, aarch64, it didn’t work properly with this error message;

$ mono MyProgram.exe

And then I got this;

Unhandled Exception:
System.ArgumentException: A null reference or invalid value was found (gdi+ status: invalidparameter)

Weird thing is, when I tried to run my c# program using mono on GNOME Ubuntu 22.04 or 24.04, which are desktop version, on my ARM64 device, it works properly in both OS.

What’s the problem?
Can you help me?

I suspect some sort of problem with cross compiling but you’d need to check with a C# developer, particularly one familiar with cross compiling on Mono in Linux.

This is not really the right forum for that. It’s possible such a person exists here, but they could also exist any number of places. Similarly, a person interested in livecoding might exist here, but this would not be the place I would expect to find the largest number of people with the most experience in the subject.

You should ask at the appropriate Mono forum. They suggest Stack Overflow.


Ok, it would be a better idea.