USB WiFi adapter not working

New to linux, decided to install lubuntu on old laptop to get acquainted with the OS so pretend that I’m an idiot.
Here’s my problem: the OS won’t recognize my USB WiFi adapter, I tried some solutions already but still no luck. I cannot plug an Ethernet cable so downloading packages will only be possible after I fix the WiFi.
so far I figured a couple of commands that people always ask so I’ll be providing their results already:


usb 5-4: RTL8188FU rev B (SMIC) 1T1R, TX queues 2, WiFi=1, BT=0, GPS=0, HI PA=0
[ 1602.008039] usb 5-4: RTL8188FU MAC: 74:ee:2a:5d:3f:ef
[ 1602.008045] usb 5-4: rtl8xxxu: Loading firmware rtlwifi/rtl8188fufw.bin
[ 1602.008111] usb 5-4: Direct firmware load for rtlwifi/rtl8188fufw.bin failed with error -2
[ 1602.008119] usb 5-4: request_firmware(rtlwifi/rtl8188fufw.bin) failed
[ 1602.008123] usb 5-4: Fatal - failed to load firmware
[ 1602.008145] rtl8xxxu: probe of 5-4:1.0 failed with error -11
[ 2895.960981] perf: interrupt took too long (2531 > 2500), lowering kernel.perf_event_max_sample_rate to 79000
paul@paul-ieg41tm7:~/Documents/Linux_Android Driver$


Bus 005 Device 004: ID 090c:6300 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) USB2.0 Card Reader
Bus 005 Device 006: ID 0bda:f179 Realtek Semiconductor Corp. RTL8188FTV 802.11b/g/n 1T1R 2.4G WLAN Adapter
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 10c4:8108 Silicon Labs USB OPTICAL MOUSE
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 413c:2106 Dell Computer Corp. QuietKey Keyboard
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub"

apparently I need to install something called ‘make’ too.

I guess your stick is relative old and a bit exotic, probably better supported out-of-the-box in the IoT domain (e.g. early Raspberry Pi’s).

Since your system is for learning, you could experiment with this…


“You’re on your own, kid”

Sorry, I did not read in time that the system does not have an actual internet connection. This complicates things a lot. It is doable, but you need another system to build the kernel driver. Better buy some other stick which is supported. It is more cost efficient (time vs. money).

To give you some soul comfort… I bought a $200 laptop a year ago (from Asus), and its onboard WiFi adapter was not recognized by most Linux ISO’s that I tried from stick (Lubuntu, Ubuntu, Debian, SparkyLinux got it though!). Not because the h/w was old, it was just too new. I got there in the end, but it was quite a journey. Now, a year later the needed driver is included, so I am fortunate. Less hassle when I need to reinstall the OS.

The starting point, at least to me, is what release you’re using.

Ubuntu LTS releases have kernel stack choices; with an older & newer stack being provided (plus OEM stacks for some specific hardware). For older hardware the older kernel stack is often an easy fix, likewise for newer hardware using the newer stack is often an easy fix. With Lubuntu, installation media itself dictates which kernel stack you’re using by default.

We however don’t have any clues as to what you’re using, as you only mention Lubuntu.

I can clone git from windows and transfer the files via pendrive, the problem is that I’m new to linux so I don’t really know what I should get, how to install or where I should put them as I wasn’t able to figure out where the equivalent of ‘c:\windows’ is yet (if there’s such thing on linux) plus there are some commands that ask me to install first so I’m lost.

is this what you mean:

Linux paul-ieg41tm7 6.2.0-26-generic #26~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Jul 13 16:27:29 UTC 2 x86_64 x86_64 x86_64 GNU/Linux


I only want to touch on this portion of your post, as I’m not sure what to do with the rest.

You can sometimes set your cell phone to hotspot mode and connect it via USB. This will give you internet access and this typically works with Linux - if your phone and carrier support it.

Now, as to your actual question. I often find that it’s easier to just find and buy a USB wireless adapter that is known to work with Linux and to use that rather than mess around. Once you find one that works out of the box, buy a spare.

(I can make a suggestion if that’s the route you’d like to take.)

1 Like

If you have another system with enough ram memory (at least 8 GB), you could try to run a rolling release distribution in a virtual machine there (Arch, EndeavourOS to give a suggestion). Or another distro that is more edgy (SparkyLinux, or many others). Desktop metaphor does not matter, just that its kernel is newer, and maybe the stick is supported. I prefer VirtualBox, since its USB tunneling from the host to the guest is easy. If you are lucky, the stick will be live after you established the tunnel.

Once you’ve managed to see the stick working as expected, you can analyze which kernel mode is involved, and copy it to the old laptop. Ask for help, if you got the stick working on the guest, if needed.

If you’re less lucky, you can try to build and install a relevant kernel module. Ask for help if needed.

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.