Unable to reset password in Lubuntu 20.04

Just installed Lubuntu 20.04 LTS and chose mypassw as the password. But for some reasons unknown to me the systems keyboard language was set to Esperanto. I remember very clearly setting it to English ( US ), so eventually my password got saved in Esperanto and I wasn’t able to view it cause apparently Lubuntu doesn’t provides a view password option.
So now I am trying to change it to something simpler, but it isn’t changing at all.
Here’s what I am doing >>
In the terminal >>

sudo passwd root

This asks for current password, so I go to Keyboard and Mouse settings, under the keyboard layout tab, chose Esperanto as the lang and came back to termnial and typed mypassw which got converted into Esperanto ( but again can’t see ). It works and the terminal asks for new password, went back to Keyboard and Mouse settings, chose English ( US ) as the lang again, clicked apply. Went back to terminal and typed my new password hello and pressed Enter, password update message is shown, but when I’m running any commands like

sudo apt get update

etc. etc. and entering the password as hello it’s showing wrong password, but when I change the Keyboard lang to Esperanto and type my old password which was mypassw, everything works.

TL;DR — > System password got saved in a language called Esperanto and is not changing.

Sorry I have no experience with other languages, or keyboards. But the command

sudo passwd root

will cause a change to the ‘root’ account password, and not change the user password. (FYI: sudo passwd would have the same effect)

Type in whoami as a command, then sudo whoami and you’ll see a different result.

You however specified in your command you want to change the of the ‘root’ account by using it as a parameter (the sudo giving you rights to do this), which I suspect was not what you intended.

If you want to change your own password, just use

passwd

1 Like

I want to change password of root. Also I think there is a problem with saving of languages in Lubuntu. Cause it’s defaulting back to Esperanto again and again.

I want to change password of root ( I am the sole user of my pc ). My problem is that every time I am changing or setting the password, it’s not getting updated at all.
sudo whoami shows root

Maybe after all you need change user password, because when you run any command with sudo, it asks user password, for example - sudo apt get update
Also, when you run command with sudo, it has “root envirement”, so why, of course, sudo whoami returns root

After all, in a simple Lubuntu installation you even shouldn’t “unlock” root user (with setting up password for root), except for special cases

Meanwhile, there are actually a bug with swithcing non-English layouts in some places (for example, log on screen) after installing from LiveCD since Lubuntu 19.10, please see Can’t change keyboard locale on logon screen with lxqt (Lubuntu 19.04, 19.10 and 20.04)

1 Like

Still after seting up layouts again in keyboard settings all works normally in GUI terminal (and after dpkg-reconfigure keyboard-configuration - for working in tty)

I’m not having problems with the language, keep the window open, delete Esperanto, and if you have more languages, put them first.

do a

sudo su

then

passwd yourusername

2 Likes

fixed it : had to reinstall the system with American English as the main lang

1 Like

fixed it : had to reinstall the system with American English as the main lang ( both keyboard lang and locale )