Unable to install Synergy software on lubuntu

Hello,
I’ve just installed lubuntu on my laptop, and I’m very excited for its performance. LinxMint wad too slow.

Now, I’m trying to install Synergy (a nice software for sharing mouse and keyboard with other pc with different Operating System).

I’ve tried the three package for ubuntu amd64 found here, but i had the same problems in all of them.

from the terminal I wrote

sudo dpkg -i synergy_1.8.8-stable+dfsg.1-1build1_amd64.deb

result:

Selecting previously unselected package synergy.
(Reading database … 315650 files and directories currently installed.)
Preparing to unpack synergy_1.8.8-stable+dfsg.1-1build1_amd64.deb …
Unpacking synergy (1.8.8-stable+dfsg.1-1build1) …
dpkg: dependency problems prevent configuration of synergy:
synergy depends on libavahi-compat-libdnssd1 (>= 0.6.16); however:
Package libavahi-compat-libdnssd1 is not installed.
synergy depends on libqt4-network (>= 4:4.5.3); however:
Package libqt4-network is not installed.
synergy depends on libqtcore4 (>= 4:4.8.0); however:
Package libqtcore4 is not installed.
synergy depends on libqtgui4 (>= 4:4.8.0); however:
Package libqtgui4 is not installed.

dpkg: error processing package synergy (–install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.24-1ubuntu3) …
Processing triggers for mime-support (3.64ubuntu1) …
Processing triggers for man-db (2.9.1-1) …
Errors were encountered while processing:
synergy

so i typed

sudo apt --fix-broken install

result:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
libqt5opengl5 linux-headers-5.4.0-42 linux-headers-5.4.0-42-generic linux-image-5.4.0-42-generic linux-modules-5.4.0-42-generic
linux-modules-extra-5.4.0-42-generic qtgstreamer-plugins-qt5
Use ‘sudo apt autoremove’ to remove them.
The following packages will be REMOVED:
synergy
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 4.071 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database … 315673 files and directories currently installed.)
Removing synergy (1.8.8-stable+dfsg.1-1build1) …
Processing triggers for mime-support (3.64ubuntu1) …
Processing triggers for man-db (2.9.1-1) …
Processing triggers for desktop-file-utils (0.24-1ubuntu3) …

could someone kindly give me some suggestions?

many thanks
t.

You haven’t mentioned which release of Lubuntu.

Qt4 is EOL and was removed from [future releases of] Ubuntu in 2019 (upstream announced EOL in 2015, though both Debian & Ubuntu supported it until 15-Mar-2019). For more details refer https://discourse.ubuntu.com/t/removing-qt-4-from-ubuntu-before-the-20-04-release/12295.

The package, if maintained should have been ported to Qt5 (introduced 19-Dec-2012) before now.


FYI: I looked up on askubuntu & I do see PPAs or 3rd party repositories that contain some Qt4 packages for focal/20.04, but I’m not willing to provide those details as I can’t vouch for the source.

thank @guiverc,
I’ve “lUbuntu 20.04.1 LTS”.

So there is no solution, I seem to understand.

now I’m trying “barrier”, really similar software, but it seems with some big bug.

If there is a bug, it’s that the Synergy software coders are still using an EOL/depreciated toolkit/library (Qt4) that reached EOL in 2015. If you’d like to file a bug, please file it with Synergy (they had from 2012-2019 to switch to the upgraded Qt5, but either haven’t or you’re trying to install a depreciated package).

My added comment was a clue that I did see where people have packaged Qt4 for 20.04/focal, however PPAs are 3rd party software sources, so you need to know the person/group who packaged it to the extent that you can trust their work, know they are skilled & will maintain it, fixing security flaws etc. I don’t know the PPAs I saw, thus I won’t put my name to them (recommend or mention them). You can look for yourself & decide if you trust them (why I left the clues/breadcrumbs as to how they maybe found)

The best fix though is finding a supported program to achieve what you want. The synergy package you have appears to be unmaintained/abandoned & thus is it secure/trustworthy? or you’re trying to use an older un-patched package and thus should instead find a recent version using Qt5. My 2c/opinion

2 Likes

It seems to me that Synergy is no longer a fully open source product which is evident in that their downloads page requires an account and/or a license purchase. Either way, you should contact Symless for support.

2 Likes

Thank you all, for the longs explanation.

Yes, it’s no longer open source.

So, I thought that the only way would be to compile the source code that I found here.

I’ve done this, following the instruction, I’ve run the command

sudo apt install qtcreator (ecc…)

and it seems finished correctly, but now I do not find the next step to do. :sweat_smile:
should it already be installed? Because I do not find nothing.

sorry for the banal questions, but I’m new to this world :slightly_smiling_face:

It seems the next step before following the Compile Steps section you need to do " Edit the Qt kit “Environment” field under Tools -> Options -> Build & Run -> Kits and add BOOST_ROOT=/home/<user>/boost."

Again, if you need further help, we’re not the best resource. Contact Symless.

2 Likes

At the end, I’ve choose to use “Barrier”, a very similar software, but open source with a good community behind, where I’ve also found a way to override a big bug in it.

3 Likes