Two internal drives mounted, but can't see them under devices or access them, error message can't mount file and path not mounted

Hello Everyone,

I would like some help with my situation; I recently installed Lubuntu on an old laptop which has two internal drives, one SSD and a bigger one HDD. I managed to install the OS on the SSD and it seems to be working (I am using it now). However I am not able to access either drive from the file explorer, event though they seem to be mounted; I get the following error messages one after the other on both drives:

image

Not sure if this should have need sorted out during the installation of the OS; or this can be arranged now that the installation is complete.

Thank you

System information below:

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.3 LTS
Release: 22.04
Codename: jammy

ux310ua
description: Computer
width: 64 bits
capabilities: smp vsyscall32
*-core
description: Motherboard
physical id: 0
*-memory
description: System memory
physical id: 0
size: 4GiB
*-cpu
product: Intel(R) Core™ i5-6200U CPU @ 2.30GHz
vendor: Intel Corp.
physical id: 1
bus info: cpu@0
version: 6.78.3
size: 2702MHz
capacity: 2800MHz
width: 64 bits

Filesystem Size Used Avail Use% Mounted on
tmpfs 377M 1.7M 376M 1% /run
/dev/sdb2 117G 9.2G 102G 9% /
tmpfs 1.9G 0 1.9G 0% /dev/shm
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
/dev/sdb1 300M 6.1M 294M 3% /boot/efi
/dev/sda1 458G 36K 435G 1% /mnt
tmpfs 377M 80K 377M 1% /run/user/1000

this has been posted before and not just for lubuntu. You’re looking at the actual drives as listed from the desktop icon “computer” (the one with the word “volume” in it works, the other two don’t as they are just references to the actual physical drives), rather than the drive contents from the left panel in “computer” under devices or places for list view or under directory view, or indeed the home icon (that is listed on your desktop with the login name)

1 Like

hello,

Thank you for your reply, I understand what you are saying but unfortunately the drives are not listed under devices in the left panel, sorry last screen shot was not informative enough.

image

okay, right, under devices would only show the secondary drive, so you cannot access the second drive, the hdd one, sda1 (looking at the list you posted, you installed to sdb, which is technically the physical secondary drive, but is the logical primary as it was installed to). Load (install if necessary) gparted and see if it is mounted and what’s it formatted to. The larger drive on sda is only at 1%, so i’m guessing it wasn’t formatted, hence doesn’t show (hopefully you didn’t have anything on it before you wanted!).

thank you for answering; I beleive it is formated to the right file sytem :

image

below details from my /etc/fstab, where I tried to ensure that it auto mounts (got UUID from blkid etc and followed instructions)

UUID=0D2C-4EF9 /boot/efi vfat umask=0077 0 2
UUID=fe286bf7-01f7-49a2-9a02-a2268314692b / ext4 discard 0 1
/swapfile swap swap defaults 0 0
UUID=12985dcd-de6f-4299-bb8e-aff915661b6f /mnt/data ext4 defaults 0 2

hmm, that does look a bit funky, the status is not mounted to the username, and not sure what the flags for (on this machine, second drive is mounted on /media/gavin/… and no flag). Is there anything on the drive? If not (and that’s the only partition on that drive), unmount it, new drive partition table on it, then format it, no flags

still no luck…

Well looks like I broke something ! I rebooted think things would good; can’t boot anymore:.

Something happened as it was trying to boot on the drive I was working on( recognize the uuid).

No worries was fresh install no data.

—————————————-

OK OK OK OK OK

Starting Network Name Resolution…

Stopped Recovery mode menu.

Mounted Mount unit for bare, revision 5.

Mounted Mount unit for core20, revision 1974.

Mounted Mount unit for core20, revision 2015.

Mounted Mount unit for firefox, revision 2987.

OK

OK

Mounted Mount unit

for gnome-3-38-2004, revision 143.

Mounted

Mount unit

for gtk-common-themes, revision 1535.

Mounted Mount unit for snapd, revision 19457.

Mounted Mount unit for snapd, revision 20290.

OK

UK

Mounted Mount unit for firefox, revision 2987 via mount-control.

Finished Load Kernel Module configfs.

Finished Load Kernel Module drm.

Finished Load Kernel Module efi_pstore.

OK OK OK

Finished Load Kernel Module fuse.

Stopped Load/Save Screen Backlight Brightness of leds:asus: kbd_backlight.

Reached target Mounted snaps.

Started Network Name Resolution.

Reached target Host and Network Name Lookups.

DK

Finished Load AppArmor profiles managed internally by snapd.

Timed out waiting for device /dev/disk/by-uuid/12985dcd-de6f-4299-bbe-aff915661b6f.

[DEPEND]

Dependency failed for /mnt/data.

[DEPEND]

Dependency failed for Local File Systems.

[DEPENDI

Dependency failed for File System Check on /dev/disk/by-uuid/12985dcd-de6f-4299-bb8e

OK

Stopped Dispatch Password Requests to Console Directory Hatch.

OK

Stopped Forward Password Requests to Hall Directory Hatch.

Starting Set console font and keymap…

OK

1

1

Closed syslog Socket, started Emergency shell.

starting Uncomplicated firewall…

777

OK

Finished Uncomplicated fIrewall.

OK

Reached target Preparation for Network.

OK

Finished Set console font and квупар.

type “journalct1 -xb” to view

sustem logs, “sustencti reboot” to reboot, to boot into default mode, Press Enter for maintenance (or press Control-D to continue): -

arh , fooey. I had a thought, did you manually partition this install and do you remember which drive the bootloader was put on?

I was surprised by this crash ; during Install of OS I ensured that every thing was automatic (guided and erase all disk); I only ensured I chose the ssd and not the hdd.

So all the boot etc was on the ssd by default. Weird how after unmounting hdd; reformatting ; removing the flag, remounting then rebooting I ended up being locked out…

Oh well… thank you for your input; I learned a few things.

sorry to read it went pear shaped, that shouldn’t have happened, but hey, linux, after 10+ years when i look back, the knowledge came a lot from when it went pear shaped! From this point, as it was a clean install, then personally I’d start over.

1 Like

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.