Today's .iso is wonky

Version: 20220323.1

Now, the manifest diff clearly shows differences (which you’ll see at the top of the image, the end results of the diff between the last two manifests). The bit you see in the top of the image is a diff from today’s manifest and the most recent manifest.

But, when I go to sync the file - this happens.

So, I’m not testing today… Which is nice, 'cause it’s pretty darned late in the day. This is above my pay-grade (and too long to fit in a chat window).

2 Likes

My zsync script uses /current/ so I’ll have to look what I actually grabbed…

I didn’t notice much, but I’ve only seen a partial diff (the key packages mentioned in the testing-checklist from the last ISO I zsync’d so it’ll be older than yours; 03-21)

** diff
2,3c2,3
< calamares-settings-lubuntu    1:22.04.1
< calamares-settings-ubuntu-common      1:22.04.1
---
> calamares-settings-lubuntu    1:22.04.3
> calamares-settings-ubuntu-common      1:22.04.3

It’s past time to go bird-walk the dog (for me), so I’ll look at what I’ve just grabbed & have just written to thumb-drive, then maybe respond (if I have anything; but maybe 90min+)

1 Like

No rush. I’m sleeping. Or I should be.

The diff clearly indicated differences (and I’m pretty much always current, or within an hour of a new daily dropping) but the sync indicated no differences.

1 Like

Nah my zsync’d ISO is old… /etc/apt/sources.list date is 20220321 so I have nothing I can offer sorry.

Lubuntu 22.04 LTS (Jammy Jellyfish) Daily Build shows

[ ] jammy-desktop-amd64.iso 2022-03-21 17:12 2.4G Desktop image for 64-bit PC (AMD64) computers (standard download)
[ ] jammy-desktop-amd64.iso.zsync 2022-03-21 17:12 4.9M Desktop image for 64-bit PC (AMD64) computers (zsync metafile)
[ ] jammy-desktop-amd64.list 2022-03-23 19:24 1.4K Desktop image for 64-bit PC (AMD64) computers (file listing)
[TXT] jammy-desktop-amd64.manifest 2022-03-23 19:17

where the ISO is dated 03-21 just as my download & thumb-drive stated, with lubuntu-artwork 22.04.1, however the manifest in that directory shows the ISO dated 03-23 19:17 should contain lubuntu-artwork 22.04.2…

yeah something is wrong, build issue possibly.

2 Likes

RikMills just noted (#ubuntu-flavors)

the daily ISO builds seem to be making .img files instead of .iso :confused:

Which is true, if you open the link I provided in my prior comment, you’ll find

[] jammy-desktop-amd64.img 2022-03-23 19:24 2.4G Desktop image for 64-bit PC (AMD64) computers (USB image)
[] jammy-desktop-amd64.img.zsync 2022-03-23 19:24 4.9M Desktop image for 64-bit PC (AMD64) computers (zsync metafile)

I failed to notice the .img

3 Likes

Yup! I knew it was above my pay grade. Thanks for all the research and details. Hopefully they’ll get it sorted soon.

The “zsync http://cdimage.ubuntu.com/lubuntu/daily-live/20220323.1/jammy-desktop-amd64.iso.zsync” came from the download page.

3 Likes
kgiii@kgiii-msi:~/Downloads$ zsync http://cdimage.ubuntu.com/lubuntu/daily-live/20220325/jammy-desktop-amd64.iso.zsync
failed on url http://cdimage.ubuntu.com/lubuntu/daily-live/20220325/jammy-desktop-amd64.iso.zsync
kgiii@kgiii-msi:~/Downloads$ wget -r --tries=10 http://cdimage.ubuntu.com/lubuntu/daily-live/20220325/jammy-desktop-amd64.iso
--2022-03-25 17:50:44--  http://cdimage.ubuntu.com/lubuntu/daily-live/20220325/jammy-desktop-amd64.iso
Resolving cdimage.ubuntu.com (cdimage.ubuntu.com)... 2620:2d:4000:1::17, 2001:67c:1360:8001::34, 2001:67c:1562::25, ...
Connecting to cdimage.ubuntu.com (cdimage.ubuntu.com)|2620:2d:4000:1::17|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2022-03-25 17:50:45 ERROR 404: Not Found.

I dunno what anyone else is testing. None of the download methods work here. I’ve tried numerous times today.

Those look like IPv6 woes, you could try disabling that and see if that resolves it.

4 Likes

I can give it a shot, but it worked just fine until recently.

EDIT: A device with IPv4 still has issues.

It’s too late in the evening to worry 'bout it today.

2 Likes

I’ll add I wrote two ISOs to thumb-drive today… the second time because the first was an old one.

After the zsync is done, my script shows me some diff results and that’s mostly what I look at; the manifest was the latest so nothing seemed wrong, but the ISO wasn’t downloaded it seems. A re-run of my script and now I’ve got an updated ISO

-rw-------  1 guiverc guiverc 2.5G Mar 25 16:58 jammy-desktop-amd64.iso
-rw-rw-r--  1 guiverc guiverc  54K Mar 26 03:55 jammy-desktop-amd64.manifest.old
-rw-rw-r--  1 guiverc guiverc  54K Mar 26 03:55 jammy-desktop-amd64.manifest

I have no answers sorry; but maybe confirmation that something went wrong for me too… A re-run of my zsync_jammy script fixed it for me anyway.


You’ll note a manifest.old of the same date/time from my first script run, but the iso.old doesn’t show being further up the directory listing as for whatever reason my zsync command didn’t update it… My script doesn’t have error checking :frowning:

I do wonder if this relates to the IMG/ISO changes of late that @leok & @KGIII especially will be aware of, and a little overzealous correction that led to other fixes being mandated… maybe more issues have been discovered & more work is being in which case I’d expect the issue to resolve itself tomorrow - my hope anyway!

3 Likes

I am finally able to download again. All methods appear to work, including syncing in the terminal.

Sorry that I missed a few days, though the vacation was kinda nice. :wink: But, the reasons for missing those days were above my pay grade. (As is evidenced by the magic repair that lets me download with the same configuration I’ve had the entire time.)

I even got an updated manifest, which is nice. The last one was from the 24th, and remarkably little has changed since then.

2 Likes