The VICE emulator won't launch

I’m trying to run the VICE emulator on LUBUNTU 24.04
The install runs find but the emulator just won’t launch

I ran the same install on ZORIN OS and the emulator runs just fine

So I have (which might be) a crazy idea
I was wondering if anyone might know how I would copy the VICE emulator files from ZORIN to a USB Flash drive. Then from the USB Flash drive to LUBUNTU

Files are just files, copy them.

I doubt it relates to files though, but differences due to the software stack changes that occurred over four years.

Your picture shows GTK3, which shows some age anyway; as GNOME/GTK have moved on to GTK4 some time ago. You’re showing a kernel from 18.04 (HWE) or 20.04 (GA) too.

If the emulator won’t launch, my guess is that shot is from Zorin 16.3, based on Ubuntu 20.04 but with the 22.04 kernel. Zorin is always running behind Ubuntu so I’d avoid it.

@jcmax101 if you run vice in the terminal in Lubuntu, is there any output? What specific commands are you using?


There’s an answer right here. I have a pending edit on it to change the location of the ROMs. They should be extracted to ~/.local/share/vice and not with sudo. You could use /usr/share/vice but it does require sudo.

In any case, the short answer is you:

  1. install the vice package from the Ubuntu archives
  2. get the ROMs and put them in the right place

And here’s the end result (note the upper section on the terminal is the output from running x64):


I was able to get VICE installed using the following 3 command

sudo apt update
sudo apt install snapd
sudo snap install vice-jz

I now have a working setup of VICE setup on LUBUNTU (without having to copy any Kernal/ROM files)

My problem now is I can’t use the joystick/gamepad while playing games
The mouse works fine when I run GEOS but I can’t use the mouse when I play any of the games so I need to get the joystick/gamepad working

I installed jstest-gtk (using the command “sudo apt install is jstest-gtk”)
And was able to confirm the gamepad is working

But again in VICE I can’t seem to select any Joystick or GamePad (*the drop-down don’t have the option to select joystick or gamepad)

It’s already installed by default.

sudo snap install vice-jz

I don’t recommend this, for several reasons:

  1. Snaps, like other self-contained sandboxed packaging formats, can create all sorts of issues as it relates to accessing other components of the host system. This is most likely the cause of your problem with the input devices and the solution is not trivial.
  2. This particular Snap does not appear to be developed by someone who is related to the VICE project. In fact, I didn’t even find an announcement on their mailing list about it, which strikes me as odd.
  3. Related to the previous point, since the Snap is neither been provided by the developer nor by Canonical (unlike, for example, the Firefox Snap), you cannot expect to get good support from either the developer or the typical Ubuntu resources.
  4. There is no guarantee that Snaps are free from malware, as one can expect with Debian packages. For a recent example of a malicious Snap, see here.
  5. Both the Debian package and the Snap are outdated relative to the current version of VICE (3.8), but the Snap is more outdated (3.3), meaning that it’s probably more buggy.
  6. Related to the previous point, the Snap has not been updated since 2021. I’d probably refer to it as abandonware.
  7. Worse yet, related to both the previous point as well as #3, the publisher has not updated any of their snaps since 2021.
  8. The publisher had an active presence on the Snapcraft Forum, but has not been since since 2020.
  9. On the forum, they had previously linked to a repository for the VICE Snap on BitBucket, which has since been deleted. Similarly problematic, there is a repo on GitHub for it, but it’s been archived.

So in summary, you’re using old, buggy software, which only has a single support source: someone who isn’t even around. You’re kind of on your own if you want to continue to use it.

I would love to use VICE as VICE also has a VIC-20 Emulator whereas VICE-jz does not
But getting VICE up and running is so difficult

I’ve found several messages (on different message forums) from people having problems getting VICE up and running on different version of Linux as no one seems to know where to copy the kernel rom files

I was able to get VICE to launch (by downloading basic-901226-01.bin, chargen-901225-01.bin, and kernal-901227-03.bin then placing them in my home directory) but I can’t load any games as there is no available drives
Unless there are also roms for the drives

Do you happen to know all the rom files I need (and which directory to place them in) in order to launch VICE “and” load a game ?

You should ask the VICE folks directly. I will say this: neither they nor any Linux distribution of VICE includes any game files.

To be clear, I’m not just trying to load a game file. I’m trying to load “any” rom file (whether it be a free word processor such as speed script or OS such a GEOS)
Literally “any” rom file to any drive using VICE

Ask the VICE folks, as I said.