Switching from virtual terminal (alt-ctrl-Fx) back to GUI fails

Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal

I can switch to the virtual terminals using the known alt-ctrl-Fx combination, but when I try to switch back, there is only a black screen and no reaction. The only way I have found to reactivate the GUI is rather desctructive: restarting the window manager, thereby killing all applications in the previous session.

I have not found the exact same problem anywhere, but I do find a lot of complaints about screens going black after boot or in other situations. I cannot tell whether there is any parallel. What I do know is that it is independent of the window manager, i.e. I have installed the mate desktop and the problem was exactly the same.

I did not have this problem with previous versions of lubuntu, as far as I remember.

Anybody who can give me a hint where to focus my research? Thanks in advance!

PS: Sorry for the lack of tags, I did not know which to use in this case.

If I’m understanding you correctly, have you tried holding down the left Alt key and repeatedly pressing the right arrow button until you’re back to the GUI desktop?


About yes. Not quite, I have first used alt-ctrl-F3, and then I have tried to find the GUI again, with alt-ctrl-F7 and others, but there were either virtual terminals in ASCII mode, or just blank black screens. No chance to come back to the GUI. So I have done what has usually worked in older versions, of course it could be that something has changed and I have not realized it?

If there were other ways, and there probably were, I never learned them. So, from my perspective it has been consistent for as long as I can remember. I just hold down the alt and use the arrow keys to get back. Unless someone else chimes in, that may be the only way to do so.

Actually with ctrl-alt-cursor I have moved to other screens of the window manager, not outside the GUI, but within the GUI. But I have found another interesting detail. With ctrl-alt-F6 I have moved to a terminal, and with ctrl-alt-F7 I should have come back to the GUI. But instead, I found a text screen:

[ OK ] Started LSB: automatic crash report generation.
[ OK ] Started LSB: disk temperature monitoring daemon.
[ OK ] Started Tool to automatica.sumit kernel crash signatures
[ OK ] Finished Terminate Plymouth Boot Screen
[ OK ] Finished Set console scheme

That looks to me as if it was there “under” the GUI from the beginning, but anyway, the GUI is nowhere to be found with ctrl-alt-F7 or any other function key.

So something is really not right in 20.04 (and perhaps in 18.04 already, I really don’t know in which version it has stopped working correctly).

The problem is that whenever this happens to me I must restart the whole … what do you call it? GUI, and I lose the whole session, which is inasmuch very unpractical because I have virtual machines running there. All of them are brutally swiched off. I am wondering whether I am the only one experiencing this. Something seems to go wrong with reinitializing the graphics mode or whatever.

Oh no, I’ve been a bit blocked, but now I understand!

You were absolutely right, it works well with alt-right, as you describe. I newer knew that! In older versions one could also do it with ctrl-alt-F7 or another (don’t remember), and that was the only one I have ever known, but this old method works no longer, it seems. Problem solved! So either you make an answer of it and I declare it the right one or I answer it myself, as you prefer.

And thanks!

1 Like

Glad you got it sorted. I’ve only ever known of the method I explained above.

There’s a “Solved” button for the person that opened the thread, but I’ve forgotten where that button is. It’s either near the bottom where the thread tools are or under the comment itself that solved it. Otherwise, a mod will be along and mark it as solved when they have time.


I’ll add my quick 2c (and apologies if I’m off the mark).

I used to use CtrlAltF7 to switch back to GUI, however a change occurred I believe at one point that put the GUI on CtrlAltF1

I don’t remember when that change occurred (as I’m regularly using modern & older releases, I still have to use both), but the change isn’t limited to Lubuntu/Ubuntu.

If this wasn’t your issue, sorry, and I’m glad @KGIII solved it for you :slight_smile:


This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.