Screensaver remains active at ten minutes when disabled or set to high(er) value

I’ve a laptop attached to an HDMI television, in which the laptop screen will be disabled automatically after Lubuntu has been booted up, and the HDMI television will be the main output afterwards. This setup is used to play movies full screen on the HDMI television.
After my recent upgrade from 22.04 to 23.04 I’ve noticed the following: Even when the screensaver is disabled or set to over two hundred minutes, the screensaver pops up after every 10 minutes and disables the HDMI television output. Moving the mouse or pressing a key revives the screen back, but it’s pretty annoying while watching a movie. However, when you disable the screensaver or set it to a high value right after boot-up, this does not happen! It’s like the setup value is used only once and disregarded afterwards!

1 Like

I’m a little confused by this part. Does disabling or setting the value for Blank After to a high value along with Lockscreen value (if you have it) work or not work?

I’m not sure why it would only work unless done right after login.

It’s difficult to explain, but here goes: Once you change the screensaver to disabled or another value (e.g. 200 minutes) after a (re)boot, the screensaver does not disable the HDMI television, but if you do not change any setting of the screensaver after a (re)boot of the notebook, the screensaver disables the HDMI television every 10 minutes, regardless of what’s been setup previously (although that value is still shown).

@Gavinccc: Thanks for the suggestion: That works too, but also only once. Once the notebook has been rebooted, you’ll have to enter the command again to avoid the screensaver from disabling the HDMI television.

At 12:50 02/07/2023 @Gavinccc: wrote:

this isn’t as easy as xscreensaver or indeed lxqt power settings, but comes down to openbox, or more specifically xorg. I’ve had this over the years using lxqt and lxde and its very hit and miss (on debian, arch, artix base). As a quick experiment, with your setup, can you go into qterminal and paste the following line, then hit enter. Leave it for over 10 minutes and then see if your screen is still on (and report back, thanks).

xset -dpms s off

1 Like

yea, its a one hit wonder. Right, i accidentally fixed the issue on this debian lxqt (not lubuntu, but it is debian) and it doesn’t make sense…I just changed the display manager to lightdm with the slick greeter instead. Its a simple process and means you stop using xscreensaver too. If you want instructions, just let me know. Also i found changing the windows manager to either kwin or xfwm4 also did it, but that does also mean “themes” would also need to be re-configured too amongst other things.

@Gavinccc : Lucky it could be solved somewhat easier by removing xscreensaver from autostart.

1 Like

good stuff, i take it you don’t go into standby or you’ll get an xdg error message and no lock on resume.

1 Like

@Gavinccc : Nope, standby functionality has also been deactivated, so no problems there too.
Maybe the problem could be thoroughly solved by reinstalling xscreensaver package, but as it’s working fine now, I’m not going to bother… :wink:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.