Screen tearing fix

I’d like to know if there’s any issues with enabling TearFree as outlined at https://wiki.archlinux.org/index.php/Intel_graphics#Tearing. I’m only noticing it on YouTube. OS: Lubuntu 18.04.4 LTS, GPU: integrated (HD Graphics 2000).

I don’t think I have a device that reports itself as having HD Graphics 2000, but I’ve made changes on Lubuntu 18.04 LTS on intel integrated graphics boxes using that method which, yes did help with the tearing, but on some devices videos appeared to somewhat lag on occasion that made me often wonder if the change was worth it.

I’ve never encountered a situation where it couldn’t be easily reversed though, just a case where I’m still yet to decide if it’s really that much better (it probably is, given I’ve not yet backed out that change & it’s been there for months, if not years)

1 Like

Have you tried simply turning on Compton? It will fix most such issues.

1 Like

Hello, I had the same problem with my Lenovo g550 (intel graphic card). I solved it with these codes in the terminal (these create twon nano or txt files in specific folders):

sudo nano /etc/X11/xorg.conf

Section “Device”
Identifier “Intel Graphics”
Driver “intel”
EndSection

(choose save with Ctrl+O, then exit nano with Ctrl+X)

sudo nano /etc/X11/xorg.conf.d/20-intel.conf
Section “Device”
Identifier “Intel Graphics”
Driver “intel”

Option “TearFree” “true”
EndSection

(choose save with Ctrl+O, then exit nano with Ctrl+X)

You need to conserve the spaces in the txt files. Note that you have created two nano files. After that, reboot and try the solution with this video: https://www.youtube.com/watch?v=0RvIbVmCOxg
Please take into account that this solution only work with intel graphic cards, as the source said.

Sources:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.