Screen goes gray and gets stuck after changing transparency/opacity settings after other changes

Totally new even to Linux (considering going with Lubuntu) as a whole here so sorry if this isn’t the right way to report things but here goes anyway:

CONTEXT OF BUG:

  • latest beta downloaded on April 9th 2020
  • wrote to USB and tested live session on laptop 1
  • in Session Settings, enabled and started Compton
  • in Window Effects, switched to GLX
  • logged out, logged back in
  • (at this point the desired effects of those effects have kicked in, namely no more screen tearing when scrolling in Firefox. However, there’s a tons of transparency in menus, windows, title bars etc, so I decide to try to change those)

THE BUG:

  • go back to Window Effects
  • change a few opacity numbers to 1.00 (forgot which ones exactly)
  • clicked Apply
  • screen goes gray, cursor is still movable but everything has vanished and everything is completely unresponsive
  • give it plenty of time but it’s still stuck
  • have to do a hard shutdown

RECREATING THE BUG:

  • tried the whole process several times again, doing everything as before but this time only changing one opacity number (the one for title bars)
  • same gray screen problem, requires hard shutdown
  • try changing the number only slightly rather than all the way
  • same gray screen problem, requires hard shutdown

  • at this point i think maybe it’s a problem with the laptop so i start testing on laptop 2
  • exact same bug

  • at this point i decide to install it on laptop 1 (a spare laptop) anyway, in case it’s a live session thing
  • install, then on the installed Lubuntu do all the same things
  • before I click Apply, I go Power Management and change some settings there so I don’t have to do a hard reset
  • I set the closing lid action to Suspend on AC and Shutdown on Battery
  • back to the opacity settings change, click Apply
  • same gray screen problem
  • close lid to suspend
  • open lid, but instead of waking to the login screen, it’s still stuck on the gray screen
  • switch to battery power then close lid, to shut down
  • switch computer back on again, login, the title bar opacity change I made has actually taken place at least
  • decide to change the others to my liking at the same time (menus, inactive windows - both set to 1.00)
  • click Apply
  • this time the screen doesn’t go gray, visually things stay the same (the windows, the bottom bar are still there)…but it’s unresponsive, frozen. Except the mouse can still move, but it can’t do anything because everything is unresponsive.
  • close lid to shut down again
  • switch back on, log in
  • things are the way I want now at least

So, at this point all the opacity changes I made have been made, so that’s good, I suppose I don’t have to fiddle about any more with opactiy any more. But clearly the frozen gray screens and then the frozen existing screens are problems. And they happened multiple times, on 2 different laptops and both as a live sessions and fully installed. I hope that’s enough info. I also hope you can fix it soon because with my small tweaks I really like the feel and simplicity of Lubuntu and might roll with this as my first (and maybe last?) Linux distro.

I get the same gray screen, when I change Special Effect Settings from Xrender to GLX. First time I even changed this settings.

Sorry to bother but I’ve had a similar experience, essentially I had screen tearing and saw one reason was due to the lack of compton config file with the intel settings toggled so I created this and it worked the screen tearing was gone however it messed with my opacity settings.
When I went to change them back I experienced this exact same problem and now if I change any setting everything crashes, it’s fine if I use Xrender though but if I do that the screen tearing problem persists.

What the output of sudo dmidecode -t baseboard

Bumping this because this issue still persists. Recently installed Linux on my Asus TP200s because windows 10 was too resource-intensive. I experience the exact same issues as OP and it always happens when I change settings in Window Effects/Special Effects Settings. I was experiencing screen tearing so I enabled Compton and changed my renderer to GLX (OpenGL). After I clicked apply I got a grey screen and was stuck. I couldn’t do anything however I could still move my mouse and it still responded to whatever it was hovering above. I had to hard reset by pressing the power button and waited to lo back in. Fortunately for me, the settings seemed to have saved and I noticed there was little to no screen tearing but everything was transparent. So I went into the same settings again, changed the opacity for most of the settings to 1 and clicked apply. It happened again, The screen goes grey and everything is unresponsive except for the mouse. I did a hard reset again and fortunately, the settings saved again. This doesn’t happen in any other settings (I think) but only happens in the Window Effects/Special Effects Settings. I have recorded what happens on this youtube video here. It appears that there are certain different grey screens. The ones I was experiencing earlier were more transparent than the ones in the video. Hopefully, this gets fixed in the near future. Thanks.

Update: Screen is now completely grey after changing some settings in opacity. The mouse is still moving and programs still seem to work but I just can’t see anything. Going to reinstall Lubuntu or some other distro because don’t know any other way on how to fix this issue atm.

Mine did that on older version. On recent 21.04 I don’t see the gray anymore. As I recall, the “gray” just flashed briefly. There might have been a config file that I also altered. I’ll check.

I get what you mean, it flashed for me as well. After I started up it would flash once and then the wallpaper would appear. I’m currently on version 20.10.

Since this issue seems to revolve around compton, I might point out that piece of software is mostly abandoned. I’m planning (I know, down to the last minute) on swapping us to the new “fork” (it’s actually almost a rewrite) called picom. The package is available in 20.10 and 21.04 if you want to play with it. It can use compton.conf but there are some options that are deprecated. Running it in terminal will give clear messages if there’s a problem.

2 Likes