Screen goes black when watching videos in Firefox

Hello!

When I watch long videos in Firefox (ex: videos on yewtu.be), the screen turns black while the video is playing. I would like that this doesn’t happen when I’m watching videos, while keeping the functionality of auto-locking my computer when idle while not watching videos.

Ideal solution: My computer would blank screen and lock (ask for passwork) after 10 minutes of inactivity except if I’m watching a video.

Context: This happens when I watch yoga instruction videos or meditation videos, so I cannot shake the mouse every couple minutes to prevent the computer to idle because I’m far away of the computer.

What I tried so far:

  • I read this topic and tried various combinations.
  • In Power Management Settings, I tried to enable/disable Idleness Watcher.
  • In Screensaver Preferences, in the Advanced tab, I tried to enable/disable Power Management as well as Quick Power-off in Blank Only Mode

Distributor ID: Ubuntu
Description: Ubuntu 20.10
Release: 20.10
Codename: groovy

Computer: Macbook mid-2009 (laptop)

Please note Lubuntu 20.10 is EOL as was announced back in July, having completed it’s 9 months of supported life (it upgraded to Lubuntu 21.04).

As such support isn’t available; unless you’re wanting to re-install a supported release of Lubuntu. You may still be able to release-upgrade your system, but given it’s been EOL for so long, problems can occur (and it’ll be harder again when 21.04 reaches EOL next month).

When using EOL software, you should be off-line, to protect both yourself, and users you share the network/internet with.

4 Likes

So I’ve looked at this a bit and your link that you shared actually helped me believe it or not, but this might not be a simple fix. As it was mentioned in that forum thread you linked to, this has been a problem with xscreensaver (the screen saver used by Lubuntu) and I don’t think the fix came around in time for 20.10.

I tried hunting down a bug for this and a few like this one came up:

However they suggest to me that the fix was already applied in Firefox.

This lead me to xscreensaver itself and I looked here:

I’m assuming the fix was in release 5.45 but could have actually been 6.0. I honestly don’t know what release was last available for Lubuntu 20.10. I’m guessing it was tied to whatever last kernel was made available on that release by Ubuntu.

It would be nice if someone could correct me here but I’m thinking the workaround for this issue is still the same for 20.10 release in that you’d likely have to invest in some kind of script that disables the screen saver when running Firefox and then renables it when Firefox is closed or no longer running.

My next try would be to upgrade. You might see better luck with a newer release. Someone can also correct me on this but I believe testing with the live ISO/DVD/USB can also confirm if this is still a problem. Just a suggestion.

Best of luck!

3 Likes

I tried xscreensaver 5.45 and it doesn’t fix the problem, so I expect we will have to wait for 6.02.
But I’m not holding my breath seeing as the developer doesn’t get along too well with the Debian guys.

Disabling xscreensaver and using only the power manager (lxqt) doesn’t work either.

If you don’t mind just having a blank screen (without the screen saver), you can install xfce4-power-manager and use that instead (xfce4-power-manager-settings) .
But you will have to replace the autostart;

Preferences > LXQt settings > Session Settings >
Autostart > LXQt Autostart > XScreenSaver >
Edit > Command

Change: xscreensaver -no-splash
To: xfce4-power-manager
OK
Logout/Login
And also disable the lxqt power settings (lxqt-config-powermanagement).

The desktop shortcut for xfce4-power-manager config is in
usr/share/applications/xfce4-power-manager-settings.desktop

This setup tested ok with smplayer (media player) and opera (web browser based on chromium),
but it still doesn’t work with firefox (don’t know why).

(I also tried xfce4-screensaver, but that doesn’t let itself be inhibit either, it only seems to work with xfce4-power-manager alone.)

(Lubuntu 20.04.02-3)

3 Likes

I installed the latest Lubuntu (21.10) and it seems to have solved the issue so far (I only tried it once).

I’ll report back in a few days to confirm.

1 Like

I have this exact same issue - the screen saver constantly kicks on in the middle of movies / tv shows. The only workaround I’ve come up with is to set it up so it takes like an hour and a half to turn on (would have to set it for three hours if I want to watch a Lord of the Rings movie, ie), but ideally I’d like the screen saver to run within a few minutes of me walking away from the machine.

Has anybody found a way to fix this? Seems like it’s an issue specifically with firefox?

Firefox supposedly added their fix to this. I think the issue is actually with the screen saver software itself in that it doesn’t have the patch/update it needs to understand not to turn off the screen when Firefox says to. Like mentioned above, unless you turn it off entirely and or come up with some weird script to hack the behavior of xscreensaver, it looks like the only work around (for now) is to use a different screen saver than the one shipped with Lubuntu as mentioned by humpty.

https://discourse.lubuntu.me/t/screen-goes-black-when-watching-videos-in-firefox/2936/4?u=that_random_guy

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.