Rsync stuck on new install

Running into a very strange issue with a new install of Lubuntu.
Previous install on an old Mac works great.
I built a new box, i7 CPU, 64G ram, etc.

To backup potos, music, video, etc. I use RSYNC command to a drive mounted from another computer. I’ve never had an issue.
However, with this build, the first file transfers fine the second file sends 32768 bytes and then gets stuck. It can remain stuck for minutes or even timeout.

I’ve tested with multiple drives, same results. Doesn’t matter if it is platter or SSD.
I’ve also tried increasing MTU to 9000 but that did nothing.

At this point, I’m questioning the network adapter on the mobo. This new machine is used to serve up movies via Plex and that’s been working fine which only adds to the confusion.

Suggestions?

1 Like

Get a WiFi dongle and see if your suspicion is right. Broken hardware is the most likely cause of what you’re describing. I use rsync on the daily over the network and have no issues.

Tried another NIC and same result. I even moved the destination computer to the same network leg, on the same gigabit switch.

It’s a very odd bug, rsync stops on the next file at exactly 32768 bytes and does nothing for upwards of a minute. Eventually it resumes, but sometimes it sits suspended longer.

For now, I’ve reverted to using rsync with -n and copy the notification of changed files to manually copy them over.

You might try filling a bug against rsync.