Rimuovere standby monitor

Salve come si rimuove lo standby del monitor ?

Ho bisogno che stia fisso e sempre acceso il browser in modalità schermo intero ( che tra l’altro no so come attivare qui [ in windows nel lanciatore dell’applicazioni all’avvio si inserisce --start-fullscreen] )

HO rimosso lo screen saver e nella finestra gestore energia tab inattività ho rimosso il flag su attiva monitor attività sistema.

Ma lo schermo va in standby lo stesso , cosa altro posso fare ?

Ciao, se ricordo bene è con il tasto f11.

Generalmente quando lo schermo diventa nero è solitamente il salvaschermo, non le opzioni di risparmio energia.

f11 se lo controlli ma vorrei partisse in modalità schermo intero

Quale comando inserisci in Linux e non funziona a schermo intero?

Automatic stand-by mode of the monitor can be avoided by the command
xset -dpms.

Alas, this command has to be given after each reboot. Hence it should be written into an autostart file.

wich kind of file ,bash file ?

Yes, it’s a bash file.

I have made a new file named ‘startpc.sh’ by the command
touch startpc.sh

Open it by
featherpad startpc.sh

Now you can write into this file
xset -dpms

Save the file and close featherpad.

Next you have to execute the command
chmod +x startpc.sh

Last step is to make it an autostart file by
applications menu → preferences → LXQt settings → LXQt configuration center → session settings → autostart → add
In the pop-up window you can choose an arbitrary name, for instance ‘Autostartbatch’. In the line for the command you have to search the file ‘startpc.sh’. Click on OK.

That’s all. :slightly_smiling_face:


I create the bash and if i click and start on terminal it work fine , but it doesn’t start on s.o. start :

Immagine 2024-06-13 161557

For clarification only:

  • I am not sure what ‘s.o. start’ means.
    Is it the booting of the operating system?
  • You have quoted ‘chmod +x’ only. In your case the entire command is
    chmod +x rimuovi_standby_monitor_bash.sh
  • The picture seems to be a screenshot from the above mentioned pop-up window.
    Why do you have posted it?

Addendum: Please tell us the version number of your Lubuntu release. Perhaps I can execute the whole procedure in VirtualBox.

yes the booting of operating suystem.

no i quoted all (there is a row to expand)

the picture show the prompt to answer if is correct

I see. Yes, it looks fine.

After clicking the OK button the file should be listed as follows (done on 22.04 LTS in VirtualBox)

After a reboot it should work (with the original system settings).

You mentioned a second problem in your first post, namely to start Firefox in fullscreen mode. For that an add-on has to be installed in Firefox.
To do this, open Firefox → Tools → Add-ons and Themes. Here you can search with the keyword ‘fullscreen’. Several add-ons get listed. Choose one that you find suitable and add it to Firefox.

The command is listed but doesn’t work , monitor goes to standby

i have chromium on startup but i don’t see opening terminal to launch the command

Let us see whether the autostart function works by adding a line to the file for testing purposes only.

Please open it by
featherpad rimuovi_standby_monitor_bash.sh

Add the following new line temporarily

Save and close featherpad. Then reboot.
Does featherpad open thereafter?

It works ,is the monitor that goes into stand by :man_facepalming:
Do you know how set chromium on fullscreen on startup ?

What is the browser? If it is chromium, what error does it give if you do chromium --start-fullscreen?

1 Like

I have found a solution for that:

  • make a desktop icon for chromium by a right click on its starter in the application menu
    → add to desktop
  • right click on this desktop icon
    → open with featherpad
  • scroll down to the first line starting with Exec=
  • add at the end of this line --start-fullscreen [thanks to @Roberalz :slightly_smiling_face:]:
  • save the modified file, close featherpad

[Added:] Now chromium will open in fullscreen mode when started with this desktop icon.

[Added:] To make it autostart fullscreen, add the command
/snap/bin/chromium --start-fullscreen
to a new line in the existing file rimuovi_standby_monitor_bash.sh.

I have tried this on 22.04 LTS in VirtualBox.


Now back to the main problem.
According to your first post, you did some changes in respect to the screensaver. Are you sure to have made them all undone?

[Added:] For instance, disabling the screen saver as autostart causes that the command xset -dpms doesn’t work. In your first post you wrote having removed the screensaver. Hence the monitor still will go to stand-by.
The right action would be to have the screensaver installed and autostarted but configured as disabled.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.