Reviving Thinkpad x31 problems with messed up screen

I have 2 IBM Thinkpad x31s that I’m trying to revive. I can get Lubuntu 18.04.4 32 bit installed and it works fine until I do updates. I think it may be a problem with the graphic card drivers. The screen is all garbled and unreadable. The graphics card is an ATI Radeon Mobility.

Providing a picture (or link to picture) for what you’re seeing may help, as would more specific details on your hardware.

Personally I use
sudo lshw -C video
to list hardware of class video. My IBM Thinkpad t43 reports an Mobility Radeon X300 for example, but providing a copy/paste of the results maybe helpful.

Which install media did you use? What I’m really asking here is if you’re using the GA (general) kernel or the HWE (hardware enablement) kernel, which can be changed post-install, but the default is selected by the ISO/install media you use. The t43 I’m using as reference runs the GA kernel thus uses the 4.15 kernel.

Thanks for the reply.
Well, I can’t take a picture right now because I did a reinstall and I haven’t done the upgrades. I installed from DVD. I just let it install.
I’m not good with the terminal but I got this

*-display
description: VGA compatible controller
product: RV100/M6 [Rage/Radeon Mobility Series]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 32 bits
clock: 66MHz
capabilities: agp agp-2.0 pm vga_controller bus_master cap_list rom
configuration: driver=radeon latency=66 mingnt=8
resources: irq:11 memory:e0000000-e7ffffff ioport:3000(size=256) memory:c0100000-c010ffff memory:c0000-dffff

Thanks, but I don’t know which Lubuntu 18.04 you have on your DVD so still don’t know which kernel you are using.

Original Lubuntu 18.04 LTS (inc. alternate ISO) & 18.04.1 media used the GA or general kernel by default. All media after that (18.04.2 onwards) defaults to the HWE stack.

If you enter
uname -r
you’ll see what kernel you’re running.

If you’re using the GA kernel it’ll respond 4.15 (plus other detail I’m not interested in currently), where as it’ll respond differently for later install media (4.18 for 18.04.2 media, 5.0 for 18.04.3 media, 5.3 for 18.04.4 media - before upgrades anyway; after upgrades HWE installs currently all upgrade to 5.4)

My own example (t43) runs the GA kernel, shown via

guiverc@t43-lubu:~$   uname -r
4.15.0-112-generic

For my t43, the bit that relates to video for that machine is
product: RV370/M22 [Mobility Radeon X300]
but I’ve also used RV350 devices in testing (not your likely older RV100 for 18.04/bionic). We are both using the same kernel module (driver= bit)

I meant to ask your RAM size too (but omitted it sorry), as I only tested with boxes of 1GB or more with 18.04. A picture though would help.

I downloaded 18.04.4 from lubuntu.net/downloads. I understand that it’s supported til 2021.

No need to apologize, I probably should have included that info in my OP. I have 2 GB Ram on this machine.

uname -r returns 5.3.0-28-generic

I haven’t installed the updates yet because I’m deciding whether or not to just run it like it is and just install the programs I need. This is just an attempt to get a more modern OS on these old machines.

This is an image I found that is similar to what it looks like.

The web site you mention is neither related to Lubuntu, nor Ubuntu. Rather than asking a search engine where to download a Ubuntu flavor, I’d suggest asking ubuntu.com, as ubuntu.com is under Canonical control, so will correctly send you to an official web site.

I would ensure your image is correct (verify using checksums from the official Ubuntu web site), refer https://tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu#0

From here on, I’ll assume you have verified you are using an unaltered and legitimate Lubuntu (as you didn’t download it from the Lubuntu site).

Your kernel shows you are using the HWE (hardware enablement stack) with the Ubuntu 19.10 kernel. I would try the generic (GA) kernel which can be achieved via

sudo apt install linux-image-generic xserver-xorg

which will allow you to select before boot using the grub menu.

If that works and solves your issue (note: I’d do this days-weeks later), you may wish in due course to remove the HWE kernel stack (sudo apt remove ^linux-image-generic-hwe ^xserver-xorg-hwe) but that is optional.

If it does relate to your very old radeon card, this may help.

1 Like

Thanks for the info.

I tried sudo apt install linux-image-generic xserver-xorg got a message that it couldn’t be found.

I’m downloading an image from the site you mentioned. I’ll reply in a few days. Thanks again.

I booted to the recent disk and did uname -r and it showed the same kernel 5.3.0-28-generic. Then I restarted the computer with my installed version and ran sudo apt install linux-image-generic xserver-xorg and that was successful (turns out I had a typo in my first attempt). I rebooted and held down the shift key to get to grub. Grub only had 2 choices, the same kernel and recovery mode. After the machine booted, I did the updates and rebooted. The screen was garbled again. I rebooted and got into grub. This time their was a newer kernel and it was selected. I selected the original kernel. Everything went back to normal.

So, the updates installed a newer kernel, then tried to use it.

I think this is solved, time will tell. I learned something and I appreciate your help.

My expectation was you’d see newer HWE kernels (5.3 is EOL so you’ll get 5.4 after updates) plus the 4.15 kernels installed via the command I provided, and could be selected at grub (boot-time). I assumed it would run update-grub automatically, maybe I was wrong.

I haven’t executed such a command in years, and don’t recall what you see, but I’m interested in which kernel you are using & works. The 5.3 is EOL & no longer supported; so is it the 4.15 (it’s still supported thus getting security updates) I hoped would solve your issues.

If it’s the initial 5.3 kernel your install provided, it’ll get removed during maintenance cleanups unless you place a apt-mark hold on it, but I’m unsure which kernel you are using.

If it’s 4.15, that’s where in time, you can [optionally] remove the later HWE kernels to reduce bandwidth (ie. updates for the HWE stack you won’t use), reduce disk space (by removing HWE packages) etc… but there is no hurry for that.

Yeah, it’s using the kernel that was part of the original install.
It wasn’t removed during the update. I wanted it to boot from that kernel by default so I searched how to do it. The results I found were way to complicated for me to grasp. Then I read about grub-customizer (I think that’s the name). It’s not in the official repositories but I managed to get it installed by adding a separate repository. It has a gui that is supposed to edit grub. I used it and it seemed to work. I checked in grub at boot and everything looked good but every time I booted, it would boot to the new kernel. So I found out that I could just remove that kernel with Synaptic, which I did. Everything works the way I want now.

I’ve been using Linux now for around 15 years but I’ve always used OSes that are gui centric, like Simply Mepis and PCLinuxOS (which I use on my main machine now) so I never needed to learn the terminal. I would’ve liked to use PCLinuxOS LXDE on this machine but they dropped 32 bit many years ago. PCLinuxOS doesn’t include kernel updates in their regular updates. Kernel updates need to be done by the user.

1 Like

This issue (or a like issue) has been reported at

I booted the recent Lubuntu 18.04.5 ISO on my IBM Thinkpad r50p and I get what you describe I think, plus somewhat what is shown in picture at UF.

I’ll do some testing… (likely file a bug), but I’m convinced the issue can be resolved by using the GA kernel stack instead of HWE.

I mustn’t have used the r50p in the 18.04.5 cycle of testing (or I’d have known about the issue; my installed system uses an older stack), but I recall using it a number of times in the 18.04.4 cycle, which fits what was mentioned in the UF post too (ie. 18.04.4 installs fine as was tested pre-release, but with updates issues; I didn’t use r50p to test 18.04.5 or later HWE stack & upgrades I believe, and my used installs use older/GA stacks)

I don’t have this issue on the t43 I do use regularly in testing, but it’s a newer pentium M (that doesn’t require forcepae --forcepae)

This comment mostly for my own benefit, I’ll start collecting these as I’ve replied to numerous…

Another that I believe is linked

I’m having trouble reporting the bug on my r50p, yes it has the same issue, but appears unstable and crashes the moment ethernet appears to have decent outgoing traffic (ubuntu-bug is performed); it’s fine on 18.04.4/5.3 or using GA/4.15 kernel), and whilst I can get further in the process using wifi, it still locks up (not even SysRq key reboot).

I’ll get there, or may end up switching to T42p myself (dead USB ports otherwise I’d have used it earlier), as at least two users have reported issues on t42.

My filed bug can be found at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1891790

(I’m still trying to run apport-collect, since I was unable to file on an impacted box using ubuntu-bug)

Also note, I’ve had this issue on two of my boxes

ibm thinkpad t42p (pentium m, 2gb ram, amd/ati mobility firegl t2; rv350/m10 gl)
ibm thinkpad r50p (pentium m, 1gb ram, amd/ati mobility firegl t2; rv350/m10 gl)

and I’ve noted users also report the same issue on a t41 and of course your x31

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.