Redshift problems [Solved]

Just installed the minimal version of the new release and all went great.

The only problem I encountered was getting the default version of Redshift to work no matter what I tried and even went to the official Lubuntu manual.

I finally just remove the non working default version of Redshift and installed a version using the terminal and it works.

The default version of Redshift appeared to be a Redshift QT version.
The version I installed using the terminal appeared to be a Redshift GTK version.
The Redshift GTK version installed and worked OOTB so mission accomplished and all is well.

Lubuntu 24.04 LTS minimal version I installed looks good and so far works well and I do like a few of the new desktop backgrounds.

I don’t know if it’s okay to post in this particular Announcement thread so if not please remove or relocate my post.

Thanks to all who worked on this new release.


What did you try to do and what happened that led you to believe you couldn’t get Redshift to work?

What I did was try and change my color temperature from 6500 daytime to 4500 daytime using the redshift-qt -t 4500:4500 in the session start up.

Now I’m having problems with the Redshift GTK version I’ve installed it’s turning itself on and off.

I believe this may be a compatibility problem between QT and GTK seems I read somewhere where the two are incompatible.

I will remove the Redshift GTK version I installed and reinstall the Redshift QT version and give it another look at.

I’m almost certain the problem is because of something I’m not doing correctly.

I appreciate your reply and the moving of my post.

I may have been outspoken in my earlier post and so my apologies to the forum.


1 Like

Probably not good to use them together. The GTK interface brings in a bunch of other dependencies you don’t need, too.

What was wrong with your startup command?

1 Like

I’m really uncertain what was causing a problem as I did do what I read in the official Lubuntu manual that is featured on the desktop.

I’ve removed the GTK version of Redshift and reinstalled QT version of Redshift.

I entered the redshift-qt -t 4500:4500 in the session start up box and rebooted my computer and all is working as it should.

Is there a way to check and remove any of the leftover GTK dependencies.

sudo apt autoremove


Okay I did some cleaning and other searching for leftovers and I believe I’m good.

I used this command.

 dpkg --list | grep <package name>

I appreciate your help and replies.
I’m old and impatient sometimes and get in a hurry causes problems sometimes.

Thanks again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.