Quicklaunch 22.04.3 problems

I just installed 22.04.3 into Virtualbox guest on Win11 Pro. Win11, VBox, and 22.04.3 all fully patched.

I wanted to put Firefox icon into quicklaunch, was not able to drag-n-drop from menu tree directly into quicklaunch. I could drag-n-drop to desktop, then drag-n-drop from desktop into quicklaunch. This works as long as I don’t delete desktop launcher. If I delete that, quicklaunch copy is gone after reboot.

I stumbled upon using configure panel, I added a second quicklaunch widget and moved it next to the existing one. THAT 2nd quicklaunch I can drag-n-drop into directly from menu tree and it persists after reboot.

Seems there is something wrong with the quicklaunch widget as supplied by the installation? Or is this expected behavior?

I just tested this with the LIVE image for 22.04.2 and I am able to drag and drop Firefox from the panel menu to the quicklaunch section of the panel.

I then tried just now on the LIVE image for 22.04.3 and the only difference I noticed is that there is no visible action indicator that overlays on the panel when moving the icon from the panel menu to the quicklaunch area.

This gives the impression that it is not actually letting drag-n-drop but I literally just dragged the icon to quicklaunch and I was successful:

Of course, this was all within the LIVE image and I haven’t tested on an actual install… does that look like what you are trying to achieve?


Thanks for looking at this. Yes this is installed not live CD.

That is what I have done in past versions, drag Firefox from the menu tree directly into that position. Doesn’t work now, I can’t find any spot that it will go into.

So, I have to first drag Firefox from menu tree to the desktop. (And Trust this executable.) Then I drag from the desktop into that quicklaunch position and it works. It looks as yours does. EXCEPT now I have it on desktop and in quicklaunch. I don’t want it on desktop, so I delete it. Still the quicklaunch icon is there. But after reboot it is gone.

If I add widget for quicklaunch again, I can drag Firefox directly from menu tree into the 2nd quicklaunch. And it persists between reboots.

Seems like installed-with-OS quicklaunch is broken somehow?

Definitely doesn’t sound like normal behavior… although it might do some good to have others confirm the same.

I will see if I can test this in Virtualbox and try again. Very odd behavior indeed.

Just to confirm… this was a fresh install of Lubuntu?

1 Like

Yes, brand new VM created and downloaded the 22.04.3 ISO, installed from that. The only changes after that was to run the preferences-upgrade for latest updates, and to install Virtualbox guest additions. No other changes to the ‘native’ install. Hopefully others can confirm this behavior.

An update from me… I just installed 22.04.3 to a VM using Virtualbox and immediately after install after logging in, I was able to drag and drop Firefox (from panel menu) to the Quicklaunch. Again, the action indicator is not like 22.04.2 and so when I’m dragging it to the Quicklaunch space, I have no real indication that it’s doing it until I release and see the icon show up there.

I rebooted and the icon remained under Quicklaunch. I also applied updates and rebooted again and the icon stayed at the next boot as well.

The only thing I haven’t tried yet is to get GA installed and test that out but it seems to be working for me like this… not entirely sure what would be different right now.

Having trouble getting GA installed on this VM but don’t have the time to get into it just yet but that’s what I have so far…

1 Like

Thank you, that is interesting. I didn’t try the quicklauch before I enabled the guest additions. Later this week I will have time to create a new VM and I’ll try to put firefox into the quicklaunch before I do anything else.

Here’s what I did to install GA:

launch qterminal
sudo apt-get install build-essential gcc make perl dkms
insert guest additions cd image (using vbox menu Devices → )
cd /media/home/VBox_GAs_7.0.10
sudo sh ./VBoxLinuxAdditions.run

1 Like

Ok, so this is truly a weird issue but I cannot seem to reproduce this glitch now even with GA installed.

I’ve rebooted 3 different times before and with the VBox GA installed but I am still able to drag and drop from the panel menu:

I will have time end of this week to create a new VM from scratch and try to duplicate/dismiss this issue, so I’ll be back by this weekend to report my results and if I found anything special. Thank you again for confirming all seems to be perfectly well with 22.04.3, that is very helpful. Kind regards.

1 Like

Truly strange. I created a new VM and used the same live CD of 22.04.3 ISO - no install yet just live mode - and for the life of me I cannot drag and drop anything into the quicklaunch area. Meaning, the tiny space between the file manager and the show desktop function icon.

To repeat, host OS is Win11 Pro and using latest virtualbox 7.0.10. Is that same as your tests? Frustrated… But this sounds like it’s a vbox issue somehow and nothing to do with Lubuntu, which is also strange. Why this, if so.

OK, I fiddled around a bit more and was finally able to get Firefox to drag-and-drop into the quicklaunch area on the live CD. Interestingly, if I add the 2nd quicklaunch (as mentioned originally) it is super easy to drag and drop into compared to the one that comes preinstalled.

No matter, we have proved there is no Lubuntu issue here. Thank you again for all your help. Kind regards.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.