Problem using Qt Creator - does not support terminal

Installed Lubuntu 20.04.02, installed Qt Creator 4.14.0 based on Qt 5.15.2. All settings are fine, compilers/assemblers/debuggers are configured. I am creating a project with terminal support. In system settings, x-terminal-emulator is installed with the -e parameter. Lubuntu itself has the qterminal terminal, the only one. I’m trying to put together a trivial project with the ability to enter data - the build is successful:

#include <iostream>

using namespace std;

int main()
    int a = 0;
    cout << "Enter value: " << endl;
    cin >> a;
    cout << "a = " << a << endl;
    return 0;

I am trying to run a project - I get an error in the application output:

Cannot change to working directory «/home/user/Programming/build-test-Desktop_Qt_5_15_2_GCC_64bit-Debug»: file or directory not found

As I understand it, the problem is not new and I want to solve it without resorting to installing additional terminal emulators … I ask for help from the knowledgeable.

P.S. In other IDE’s, everything is compiled and run in an embedded terminal.

I launch Qt Creator through the terminal and get the output of messages to the terminal when I run my program:

user@vb:~$ qtcreator
Properties constructor called
TRANSLATIONS_DIR: Loading translation file "qterminal_ru_RU.qm" from dir /usr/share/qterminal/translations
load success: true
Icon theme "elementary" not found.
QDir::exists: Empty or null file name
QDir::exists: Empty or null file name
Canot open file "/home/user/.config/"
Trying to load translation file from dir "/usr/share/Lubuntu"
Trying to load translation file from dir "/usr/local/share"
Trying to load translation file from dir "/usr/share"
Trying to load translation file from dir "/var/lib/snapd/desktop"
Trying to load translation file from dir "/usr/share/qtermwidget5/translations"
default KB_LAYOUT_DIR:  "/usr/share/qtermwidget5/kb-layouts"
Shell program: "/opt/Qt/Tools/QtCreator/bin/../libexec/qtcreator/qtcreator_process_stub run /tmp/QtCreator.ZPtjNF/stub-socket Для закрытия данного окна нажмите <ВВОД>... /home/user/Programming/build-test-Desktop_Qt_5_15_2_GCC_64bit-Debug /tmp/QtCreator.kcxFmh 1130 /home/user/Programming/build-test-Desktop_Qt_5_15_2_GCC_64bit-Debug/test"
("/opt/Qt/Tools/QtCreator/bin/../libexec/qtcreator/qtcreator_process_stub", "run", "/tmp/QtCreator.ZPtjNF/stub-socket", "Для", "закрытия", "данного", "окна", "нажмите", "<ВВОД>...", "/home/user/Programming/build-test-Desktop_Qt_5_15_2_GCC_64bit-Debug", "/tmp/QtCreator.kcxFmh", "1130", "/home/user/Programming/build-test-Desktop_Qt_5_15_2_GCC_64bit-Debug/test")
Invalid run control state transition from  "RunControlState::Starting"  to  "RunControlState::Stopped"
Properties destructor called

No clue. I’d suggest checking with the Qt folks.

Yes… I have already reached out to the Qt forum and from GitHub with the creators of QTerminal, but the problem is still not solved.

Yes, and as they pointed out on the forum, there is still an open bug in Qt for this issue, which affects terminals beyond just QTerminal. That said, the issue is on their end and you would need to deal with them to resolve it. Maybe comment on the bug or open a new one rather than using a forum, as you’re more likely to get to actual developers that way.

Do you think developers should create a bug report?

Yes, I think the Qt developers should create a bug report. Not LXQt developers or Lubuntu developers, since the issue isn’t specific to either.

I created a bug report, I will wait for an answer.

Strange, but why is it run in xterm then?

We’re not Qt developers, so you should ask them.


Please do not close the topic for now. I will wait for a response from the developers, I will write the result here.

It will close automatically under this subject given a certain amount of time. Since this really is offtopic, I’ll move it there.

As far as I can see the version in the focal repository of qtcreator is 4.11.0-2build2 and you are using 4.14.0.

Lubuntu 21.04 contains at the moment version 4.14.0-4.

All the same, the problem was in the QTerminal. Here and here. We will wait for a decision.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.