Printer issues, does not print the full page

I installed Lubuntu 19.04 a few days ago. Everything works but the printer. It prints only half to 3 quarter of the first page. Not the top part, nor the bottom part, nor the following pages. I am not sure if this is a Lubuntu or printer issue. The printer is an HP 2632 all in one printer. Does anyone have an idea?

How did you set it up? Does it do it this way in every application? Don’t those all in ones have a web server? Have you tried connecting to it and printing from that (that should be a direct connection; the OS isn’t involved)?

Thanks for your reply.
I installed Lubuntu OS while the printer was connected to the laptop. The driver for the printer was already installed when i wanted to install the printer driver.
Laptop and printer connected directly through an USB cable. Today I connected the printer to a desktop which is running on Zorin 9. The printer worked perfectly with the same files I wanted to print initially from the laptop.
Before I installed Lubuntu the laptop was running on Linux Mint. But I had a few problems with it, that’s why I installed Lubuntu. One problem was printer issues. It printed files properly only in PDF format. When I wanted to print directly from Libre office it did print, but only very small. An A4 document became the size of a till receipt. Other issues were that the laptop was very slow, hence I installed Lubuntu. It’s much faster now but the printer issue persists.
I just tried to print a file from Libre office. Nothing happened initially. The printer was off, I started it to get a print out and nothing happened. I shut the laptop down and when it restarted the printer started to print. The page was printed completely. Would that be an USB port issue?

One way to find out: try a different USB port.

Thanks for your help but that didn’t fix it,

If changing the port didn’t make a difference, then it’s likely not a port issue. Did you try swapping out the cable? That way you eliminate the likelihood of a hardware issue (although the printer could be malfunctioning).

Yes i tried that, it made no difference.

Ok, let’s dig into the software then. What does lpstat -t tell you?

see if it is set to a4, in my case it was in another default value and you tell us if it was corrected to keep looking